Authentification Samba

Résolu/Fermé
stena83 - 9 févr. 2005 à 09:41
 bourlaye - 16 janv. 2009 à 22:34
Bonjour, j'ai encore des problèmes avec Samba

Lorsque je veux accéder à un dossier partager sous XP, il me demande un mot de passe, mais je ne peux choisir le login, il me force a utiliser le compte invité, comment contrer cela???

merci

17 réponses

jipicy
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 897
9 févr. 2005 à 10:24
Re-

Donc avec un "smb.conf" dans ce genre chez moi (client W2K), "Security = share" ben le dossier "public" est accessible sans "authentification" alors que le dossier "partage" (avec la directive "valid user") n'est accessible qu'après authentification (login + password).
[global]
        workgroup = MON_RESEAU
        server string = Samba Server %v
        #map to guest = Bad User
        log file = /var/log/samba/log.%m
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        dns proxy = No
        #write list = @adm, root
        #printer admin = @adm
        security = share
        read only = No
        create mask = 0700
        guest ok = Yes
        hosts allow = 192.168.10.0/255.255.255.0
#       printable = Yes
        available = Yes

#[homes]
#       comment = Home Directories

[printers]
        comment = All Printers
        path = /var/spool/samba
        read only = Yes
        print command = lpr-cups -P %p -o raw %s -r   # using client side printer drivers.
        browseable = No

[public]
        comment = Répertoire partagé sur Mandrake
        path = /home/jp/partage
        browseable = Yes

[Partage]
        comment = Nouveau répertoire partagé
        path = /home/jp/partage
        browseable = Yes
#       read only = No
        valid users = jp
;-))
3
jipicy
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 897
9 févr. 2005 à 09:54
Salut,

Il faut que tes utilisateurs XP aient aussi un compte déclaré sous Samba (smbpasswd -a nom_user) et définir la directive "Security" à "user" comme dans cet exemple :
http://www.commentcamarche.net/forum/affich-1294108-Authentification-Samba
En espèrant avoir bien compris ton dilemme ;-)
1
Voila mon fichier qui est trés ressemblant au tien
Seulement je ne peux choisir mon login, XP m'ouvre la boite de dialogue avec un login que je ne peux changer.

# Configuration générale de Samba
[GLOBAL]
# Nom du groupe de travail
workgroup = egroup

# Nom qui sera vu dans le voisinage Réseaux
server string=La bete

# Accés au serveur en tant qu'utilisateur nobody
guest account = nobody

# Partage en accés libre
# permet d'autoriser certaine IP
#Hosts allow = 192.168.

# Accè mutli-utilisateur
share modes = yes

# Cryptage de mot de passe
encrypt passwords = yes

# Fichier de mot de passe
smb passwd file = /etc/smbpasswd
# type de sécurité (Share|user|server|domain)
# share : partage aveugle, sans authentification.
# user : Samba gère les acces avec le fichier de mot de passe
# server : deleguer lauthentification du samba par le PDC
# domain : pour faire appel a un serveur de mot de passe
security = share

# Fichier de log
log file = /var/log/samba/log.%m

# Taille du fichier de log
max log size = 100

# Liste d'option pour affiner Samba
# TCP_NODELAY : permet un accés plus rapide
# Taille du buffer en émission et réception : SO_RCVBUF=8192 SO_SNDBUF=8192
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

# permet d'activer la fonction de résolution de noms NetBios
dns proxy = no

# autorise les mot de passe null
null passwords = yes

# Utilisateur invalide
invalid users = root

#revalidate = yes

#guest only = yes
[Commun]
comment = Fichiers de données
path= /donnees/commun
writable = yes
read only = no
browseable = yes
guest ok = yes
[SICEFAR]
comment = Démarche qualité
path = /donnees/DQ
writable = yes
read only = no
browseable = yes
public = no
guest only = no
valid users = @cefar
1
C good j'ai trouvé, en fait j'explique en mettant l'essentiel

[GLOBAL]
security=user
guest ok = yes

voila ce que j'ai changé dans mon fichier.

A+
1

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
euh ton lien renvoi vers la page actuelle, sinon jsui ok pour mettre à user, mais a ce moment il sont obligés de mettre un login et mot de passe pour n'importe quelle partage. hors j'ai deux partage:

- 1 privé réservé a certain users
- 1 public accessible par tout le monde (meme ceux sans mot de passe)

Dc si je met security a user mon pb se pose à l'envers, comment empecher qu'il m'ouvre une boite de dialogue login/pass

merci
0
jipicy
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 897
9 févr. 2005 à 10:11
0
Donc jipicy j'ai testé ton fichier,

il fonctionne mais le problème est toujours le meme,

il me force a utiliser le login \\nom_serveur\invité
0
jipicy
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 897
9 févr. 2005 à 10:58
Là je vois pas :-(
Essaie de commenter un maximum de directives et de laisser que les primordiales dans un premier temps, afin d'avoir un accès à tes dossrs puis de décommenter au fur et à mesure.

[SICEFAR]
comment = Démarche qualité
path = /donnees/DQ
#writable = yes
#read only = no
browseable = yes
#public = no
#guest only = no
valid users = @cefar

N'oublies pas de relancer le daemon "smb" après chaque modification du fichier "smb.conf" ;-))
0
ben un grand merci quand même de ton aide.

Si il y a un moyen de forcer samba a pouvoir rentrer un login c nickel mais bon y a bien un moyen
0
Je sais qu'il existe une directive "force user" et "force group"
ya ptetre un moyen de l'utiliser
0
Bonjour,

Je viens d'installer mon serveur samba, et avec mon poste client je le voit bien dans le voisinage réseau mais il m'est impossible de pouvoir y accéder, il me met que je ne dispose pas des autorisations nécessaire.

De plus, quant je rentre le nom du domaine dans les propriétés du poste de travail, il ne le reconnait pas.

Si quelqu'un pouvait m'aider ???
0
Dans ton [GLOBAL] tu dois avoir une directive 'security'

tu met dans ton smb.conf :

security = share

envoi ton fichier smb.conf, ça sera plus facile pour t'aider
0
# Global parametres

[global]
workgroup = data7kolab

netbios name = Serveur Linux

encrypt passwords = Yes

security = user


add user script = /usr/sbin/useradd -d /dev/null -g machines -c 'Machine Account' -s /bin/false -M %u

# chemin du profil NT
logon path = \\%L\Profiles\%U

# création du montage H: (répertoire perso) pour tous les utilisateurs
logon drive = H:
logon home = \\%L\%u

# Controleur de domaine principal
domain logons = Yes
os level = 64
preferred master = Yes
domain master = Yes
admin users = root @adm
dns proxy = No



hosts allow = 192.168.2. 127.


[homes]
comment = Home Directories
read only = No
browseable = No

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon
guest ok = Yes
browseable = No

[Profiles]
path = /var/lib/samba/profiles
read only = No
guest ok = Yes
browseable = No


[public]
comment = pour la totalité
path = /mnt/serveur/public
valid users = @tonz,@adm
directory mode = 775
public = yes
create mode = 0664
writeable = yes
wide links = no
0
Je veux que se soit un controleur de domaine

J ai créer les utilsateur unix,samba et le compte de la machine donc voila.
Mais sa marche toujours pas.
0
essai avec un guest ok dans [ global]


personnellement je connais pas tout ce qui en dessous, les controleur de domaines j'ai pas encore tester.

add user script = /usr/sbin/useradd -d /dev/null -g machines -c 'Machine Account' -s /bin/false -M %u

# chemin du profil NT
logon path = \\%L\Profiles\%U

# création du montage H: (répertoire perso) pour tous les utilisateurs
logon drive = H:
logon home = \\%L\%u
0
Salut,
j'ai bien essayé avec
security=user
guest ok = yes

Mais il me demande toujours de m'identifier. Comment as-tu fait?
En user il ne force plus à se logguer en Invité mais il force à se logguer tout le temps meme dans les dossiers public.

Merci
0
il faut d'abord créer un utilisateur dans le fichier (smbpasswd -a nom de l'utilsateur) l'utilisateur doit etre authoriser dans le partage valid user = nom de l'utilisateur ok
0