Caractères accentués dans Mozilla Firefox Fr [Résolu/Fermé]

Signaler
Messages postés
28
Date d'inscription
samedi 29 janvier 2005
Statut
Membre
Dernière intervention
1 mai 2008
-
Messages postés
4
Date d'inscription
vendredi 7 mai 2010
Statut
Membre
Dernière intervention
5 février 2013
-
Bonjour les CCM Members !!!

J'utilise depuis peu Firefox, que je trouve vraiment bien. Un suel petit défaut... cur certaines pages, les caractères accentués ne s'affichent pas correctement... quelq'un peut-il me dire s'il a rencontré le même pb ? Y a t'il une solution ???? Sinon, je vais être obligé de revenir à IE 6.0 .. dommage non ?
Il a aussi du mal à afficher les balises layers dans certains cas (apparation de layers sur appel de code javascript), mais ça je peux pas trop lui jeter la pierre...

14 réponses

je viens de trouver une case magique,qui permet de solutionner les differents encodage pour la version 2.x du moins.
affichage / Encodage des caratères / Détection automatique / universel.

chez moi cela à permi un retour à un affichage correct.
12
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Merci pour votre réponse.
J'avais le même pb, cela l'a résolu immédiatement ... (détection automatique/universel)
impeccable.
Merci beaucoup
ça napa marché
exemple: irefox 2, l'encodage des caractères est à modifier dans Affichage comme indiqué précédemment.
ça napa marché
irefox 2, l'encodage des caractères est à modifier dans Affichage comme indiqué précédemment.
I love you!!!!
Vous me sauvez la vie!!!
merci
Messages postés
1326
Date d'inscription
vendredi 9 janvier 2004
Statut
Contributeur
Dernière intervention
28 octobre 2007
150
Bonjour,

essaie de changer l'encodage des caractères.
Menu Affichage > Encodage des caractères > Occidental(ISO-8859-1)

A+
Messages postés
58
Date d'inscription
mardi 17 avril 2007
Statut
Membre
Dernière intervention
16 octobre 2012
23
Avec firefox 2, l'encodage des caractères est à modifier dans Affichage comme indiqué précédemment.
J'ai constaté que l'encodage varie selon le site (ex: pour "Comment ça marche" cela donne ISO-8959-1, pour Yahoo et Google cela donne UTF-8). Cependant pour de rares pages comme le site suivant : http://www.lymphoma.ca/fr/symptom_checklist.htm ) l'encodage des accents est incorrect et ISO-8959-1 ne convient pas. Il faut changer en UTF-8. Le changement ne devient pas le défaut ou alors je n'ai pas encore compris.

J'ai eu ce problème moi aussi... A priori, c'est le module complémentaire "key scrambler" qui empêche l'affichage des accents ; Je l'ai viré et depuis ça refonctionne bien...
Moi aussi j'ai le même problème mais que avec certaine pages, je suis dans le PHP est lorsque je visite un site avec du code source il apparait des caractères bizarre...

Natsboss
http://natsboss.c.la
Messages postés
28
Date d'inscription
samedi 29 janvier 2005
Statut
Membre
Dernière intervention
1 mai 2008

Pb résolu, enfin presque, il m'a suffi de revenir au bon vieux Internet explorer...
Aucune personne n'a su me donner la solution sur Fire fox...

Oscar

THE END
pour répondre a vos questions, j'ai eu le probleme que vous dans le navigateur firefox.

solution pour firefox: aller dans (outils - options - avancé) puis dans encodage des caractères, en face de encodage par defaut selectionner (occidental ISO 8859-1)

ensuite dans votre navigateur verifier dans (affichage - encodage des caractères) que c'est correct

c'est tout et vous verrez le francais s'afficher clairement ainsi que les signes corrects
Messages postés
487
Date d'inscription
samedi 5 avril 2008
Statut
Membre
Dernière intervention
22 septembre 2019
22
Bonjour Eric,
j'ai tenté ce que tu proposes, l'encodage dans Firefox. Mais mon problème est l'encodage dans Thunderbird, outils, voilà ce que j'ai dans : options, affichage, avancés :
message entrant : occidental ISO 8859-1
message sortant : occidental ISO 8859-1
Quand c'est possible, utiliser l'encodage par défaut : la case est cochée.

Quand j'envoie un mail il est en ISO 8859-1 mais quand j'en reçois, ils sont tous en "hiéroglyphes", je suis obligée de choisir l'encodage UFT-8 et là, tout est correct
Comment ne pas être obligée de faire ces manip. à chaque lecture ?
Si tu reçois ce mail aujourd'hui 10 août 2012 alors que ta réponse date de juin 2007, que ça ne t'empêche pas de me répondre, ok ?
Merci beaucoup, Babeth.
Messages postés
35
Date d'inscription
vendredi 17 août 2007
Statut
Membre
Dernière intervention
18 mai 2010
27
J'ai posé la question à un gars de mon taf, et voilà son avis : si ça marche sur certaines pages et pas sur d'autres, en utilisant le bon encodage de caractères, c'est donc que le problème n'est pas "chez nous", mais "en face".

Vu comme ça... forcément !
Messages postés
58
Date d'inscription
mardi 17 avril 2007
Statut
Membre
Dernière intervention
16 octobre 2012
23
D'accord
Messages postés
13
Date d'inscription
samedi 25 novembre 2006
Statut
Membre
Dernière intervention
3 février 2008
12
Ca ne marche par chez moi.

Mais le problème est d'autant plus curieux que :
- mon encodage est correct à la base (je suis en universel)
- le pbl est intervenu depuis la MAJ pour 2.0
- sur certains sites, selon la police de caractère ou son épaisseur (même police, 2 épaisseurs différentes), l'une affiche les accents, l'autre met des "?" à la place
- sur CCM par ex, tout fonctionne correctement
Merci à Eric pour son vieux message qui m'a permis de résoudre mon problème :))
Bonjour,

Je fais un petit up de ce topic car j'ai moi aussi ce souci sous firefox

Config :

Windows 7
firefox 3.6

En fait, mon encodage change en fonction des pages (UTF - 8 ou de ISO-8859-1) et si je le change manuellement, dès que je charge une page, il rebascule sur le mauvais (UTF - 8 en l'occurrence) mais uniquement sur un site. Sinon, pas de soucis pour les autres sites

J'ai tenté de faire detection automatique / universel mais rien n'y fait, dès que je charge, je me retrouve avec un mauvais affichage des caractères spéciaux.

Je précise que ça me fait ça depuis peu de temps

Merci à tous ceux qui pourrons me filer un coup de main :)
bjr,

Avez-vous essayé l'encodage Occidental (Windows 12-52) ?
Bonjour,

et bien moi, j'ai le même problème sous Explorer ou Firefox dans les mêmes pages, alors c'est définitivement pas une question de navigateur.
J'ai essayé tous les codages inimaginable et niet.

: (
Messages postés
1
Date d'inscription
mardi 5 août 2008
Statut
Membre
Dernière intervention
27 décembre 2010

Bonjour, je suis dans le même cas sur l'un de mes sites. J'ai tout essayé ! changer l'encodage, mettre les symboles html, rien n'y fait. Si je change dans Firefox (AFFICHAGE ENCODAGE ... ) et que je recharge la page les signes FFFD réapparaissent. On dirait de la génération spontanée !!!
J'en viens à dire que l'erreur n'est pas chez moi... ni chez Firefox
le site en question est chez FREE
La page index.php est correcte (les é comme les $eacute; sont des é). La page index.php d'un sous-répertoire est aussi correcte mais pas les autres fichiers de ce répertoire !!!
D'autres sites aussi chez FREE n'ont pas ce problème que je viens de rencontrer juste ces jours-ci (j'ai aussi d'autres sites sur d'autres hébergeurs : ils sont pour l'instant sans problème.
J'ajoute que cela ne semble se produire que sur les texte issues de bases de données mysql (où j'ai pris la peine d'écrire avec $eacute; mais même ceux-là ne passent pas à chaque fois (ici ça marche, et là ça plante !!!).

J'en viens à penser à un problème de piratage... mais comment ??? rien n'est inscrit en plus dans mes fichiers.
Je ne peux pas décrire plus avant ce problème...

Merci si vous obtenez une réponse ou en avez unes.
Messages postés
4
Date d'inscription
vendredi 7 mai 2010
Statut
Membre
Dernière intervention
5 février 2013

https://addons.mozilla.org/fr/firefox/addon/right-encoding-76838/

Right Encoding permet de changer d'encodage par le menu contextuel.