Probleme excel - nb de cellules où >=1 <=5

Résolu/Fermé
Signaler
-
 stefff342 -
Bonjour,
J'ai un soucis avec excel...
J'ai un tableau dans lequel je dois déterminer le nombre de cellules d'une colonne dont le chiffre est compris entre 1 et 5. J'ai réussi pour une seule condition comme par exemple < 15 mais dès que j'essaie avec >= 1 et <= 5 impossible....
Merci par avance pour votre aide

5 réponses


Tu fais nb.si<5 - nb.si<1 et tu as le résultat (noter le moins)
Tout d'abord merci beaucoup pour ta réponse !
Je viens d'essayer et j'ai encore un message d'erreur
En fait je ne sais pas où intégrer ma plage (B8:B107) dans laquelle je dois rechercher les cellules comportant le chiffres compris entre 1 et 5.
Merci par avance

=NB.SI(B8:B107;"<5")-NB.SI(B8:B107;"<1")
J'ai la version excel 2003. Je ne sais pas si cela peut avoir une incidence !
Sinon j'ai réessayé, sur certaines colonnes je tombe sur le bon résultat et sur d'autres non.
Alors cette fois j'ai bien un résultat, mais j'ai toujours un écart de 1 ou 2 à chaque fois, je ne comprends vraiment pas !
Utilisateur anonyme
peut être simplement la différence entre < et <= ?
> Utilisateur anonyme
J'avais aussi essayer mais rien à faire, je tombais toujours à 1 ou 2 chiffres d'écart !
Une autre personne m'a proposé la solution suivante =Sommeprod((B8:B107<=5)*(B8:B107>=1)) qui a fonctionné !
Encore un grand merci pour m'avoir aidé si rapidement à solutionner mon problème ! Je reviendrais sur ce forum qui est vraiment super !
Merci
Messages postés
469
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
21 juin 2017
125
Bonjour
Essaye
=Sommeprod((B8:B107<=5)*(B8:B107>=1))
Super !!!!! Ca fonctionne !!!
Mille fois merci ! tu me sauves !!!
Encore un grand merci et bonne journée !!!