Utilisation d'une formule

[Résolu/Fermé]
Signaler
Messages postés
56
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
19 janvier 2017
-
Messages postés
56
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
19 janvier 2017
-
Bonjour,
J'utilise un tableau que je reproduis souvent et j'aurais voulu créer une formule pour me faciliter la vie.
j'ai un tableau avec une colonne "Prix Unitaire", à coté de ce tableau je la reproduis par rapport au nbre de fournisseurs.
j'aurai voulu que les prix unitaires du fournisseur dont le montant hors taxe est le plus petit s'affiche automatiquement dans le tableau d'origine...
J'espère avoir été assez clair
Pour aider je peux poster le tableau
Merci d'avance pour l'aide.

6 réponses

Messages postés
841
Date d'inscription
mercredi 14 mai 2008
Statut
Membre
Dernière intervention
1 juin 2021
31
tu fais ça avec exel ?
Messages postés
56
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
19 janvier 2017
1
Bonjour, oui j'utilise excel
Voici le lien

https://www.cjoint.com/?fcg0A1A427
Messages postés
202
Date d'inscription
dimanche 26 octobre 2008
Statut
Membre
Dernière intervention
9 juin 2018
156
Bonjour,

Poster votre tableau

Quel Excel utilisez vous?

A+
Messages postés
56
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
19 janvier 2017
1
Bonjour,
j'ulilise plusieurs version qui doit être comprise entre 2003 et 2008

Sinon voici mon lien avec le tableau
https://www.cjoint.com/?fcg0A1A427
Messages postés
202
Date d'inscription
dimanche 26 octobre 2008
Statut
Membre
Dernière intervention
9 juin 2018
156
Bonjour
Voici la formule qu'il faut entrer

=SI(ET(OU(I10="";I10=0);OU(L10="";L10=0);OU(O10="";O10=0));"";SI(OU(I10="";I10=0);MIN(L10;O10);SI(OU(L10="";L10=0);MIN(I10;O10);SI(OU(O10="";O10=0);MIN(I10;L10);MIN(I10;L10;O10)))))

A+
Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 899
Bonjour,

ou plus simplement :
=SI(MIN(I10;L10;O10);MIN(I10;L10;O10);"")
à recopier vers le bas
eric
Messages postés
56
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
19 janvier 2017
1
bonsoir,
J'ai essayé votre formule, mais ce n'est pas tout à fait ce que je recherche. Par rapport au montant total Ht, je souhaiterais que tout les prix unitaires correspondant à ce montant s'affiche et non les prix unitaires les plus faibles.
Si c'est le montant du fournisseurs 2, je souhaiterais que tous le prix unitaires correspondant à lui s'affiche.
J'espère avoir été plus clair
Merci de votre aide
Messages postés
202
Date d'inscription
dimanche 26 octobre 2008
Statut
Membre
Dernière intervention
9 juin 2018
156
Bonjour,

Avec votre formule, quid si l'un des fournisseurs ne répond pas et reste à zéro?..le résultat sera zéro.

A+
Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 899 >
Messages postés
202
Date d'inscription
dimanche 26 octobre 2008
Statut
Membre
Dernière intervention
9 juin 2018

Bonjour,

Exact.
Dans ce cas il est peut être plus simple de mettre un texte dans les cellules Total HT pour qu'elles ne soient pas prises en compte.
Avec par exemple : =SI(SOMME(J10:J28)=0;"absent";SOMME(J10:J28))

eric
Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 899
montant total Ht
Il aurait fallu le marquer au 1er post...

en E10 :
=DECALER(I10;0;EQUIV(MIN(J30;M30;P30);J30:P30;0)-1)

eric
Messages postés
56
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
19 janvier 2017
1
Merci pour votre solution, et votre rapidité

christophe