Formule excel : figer les cellules appelées

Résolu/Fermé
identifiant-comment Messages postés 341 Date d'inscription lundi 20 avril 2009 Statut Membre Dernière intervention 6 mars 2017 - 30 avril 2009 à 10:05
 rida - 7 oct. 2013 à 18:36
Bonjour à tous,

Le fait de mettre des dollars est-il le seul moyen de bloquer l'appel à une cellule dans une formule excel (ex.$A$1) ?

En effet, dans la formule qui suit, le moindre changement dans le fichier provoque un glissement des cellules appelées.
Cela se produit pourtant dans des formules déjà existantes, que je ne copie ni ne déplace pas.

=SI(SOMME(NON(ESTERREUR(CHERCHE(B9;[Tableau1-v0.5.xls]Onglet1!$F$19:$F$868)))*1);INDEX([Tableau1-v0.5.xls]Onglet1!$A$1:$A$868;MAX(NON(ESTERREUR(CHERCHE(B9;;[Tableau1-v0.5.xls]Onglet1!$F$19:$F$868)))*LIGNE($F$15:$F$864)));"Pas de risque associé")

j'ai surligné en gras la plage de cellule qui change à chaque modification du fichier. La plage qui devrait être indiquée est : $F$19:$F$868, comme dans le reste de la formule.

J'espère que l'un de vous pourra m'aider et je vous remerci d'avance !

2 réponses

eriiic Messages postés 24453 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 4 octobre 2022 7 137
30 avril 2009 à 10:15
Bonjour,

C'est de ma faute, met :
...LIGNE([Tableau1-v0.5.xls]Ongle­t1!$F$19:$F$868)
que tout soit bien lié sur la même feuille en cas d'insertion/suppression de lignes.
eric
5
Bonjour,
je cherche à verrouiller mes cellule pour que mes formules ne disparaissent pas!!,
comment faire????!!! merci de m'expliquer la procédures en détails
merci
0
identifiant-comment Messages postés 341 Date d'inscription lundi 20 avril 2009 Statut Membre Dernière intervention 6 mars 2017 54
30 avril 2009 à 10:17
Salut !

C'est fait, je te remercie !
0