Excel formule SI à plusieurs critères HELP!!! [Résolu/Fermé]

Signaler
-
 Serge -
Bonjour à tous,

Je débute avec excel et j'ai donc grand besoin de votre aide. Je dois faire une formule à plusieurs critères mais je n'y arrive pas.

Je dois exprimer ceci:

SI le temps de communication (A1) est < 10 donc A2 =40,si A1 compris 10 et 14 donc A2=20,si A1> ou = 15 donc A2=0

J'espère que c'est clair et que vous allez pouvoir m'aider.

Merci par avance

Jujulmn

8 réponses

Messages postés
36299
Date d'inscription
mercredi 5 novembre 2003
Statut
Modérateur
Dernière intervention
19 mai 2020
3 230
Salut

Il te faut un et logique, je ne connais pas la syntaxe exel, mais tu doit pouvoir allez dans l'aide pour verifier.

Normalement ça devrait être &.
Messages postés
72
Date d'inscription
samedi 6 décembre 2008
Statut
Membre
Dernière intervention
16 juin 2013
17
=SI(A1<10; 40; SI(A1>10; SI(A1<14;20); SI(A1>=15; 0))

a mettre dans A2

la syntaxe est SI(condition; alors valeur case; sinon valeur case)

on peux mettre plusieurs SI les un dans les autres a la place des valeurs
Messages postés
72
Date d'inscription
samedi 6 décembre 2008
Statut
Membre
Dernière intervention
16 juin 2013
17
=SI(A1<10; 40; SI(A1>10; SI(A1<14;20)); SI(A1>=15; 0))

dsl g oublié la parenthese
Merci MayeulC, je viens de faire la formule.

Mais j'ai un message d'erreur:" Vous avez tapé un nombre trop important d'arguments pour cette fonction"

???
Messages postés
13289
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
22 novembre 2019
1 215 > jujulmn
Bonsoir,
Voici la formule à mettre en A2 :
=SI(A1<10;40;SI(A1>=15;0;20))
Bonne soirée
>
Messages postés
13289
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
22 novembre 2019

Merci beaucoup ça marche, c'est super ;-)

Bonne soirée
Messages postés
13289
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
22 novembre 2019
1 215 > jujulmn
Re,
De rien :)
Bonne nuit
Messages postés
1
Date d'inscription
lundi 30 mai 2011
Statut
Membre
Dernière intervention
30 mai 2011

Bonjour, j'ai le même problème lorsque je veux modifier une fonction, on me dit que j'ai trop d'arguments pour cette fonction.
J'arive pas à trouver mon erreur.

La fonction que j'ai modifié :

=SI(ET(M6="";E6="");"";SI(ET(M6="";E6>0);1;SI(M6="";"";(M6/1,3);si(M6>50;"vc"))))

La fonction d'origine étant celle ci :

=SI(ET(M6="";E6="");"";SI(ET(M6="";E6>0);1;SI(M6="";"";(M6/1,3))))
Messages postés
13289
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
22 novembre 2019
1 215
Bonjour,

Essaie cette formule :

=SI(M6>50;"vc";SI(ET(M6="";E6="");"";SI(ET(M6="";E6>0);1;SI(M6="";"";(M6/1,3)))))

Bonne journée
Bonjour à tous

=SI(ESTNUM('Dates'!A2;'Renseignements'!A2;"")


Je cale sur cette fonction... meme probleme que les autres...
C'est pour reprendre l'énoncé de mes lignes... Je ne comprend pas pour toutes mes autres feuilles ça fonctionne très bien. Sauf pour celle là... :-s

Merci d'avance de l'aide que vous me fournirez

Kint
Messages postés
25091
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 256
Bonjour

=SI(ESTNUM('Dates'!A2);'Renseignement!A2;"")
manque la parenthèse derrière le A2 pour fermer le code ESTNUM
crdlmnt
merci de ton aide... c'était tellement bete de ma part...
ca fonctionne maintenant
Bonjour à tous,

J'ai un petit soucis au niveau de la fonction SI d'Excel.
Voici la formule que j'ai créée :
=SI(ESTVIDE(ET(H6;K6;R6;W6;AC6);0;SI(OU(I6>9;L6>9;S6>9;X6>9;AD6>9);C6*7%;0)))

Mais je recoit un message d'alerte me précisant que j'ai tapé un nombre trop grand d'argument pour cette fonction.
Je voudrait que si H6,K6,R6,W6 et AC6 est vide alors 0 sinon si I6,L6,S6,X6 et AD6 >9 alors C6*7% sinon 0.
Dans d'autre colonnes je ferais la même formule mais avec des valeurs de H6,K6,R6,W6 et AC6 différente ainsi que le pourcentage de fin.

Je n'arrive pas à trouver mon erreur.
J'espère que vous pourrez m'aider.

Merci par avance
Messages postés
25091
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 256
Bonjour
ça n'est pas tout à fait aussi court:

=SI(ET(ESTVIDE(H6);ESTVIDE(K6);ESTVIDE(R6);ESTVIDE(W6);ESTVIDE(AC6));0;SI(OU(I6>9;L6>9;S6>9;X6>9;AD6>9);C6*7%;0)))

à moins que les éléments du premier item soient des valeurs numériques auquel cas vous pouvez raccourcir:
=SI(H6+K6+R6+W6+AC6=0;0;SI(OU(I6>9;L6>9;S6>9;X6>9;AD6>9);C6*7%;0)))

crdlmnt
Bonjour, j'ai le même soucis lorsque je souhaite retrouver une valeur dans 4 feuilles différentes...
=SI(ESTNA(SI(A2="";0;RECHERCHEV(A2;'1er trimestre'!$A$4:$Q$100;2;0)));SI(A2="";0;RECHERCHEV(A2;'2eme trimestre'!$A$4:$Q$100;2;0));SI(A2="";0;RECHERCHEV(A2;'3eme trimestre'!$A$4:$Q$100;2;0));SI(A2="";0;RECHERCHEV(A2;'4eme trimestre'!$A$4:$Q$100;2;0)))
Merci pour votre aide