NB SI avec 2 critères (texte et formule) [Résolu/Fermé]

Signaler
-
Messages postés
2
Date d'inscription
lundi 20 avril 2009
Statut
Membre
Dernière intervention
21 avril 2009
-
Bonjour,

Je suis à la recherche de la formule excel à utiliser qui me permette d'extraire des données d'un tableau de données :
la formule souhaitée doit me permettre de comptabiliser le nombre d'occurences répondant à 2 critères :
tout d'abord un critère texte : "nom du Pays"
ensuite un critère avec une formule de type "nb de logements >0"

j'avais initialement mis une formule NB SI, à savoir :
=NB.SI(num!A2:AB223;"Pays du Centre")

mais le souci c'est que le résultat intègre des lignes où le résultat était =0

d'où mon souhait de faire une formule avec 2 critères.

merci par avance.

jéjé

4 réponses

Messages postés
191
Date d'inscription
lundi 1 décembre 2008
Statut
Membre
Dernière intervention
13 août 2015
96
Bonjour,

essaie :
=SOMMEPROD((A1:A223="Pays du Centre")*(B1:B223<>0))

Test dans la colonne A pour le pays du centre
test en colonne B pour différent de 0

A +
7
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57581 internautes nous ont dit merci ce mois-ci

merci beaucoup. La fonction proposée fonctionne nickel !!!
Par contre ayant enregisté ma question en tant qu "anonyme" (il me semble), savez vous comment faut il faire pour indiquer que le problème est résolu ? Merci de vos éclairages.


par ailleurs, si je peux me permettre de solliciter votre connaissance expert d'excel, je me demandais si je pouvais obtenir une formule qui permette de trouver une donnée à partir de 3 colonnes distinctes :
le nombre de communes (colonne A) appartenant à un "Pays" déterminé (colonne B) et dont le "Total logements" est <>0 (colonne C)

le résultat doit me permettre de sortir le nombre de communes appartenant à un Pays et disposant de logements.

j'ai essayé de remodifier votre formule dans l'esprit afin de l'adapter mais sans succès.

cordialement.


jéjé
Messages postés
191
Date d'inscription
lundi 1 décembre 2008
Statut
Membre
Dernière intervention
13 août 2015
96
salut,

pour mettre en résolu, il faut demander au modérateur (icône panneau Attention je crois).

pour le test sur 3 valeurs c'est la même formule
=SOMMEPROD((test1)*(test2)*(test3)...)

le test peut être comme précédemment :(A1:A223="Pays du Centre") ou (B1:B223<>0)
si tu veux faire la somme d'une colonne selon 2 tests la formule deviendrait
=SOMMEPROD((A1:A223="Pays du Centre")*(B1:B223<>0)*(C1:C223)) ==> somme des valeurs de la plage C.

tu peux t'amuser un bon moment avec cette formule...
Messages postés
2
Date d'inscription
lundi 20 avril 2009
Statut
Membre
Dernière intervention
21 avril 2009

merci
j'ai essayé avec ta formule que j'avais déjà essayé :
=SOMMEPROD((Pays="Pays du centre")*(TOTAL_LOGEMENTS<>0))*(F2:F217)

... mais cela n'a pas donné de résultats satisfaisant : #VALEUR!

je pense que cela vient du fait que mon 3ème critère correspond à une base de données en format texte, non ?
si je remplace cette colonne "nom de la commune" par une autre où les données sont numériques, par exemple le code INSEE, cela me donne un résultat, mais qui ne présente pas d'intérêt pour ce que je recherche.

ma formule doit me permettre de comptabiliser le nombre de communes du Pays X ayant des logements, sachant qu'une commune peut apparaître plusieurs fois dans la base et que je veux que la formule ne comptabilise pas ces doublons.

si vous avez d'autres pistes, je suis preneur !
Messages postés
191
Date d'inscription
lundi 1 décembre 2008
Statut
Membre
Dernière intervention
13 août 2015
96
Salut,

çà se complique ...

Pour le moment je bloque pour le faire en une seule formule.

Si une commune n'apparaît que dans un seul pays (je pense que c'est le cas) et que toutes les lignes de la communes ont au moins un logement j'ai une solution :
=SOMMEPROD((Pays="Pays du centre")*(TOTAL_LOGEMENTS<>0))*(1/NB.SI(F2:F217;F2:F217)))

Si pour la ville X, il peut y avoir des lignes à 0, ou qu'une même ville (même nom mais pas forcément même commune) existe dans 2 pays, cela ne marche pas.
J'arrive à le faire en créant une colonne intermédiaire par recherche de Pays ce qui n'est pas génial.

Je continue à cherche une idée géniale
Messages postés
191
Date d'inscription
lundi 1 décembre 2008
Statut
Membre
Dernière intervention
13 août 2015
96
Re,

encore moi avec une autre solution.

Il faut ajouter une colonne pour concaténer Le pays et la ville avec cette formule :
=SI(B2<>0;A2&"/"&C2;"") (B = logement, A = pays et C = ville)
==> vide si pas de logement et Pays du centre/Commune X si il y a des logements

le calcul devient alors
=SOMMEPROD((GAUCHE(D2:D9;NBCAR(E2))=E2)*(1/NB.SI($D$2:$D$9;D2:D9)))

Colonne D = nouvelle colonne
E2 = cellule qui contient le pays cherché (Pays du Centre par exemple)
1/Nb.si : compte des couples Pays/Ville recherchés.
Messages postés
2
Date d'inscription
lundi 20 avril 2009
Statut
Membre
Dernière intervention
21 avril 2009

Ta 2ème formule fonctionne nickel !!!

merci beaucoup.

je n'ai pas tout compris à son contenu mais je vais m'y pencher.

encore merci.