Pb d'acces internet sur os x / adresse ip

Résolu/Fermé
Signaler
-
 chris -
Bonjour,
Voila mon problème, depuis 24h et une defragmentation de mon disque sur idefrag je ne peux plus accéder a internet depuis mon macbook pro, ni par airport, ni par ethernet, sur aucun réseau que ce soit (alors que la livebox est reliée a d'autres ordinateurs de la maison et fonctionne très bien).
Par contre le signal airport est plein et me ferait penser que je suis connecté mais le fameux "vous n'etes pas connecté a internet" apparait.
Dans les préférences système dans l'onglet réseau, il est indiqué : "Airport possede une adresse ip locale et n'est peut etre pas en mesure d'acceder a internet"
Pourtant le voyant devant Airport est en vert. En dessous il y a écrit : "Adresse...assignée" est-ce que c'est non assignée, pas assignée, mal assignée? ^^
J'ai essayé l'ethernet, idem; j'ai essayé de mettre une adresse ip fixe, idem. A savoir que toutes mes applications fonctionnent correctement a part ca...
Si quelqu'un avait une idée.

Merci

6 réponses

Je pense que tu as résolu ton probème, en général il se règle de lui-même... Mais pour ceux qui tomberaient sur ce post, j'écris ici une solution qui a marché pour moi et que je veux partager, parce que ce problème-là est vraiment énervant...

Il y a quelques temps, j'ai activé le firewall intégré à OSX avec l'option "définir l'accès". Le fait est qu'il me demandait à chaque fois si je voulais accepter les connections de configd au démarrage, et que quand le problème apparaissait, il ne me le demandait pas (donc ce firewall ne fonctionne pas parfaitement...).
Donc je suis allé voir le log (pref. système->sécurité->coupe-feu->avancé->historique) et j'ai constaté qu'il avait décidé de bloquer automatiquement configd... J'ai donc rétabli l'accès à configd et ça a remarché (dans le menu du coupe-feu, cliquer sur +, faire shift+cmd+g et rentrer /usr/sbin pour accéder aux processus système.)
Voilà aussi un petit tuto un peu plus complet que j'ai trouvé sur un forum anglo-saxon:

1. Reset the com.apple.kerberos.kdc certificate as described in http://support.apple.com/kb/TS1245

2. Delete the ApplicationFirewall Preferences (located in Library/Preferences/com.apple.alf.plist)

3. Allow the system processes mdnsresponder, configd and racoon in the firewall (click "plus", then alt-shift-g to access the system processes, then write /usr/sbin, then choose the three processes, add)

4. As I run Little Snitch, I did two additional things: Allow these processes in Little Snitch as well

5. Update from Litte Snitch 2.0.1 to 2.0.4

La solution de renouveler le bail DHCP pour se refaire assigner une IP (préf sys.->airport->avancé->TCP/IP) ne marchait pas pour moi, et effectivement ça n'était pas un problème de airport, vu que quand je voulais me connecter en ethernet/en partageant la connection de mon Iphone, ça ne marchait pas non plus.

Concernant ONYX, et bien je pense que ça tient presque de la coïncidence.
Alain : "le systeme m'a alors demander si j'acceptais les connexion entrantes de 2 applications au nom farfelu, ayant repondu oui les 2 fois, tout remarche comme avant." Probablement que ces applications étaient "configd" et "mdnsresponder", et rétablir leur accès a rétabli ta connection. Je ne pense pas qu'ONYX y soit pour grand chose, des fois le firewall demande si on veut autoriser l'accès, des fois pas, mais je ne pense pas que ONYX aie une influence directe là-dessus, c'est plutôt un coup de bol... Le meilleur moyen reste de rétablir les accès manuellement, comme décrit au-dessus.


J'espère que ça aidera certains.
3
MERCI, ça fait 3h que je cherchais d'où venait le problème...
0
merci, très clair et ça marche super
0
Messages postés
10177
Date d'inscription
mercredi 24 décembre 2008
Statut
Contributeur
Dernière intervention
5 mai 2020
2 343
Bonjour,

Faites une réparation des autorisation du disque, on sait jamais.

(vois utilitaire de disue ou Onyx)
0
Merci du conseil mais c'est deja fait, j'y avais déja pensé, j'ai oublié de le préciser ^^
Ca n'a rien changé au problème.
0
> Alain
Au cas ou cela se produirait pour d'autres, je precise que j'ai résolu mon probleme en nettoyant tout avec onyx et en redemarrant, le systeme m'a alors demander si j'acceptais les connexion entrantes de 2 applications au nom farfelu, ayant repondu oui les 2 fois, tout remarche comme avant.
Mac c'est magique pour bien marcher, et magique pour ne pas savoir pourquoi ca ne marche pas ^^

Merci en tous cas a aigledu29
0
> Alain
Bonjour Alain

Il y a quelques semaines j'ai eu le même problème avec mon MacBook. J'ai téléchargé Onyx et essayé les nettoyages mais ça n'a rien donné. Pourriez-vous me dire précisement ce que vous avez fait avec Onyx?
Merci d'avance.

Caso
0

RÉINSTALLE LE LOGICIEL ou REDÉMARRE SON PROSSESUS ET DSL SI MA REPENCE EST FOSSE.
0
bonjours,

moi j'avais deja eu se pb, et je l'avais réparer av ONYX,
mais la sa ma refait le meme pb je narrive pas a me connecter et meme en nettoyant avec ONYX sa ne marche plus sa fait pas comme la derniere fois
0
Je suis très content d'avoir vu le post de Mousss, qui a eu la bonne idée de filer l'info en réponse sur plusieurs forums. J'écris car avec un MBP neuf j'ai eu exactement ce problème (10.6.8) au bout de 3 semaines d'utilisation et c'était lundi!!
Mon problème c'est que mon fichier Configd est inexistant, il y a bien Mdns... et Racoon mais pas le premier.
Ensuite je ne sais pas qu'elle version d'OS x était concernée car mes options firewall ne semblent pas être les mêmes exactement.
Effacer le com.apple.alf.plist n'a rien donne non plus. Et je n'ai pas compris le reset du Kerderos, l'outil est pour OSX server ? Moi OS x client only.
Ce week end je récupère mes CD install et je pars pour un Erase et install. Pour combien de temps? Il faudrait savoir d'où ça vient tout ça!
En attendant je suis toujours bien connecte a internet via Ethernet selon mes preferences reseaux mais rien rien rien ne se connecte a internet (firefox, safar, skype etc....). Comme bien mentionne sur ce forum TRES ENNERVANT !
Cordialement,
0
Bonjour,

Moi j'ai réglé le problème à partir d'un autre ordinateur (en l'occurrence un PC vista) branché sur le même réseau. Je suis allée dans Centre de réseau et de partage>>Voir le statut>>Propriétés>> Partage>> Puis décocher la case Autoriser d'autres utilisateurs du réseau à se connecter.....

Pour moi ça a marché.
0