Mandriva plante au démarrage

[Résolu/Fermé]
Signaler
Messages postés
99
Date d'inscription
mardi 5 février 2008
Statut
Membre
Dernière intervention
7 juillet 2010
-
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
-
Bonjour à tous,

Voilà, après qq petits soucis, j'ai réussi à installer XP et mandriva en dual boot sur une machine avec 2 disques durs en RAID 0.
BIOS avec RAID activé (SATA 0 PRIMARY activé et SATA 0 SECONDARY activé)
Partitionnement :

- 1 partition NFTS de 140 G pour XP

- 1 partition EXT 3 de 15 G avec /
- 1 partition SWAP de 4G
- 1 partition EXT3 de 60 G avec /home

Le soucis, c'est que la procédure de démarrage de mandriva s'arrête et qd je passe en mode dégradé, j'ai le message suivant :
"Vérification du système de fichiers.
fssck.ext3 : bad magic number in super-block while trying to open /dev/mapper/nvidia_bedbjbaap7
/dev/mapper/nvidia_bedbjbaap7 : the superblock could not be read or does not describe a correctext2 file system.
If the device is invalid and it really contains an ext2 filesystem (and not a swap or a ufs or something else), then the superblock is corrupt, and you might running e2fsck with an alternative superblock : e2fsck -b 8193 <device>

Une erreur a été détectée lors de la vérification du système de fichiers
Nous vous laissons dans un shell
Le système redémarrera quand vous quitterez le shell
Give Root password for maintenance or type control-D to continue :"


Et là, pas moyen de rentrer mon mot de passe Root ou quoi que ce soit d'autre et si je fais CTRL-D, le systère reboote


Merci d'avance pour votre aide car je rame !

3 réponses

Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 882
Salut,

Sans donner le mot de passe root et en tapant CTRL+D, ça passe pas ?

Sinon pour le mot de passe root, si rien n'apparait à l'écran quand tu tapes le mot de passe c'est normal, pas d'echo sous GNU/LInux, donc pas d'étoiles :-))

Donc essaie de taper ton mot de passe à l'aveugle et ensuite entre la commande préconisée dans le message d'erreur :
e2fsck -b 8193
;-))
Messages postés
99
Date d'inscription
mardi 5 février 2008
Statut
Membre
Dernière intervention
7 juillet 2010
4
Salut,

Effectivement, il n'y a pas d'écho et je sais rentrer mon mot de passe Root ;o)

Ensuite, je reste ds la console (réparation de système de fichiers) et le pblm suivant est que je ne sais pas ce que je dois rentrer exactement comme information , ce que représente exactement le <device> de la ligne de commande...

Par ailleurs, qu'est-ce que c'est que ce superbloc ?

Si je rentre uniquement la commande "efsck -b 8193", il me demande ensuite de lui préciser d'autres paramètres que j'ignore (nbre de blocs du tampon i noeuds, taille i noeur precess, taille de bloc, ...

Il devrait y avoir moyen de travailler en ligne de commande mais encore faudrait-il savoir que faire ...
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 882
Oups il était tard hier soir et j'ai oublié le device ;-[

Alors il faut donc lui donner la bonne partition en paramètre, mais avec cette histoire de RAID ça se complique...

Donc c'est soit
/dev/sdb1 (la 1ère partition de ton 2nd disque en notation normale)
soit
/dev/mapper/nvidia_xxxxxxxx (en remplaçant les "x" par la dénomination de ta partition)

Mais là je n'en ai aucune idée !?