Problème de PHP dans une balise HTML [Résolu/Fermé]

Signaler
-
 That -
Bonjour,
J'ai bout de code qui m'embête :
 <img src="<?php $key="thumbnail"; ?>" /> 


Le problème est que au lieu de lire "<?php $key="thumbnail"; ?>" ça lit "<?php $key=" . Donc l'image ne s'affiche pas...
Désolé de ne pas être plus clair, mais je sais pas trop comment dire...
Merci de vos réponses.

Cordialement

Thibaud

9 réponses


<img src="<?php echo $key; ?>" />

key doit contenir l'url de l'image...
Messages postés
3758
Date d'inscription
dimanche 8 juillet 2007
Statut
Membre
Dernière intervention
12 janvier 2014
848
Et bien je dirai logique
"<?php $key="thumbnail"; ?>"
le probleme vient de tes guillemets
Oui le problème vient des guillemets. Mais j'ai besoin de $key="thumbnail" qui est le liens de l'image
Utilisateur anonyme
ah non..


1) thumbnail cest le lien de l'image ???
2) et même si c'était le cas la syntaxe n'est pas la bonne. ce que tu veux faire ne veut rien dire
Messages postés
3758
Date d'inscription
dimanche 8 juillet 2007
Statut
Membre
Dernière intervention
12 janvier 2014
848 > Utilisateur anonyme
le 1er guillemet indique la fin de <img src="<? non?
il faut qu'il mette un \ devant
ce qui donne
<img src="<?php $key=\" thumbnail \"; ?>" />
c'est lié au PHP

.. une source = image.jpg

Quand on verra ca apparaitres quelque part on verra pour la suite

Message 1 c'est la bonne syntaxe. Si biensur elle veut afficher une image...
Messages postés
3758
Date d'inscription
dimanche 8 juillet 2007
Statut
Membre
Dernière intervention
12 janvier 2014
848
Oui tu as raison
Euh, ça marche pas
<img src="<?php $key=\" thumbnail \"; ?>" /> 
. il faut que
"<?php $key=" 
soit reconnu...
Euh, ça marche pas
<img src="<?php $key=\" thumbnail \"; ?>" /> 
. il faut que
"<?php $key=" 
soit reconnu...
Utilisateur anonyme
ca t'arrive de regarder le message 1 ?
Mais j'ai besoin du $key"thumbnail", c'est dans un thème wordpress, quand on fait un article, y a un champ personnaliser et il faut mettre un nom ( thumbnail ) et un valeur ( L'url de l'image )...
Utilisateur anonyme
et ou marque tu l'url ? car dans ton exemple il n'y a aucune url

c'est pas clair..
L'url je la mets en fessant l'article, après y a la clé qui est "thumbnail" qui fait que l'url se trouvera où y a le code
<img src="<?php $key=\" thumbnail \"; ?>" />

Excuse moi, c'est dur de raconter.
Utilisateur anonyme
c'est déja plus clair

<img src="<?php $key=\' thumbnail \'; ?>" />

apparement ca serait ca

si ca marche pas essaye ca

<img src="<?php echo $key=\' thumbnail \'; ?>" />
Utilisateur anonyme > Utilisateur anonyme
mais quand je vois ca

https://css4design.com/

il dise ce que j'ai dit en premier message...
Non, rien ne marche, bon tant pis je ferai autrement, merci d'avoir faire votre possible :-)

Cordialement

Thibaud