Formule excel 2003 calcule de résultat

Résolu/Fermé
Signaler
Messages postés
176
Date d'inscription
lundi 29 septembre 2008
Statut
Membre
Dernière intervention
21 mai 2014
-
Messages postés
176
Date d'inscription
lundi 29 septembre 2008
Statut
Membre
Dernière intervention
21 mai 2014
-
Bonjour,
Voila j'ai un fichier : http://www.cijoint.fr/cjlink.php?file=cj200903/cijzdOjoSC.xls

J'ai réussi a mettre dans les ligne 29 et 30 la lettre correspondant au plus grand des resultats mais je voudrais aussi qu'il y est le chiffre correspondant au x le plus élevé.

Par éxemple ici il faudrait C8 à la place du "C" tout seul...

Quelqu'un voi ce que je veux dire?

Merci d'avance

4 réponses

Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
242
re:

nouvelle formule à mettre en L29 et tirer vers la droite
=SI(DECALER(L8;3+EQUIV(MAX($K$12:$K$26);$K$12:$K$26;0);0)="X";L8 & MAX($K$12:$K$26);"")

évite les cellules fusionnées, c'est difficile à faire des formules apres
pourquoi fusionner 4 lignes pour avoir une certaine hauteur alors qu'il suffit d'agrandir la cellule vers le bas

si tu décides de défusionner, il faut retirer ce que j'ai mis en gras
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
176
Date d'inscription
lundi 29 septembre 2008
Statut
Membre
Dernière intervention
21 mai 2014
29
Tu est génial!!!!

merci c'est magique

Merci beaucoup beaucoup vraiment beaucoup :) je vais gagner un temps fou avec ça!!!
Messages postés
1506
Date d'inscription
mardi 19 juillet 2005
Statut
Membre
Dernière intervention
18 juin 2012
590
bonjour
Pour traiter ce genre de problèmes
Il faut utiliser la fonction RANG d'excel afin de déterminer le classement des cellules concernées
Ensuite la Fonction MIN pour obtenir la cellule ayant la + petite valeur
La fonction MAX pour obtenir la cellule ayant la + grande valeur
Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
242
Bonjour

si j'ai tout compris, voici une formule
=SI(ET(NB.SI(N12:N26;"X")>0;O29=" ");"C" & MAX(DECALER($H$12:$K$12;EQUIV("X";$N$12:$N$26;0)-1;0));" ")
Messages postés
176
Date d'inscription
lundi 29 septembre 2008
Statut
Membre
Dernière intervention
21 mai 2014
29
Bonjour,
Avec cette formule j'aurais toujours C + la sommes la plus élevée de la colonne K

Mais le truc c'est que la lettre doit pas toujours etre C...

En fait si le total (colonne K) est égale à 3 ou 4 la lettre sera A, et un X sera inscrit dans la colonne L de la ligne
Si le total (colonne K) est égale a 5 ou 6 la lettre sera B, et un X sera inscrit dans la colonne M de la ligne
Si le total (colonne K) est égale à 7 ou 8 la lettre sera C, et un X sera inscrit dans la colonne N de la ligne
Si le total (colonne K) est égale a 9, 10, 11 ou 12, la lettre sera D, et un X sera inscrit dans la colonne O de la ligne

Vous pouvez voir ca sur le classeur en ligne (les X se mette seul en fonction des total) en modifié les critère fréquence gravité ou détéction.

et ensuite en fonction des résultats exemple :
ligne 12 : total = 8
ligne 13 : total = 3
ligne 14 : total = 10
ligne 15 : total = 4
ligne 16 : total = 6
ligne 17 : total = 5

tout en bas on doit avoir en célule O29 écrit D10 (car le score le plus haut est 10)
si le score le plus haut avait été 7 on aurait eu écrit C7 en cellule N29
si le score le plus avait été 5 on aurait eu B5 en cellule M29
et enfin si le score le plus haut avait été 4 il faudrait un A4 en cellule L29

Vous voyez ce que je veux dire???

c'est un peu galère... désolé...

Mais merci beaucoup d'avance