Activer php5 chez free

Résolu
Bonjour,

bonjour je voudrai activer le php5 chez free,

j'ai vu des tutos ou il faut mettre "php 1" dans un fichier .htaccess, mais ca ne marche pas (j'ai vérifié avec la fonction phpinfo() )

POuvez vous m'aider?

merci
Configuration: Windows Vista
Firefox 3.0.7

27 réponses

Résumé de la discussion

Activation de PHP5 sur Free via .htaccess est au cœur des échanges, les utilisateurs cherchant la bonne directive et l'encodage adéquat pour activer PHP5 sans renommer les fichiers. Des procédures variées existent selon l'hébergeur et nécessitent souvent une conversion d'encodage en ANSI, puis l'upload d'un fichier .htaccess (ou .htaccess.txt temporaire) et l'attente de l'effet côté serveur. Plusieurs exemples mentionnent des réglages propres à chaque hébergeur, notamment 1&1, Lycos ou OVH, avec des lignes comme AddType x-mapp-php5 .php ou SetEnv PHP_VER 5 pour activer PHP5. Une mise à jour indique que Free propose désormais trois versions PHP, avec PHP 4.4.3 par défaut, PHP 5.1.3 via des mappages IfDefine Free et une version bêta 5.6.8, ce qui complexifie les choix.

Bobot (l’IA à votre service)
  1. Ok.. les gens vous allez m'aimer

    10 euros pr moi chaque fois que qqun me repondra par "oui"

    Question : Votre .htaccess est-il encodé en utf-8 ?

    ...
    oui ? :)

    Convertissez en ANSI votre .htaccess avec "php 1" (sans les guillemets)
    MIRACLE !

    Et voila votre site en PHP5 sans tout renommer... (ce que j'ai fait... et pensez à cette solution 15 min apres -_- )

    Pluch ;)
    41
    1. voila 10 euros...
      merci
      0
    2. Respect ! Fallait y penser !!!
      0
    3. Merci pour l'astuce du "php 1" que je ne connaissais pas ! :-)
      0
    4. chat pot !
      0
    5. Chapeau* = je te tire mon chapeau ;)
      0
  2. bon je recommence :
    Souvent les serveurs dédiés ou mutualisés sont activés pour PHP4 Certains scripts répondent maintenant qu'au php5, il faut donc créer un fichier htaccess pour activer php5.

    Voici une liste de procédures suivant les hébergeurs que nous connaissons :

    1&1 :
    Pour activer PHP5, ajoutez à votre fichier .htaccess cette ligne :
    Citation :
    AddType x-mapp-php5 .php

    Sinon, on peut aussi nommer les fichiers PHP à exécuter en PHP5 avec
    l'extension .php5 .

    Pour l'url rewriting, ajoutez cette lignes :
    Citation :
    RewriteBase /

    Free :
    Pour activer PHP5, ajoutez à votre fichier .htaccess cette ligne :
    Citation :
    php 1

    Lycos :
    Pour activer PHP5, ajoutez à votre fichier .htaccess cette ligne :
    Citation :
    AddHandler application/x-httpd-php5 .php

    OVH :
    Pour activer PHP5, ajoutez à votre fichier .htaccess cette ligne :
    Citation :
    SetEnv PHP_VER 5

    Pour désactiver les registers globals :
    Citation :
    SetEnv REGISTER_GLOBALS 0

    Pour l'url rewriting, ajoutez cette ligne :
    Citation :
    RewriteBase /

    infomaniak :
    Pour activer les URL externes, ajoutez à votre fichier .htaccess ces lignes :
    Citation :
    php_flag "allow_url_fopen" "On"
    php_flag "allow_url_include" "On"

    Amen :
    Pour l'url rewriting, ajoutez cette ligne :
    Citation :
    RewriteBase /

    La création d'un site commence par la réflexion de son devenir...
    19
    1. Merci!!!!
      Après deux jours de bloquage complet, je viens d'apprendre qu'il fallait seulement rajouter un 5 à PHP pour 1and1. ça marche!
      0
  3. Bonsoir, idem j'ai exactement le meme soucis :x

    J'ai créé un fichier htaccess.txt avec "php 1" dedans (Sans les guillemets).

    J'ai upload sur le ftp, puis une fois envoyer je change sur le ftp par ".htaccess"

    Et la une magnifique erreur 500 : Internal Server Error quand je vais sur mon site :\

    Personne ne connait une solution ?
    2
    1. il faut ajouter un autre .htacces + .htacces + htpassword.txt dans un repertoir admin et tu suis les étapes ici
      http://www.siteduzero.com/...

      et il faut laisser le .htaccess dans la racine avec seulement PHP 1
      0
  4. Modérateur
    l'explication du départ pour free est bonne !
    il suffit de créer en local .htaccess.txt
    de le transférer
    une fois sur le serveur le renommer .htaccess
    et juste avec " php 1 " dedans ;)
    2
    1. juste un rectificatif à ce que j'ai dit plus haut, il faut mettre php 5 au lieu de "php 1" et on a plus l'erreur serveur 500
      2
      1. j'ai le même problème avec le php 5

        je suis chez free et j'ai télécharger un module de e-commerce qui fonctionne que en php5
        j'ai donc suivis les instruction trouvés sur le net qui disait de créer un fichier .htaccess a la racine du site avec php 1 comme code

        mais la seule chose que j'obtiens c'est une erreur 500
        et quand j'enlève le fichier .htaccess je me retrouve avec ça:

        Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/mnt/162/sdc/c/8/kekeetcece) in /mnt/162/sdc/c/8/kekeetcece/config/config.inc.php on line 26

        Warning: Cannot modify header information - headers already sent by (output started at /mnt/162/sdc/c/8/kekeetcece/config/config.inc.php:26) in /mnt/162/sdc/c/8/kekeetcece/classes/Tools.php on line 42

        je comprend rien
        1
        1. Bonsoir
          j'ai exactement le même PB
          J'ai créé un ficheir ".htaccess" (avec extension php, txt, php5)
          avec à l'intérieur la ligne php 1
          Aucun résultat je ne peux faire les imports de fichiers sur mon site qui nécessitent php 5 sur le serveur.

          merci de votre aide
          1
          1. Il ne faut pas mettre d'extension c'est un .htaccess et pas .htaccess.php ou je ne sais quoi
            0
        2. Bon alors j'ai essayer avec le .php5 en extension ca marche niquel
          Bon c'est chiant mais pas trop trop le choix ^^

          Pitite astuce : Vous ouvrez l'inviter de cmd, vous vous placez dans votre dossier
          cmd :
          cd wamp/www/VotreSite
          ren *.php *.php5

          Plus rapide ;)

          ++
          1
          1. C'est bon regarde ma réponse du haut ;)
            faut mettre le .htaccess en ANSI et non en UTF-8
            1
            1. Bonjour,

              j'essaie d'injecter 2 fichiers dans mon site en SPIP et il est noté qu'il faut que php5 soit activé, ce que j'ai fait en joutant un fichier '.htaccess' dans lequel j'ai écrit php 5 dedans,
              mais j'ai tjrs cette erreur :

              Fatal error: Call to undefined function: simplexml_load_file() in /mnt/102/sda/5/d/hasrouri/cdt/administration/import_cdt_choix_semaine.php on line 108

              Si quelqu'un peut m'aider cela m'arrangerai bcp

              merci d'avance

              Configuration: Windows XP / Firefox 3.5.10
              1
              1. bonjour,

                pour passer en php5 sur free, il faut bien mètre un fichier .htaccess avec en 1er ligne :
                php1

                avec Notepad++ passer votre fichier en ANSI (Encodage > convertir en ANSI)

                Upload le fichier à la racine de votre site free.

                et surtout faut attendre un petit moment avent que le serveur fasse la modification ! (moi ça ma pris environ moins de 2H à chercher comme un âne et puis je suis aller manger et à mon retour ça a marché ^^)

                ça a réglé les problèmes de PDO puisque le php5 le gère en natif.

                maintenant je n'ai plus d'erreur Could not Find driver pour mon site avec ligne $bdd = new PDO('mysql:host=sql.free.fr;dbname=monSiteFree', 'monSiteFree', 'monMdp')

                Merci pour cette aide :)
                1
                1. oups c'est php 1 (phpESPACE1) et pas php1 tout attacher comme je l'ai ci dessu
                  0
                2. Contributeur
                  Juste pour confirmer que le passage en php5 n'est pas immédiat.

                  J'ai uploadé le .htaccess à la racine de mon site perso et mes accès suivants se soldaient par un "Free Pages Personnelles: Erreur 500 - Erreur interne du serveur"

                  J'ai attendu 5-6h avant que mon .htaccess soit pris en compte et que phpinfo() daigne me retourner le bon résultat (à savoir : PHP Version 5.1.3RC4-dev)

                  Pour info, mon .htaccess (copié depuis https://www.developpez.net/forums/d1106914/php/langage/aucune-evolution-php-chez-free/#post6115050):
                  php 1
                  SetEnv PHP_VER 5
                  ##Passage register globals off
                  SetEnv REGISTER_GLOBALS 0
                  ## identifiant de session placé dans le cookie
                  SetEnv SESSION_USE_TRANS_SID 0

                  J'ai aussi testé .htaccess qui contient :
                  php 1

                  Et ça fonctionne également

                  Cordialement
                  lnj
                  0
              2. Petite mise à jour pour Free:

                Il y a maintenant 3 versions de PHP dispo :

                PHP 4.4.3 (par defaut)

                PHP 5.1.3 :
                Il faut mettre ça dans un fichier .htaccess :

                <IfDefine Free>
                php 1
                </IfDefine>


                PHP 5.6.8 (encore en version beta visiblement)
                <IfDefine Free>
                php56 1
                </IfDefine>


                Source : http://les.pages.perso.chez.free.fr/migrations/php5v6.io
                1
                1. Salut,

                  T'as essayé de mettre des .php5 comme extension de tes scripts?

                  Bonne journée
                  0
                  1. lu

                    personellement sur mon 1&1 j'ai mis cette ligne

                    AddType x-mapp-php5 .php

                    et ça marche niquel -> php 5.6 je crois de mémoire

                    est-ce que ca marche chez free... j'en sais rien

                    sinon -> google
                    0
                    1. par ce que tu as mal placé ton fichier ou mal enregistré ou mal uploadé par ce que le libellé
                      php 1
                      est bon pour free
                      La création d'un site commence par la réflexion de son devenir...
                      0
                      1. dans ce cas la regarde les autorisations
                        0
                        1. jcrois cest a peu pret tout lol :)
                          0
                          1. merci a tous j'essaye .php5!
                            0
                            1. En attendant La solution qui marche ...........................;
                              0
                              1. Oui c'est ce qu'on a tous fait, mais le "Internal Server Error" il vient d'où quand tu fais ca ? :\
                                0
                                1. Modérateur
                                  internal error = erreur du serveur ...
                                  alors si ton fichier est vraiment nickel, faut voir du côté de chez free ...
                                  0
                                2. Il viens de l'encodage UTF-8 du fichier.
                                  J'ai constaté que le fichier .htaccess en UTF-8 fait 8 octets, en ANSI il en fait 5 !
                                  0
                              • 1
                              • 2