Probleme d'affichage sur une page HTML

Résolu/Fermé
ed_013
Messages postés
12
Date d'inscription
mercredi 18 mars 2009
Statut
Membre
Dernière intervention
21 septembre 2011
- 18 mars 2009 à 18:04
ed_013
Messages postés
12
Date d'inscription
mercredi 18 mars 2009
Statut
Membre
Dernière intervention
21 septembre 2011
- 18 mars 2009 à 18:23
Bonjour,

J'ai un problème d'affichage sur une page PHP, mon affichage se fais bien sur certaine page et bug complètement sur d'autre, pourtant je fais les meme include sur toutes les pages, un exemple vaut mieux qu'un long discours

Voila l'affichage qui marche bien sur cette page

http://img27.imageshack.us/img27/1858/bonc.gif

et le code associé :
---------------------------------------------------------------------------------------------------------------------------------------------------------------
<? include 'verif_admin.php'; ?>
<? include 'connect.php'; ?>
<? include 'menu.php'; ?>



<? echo '<div class=Titre>Gestion des domaines d\'activité</div>'; ?>

<div class='Corps'>
<div class='Corps_gauche'>
<div class='Sous_titre_section'>Affichage des domaines d'activité</div>
<?
// recuperation des element de la table
$sql_select = "SELECT domaine_id, domaine_nom FROM domaine ORDER BY domaine_nom ASC";
$res_select = mysql_query($sql_select);
while ($row=mysql_fetch_array($res_select))
{
$domaine_nom_sale = $row["domaine_nom"];
$domaine_nom_nickel = html_entity_decode($domaine_nom_sale);
echo "<div class=Numero_element_section>$row[domaine_id]</div><div class=Liste_element_section>".$domaine_nom_nickel."</div>";
}
?>
</div>
<div class='Corps_droit'>

<form class="formulaire" name="formulaire" action="domaine_insertion.php" method="post">
<titre>Insertion d'un domaine d'activité</titre><br/><br/>
<div>Pour insérer un domaine d'activité qui se retrouvera dans la fiche de saisie de contact, veuillez remplir le formulaire ci-dessous.</div><br/>
<label>Nom du domaine d'activité</label><input type=text name=domaine_nom /><br/><br/>
<p class="button"></b><input type="submit" name="submit" value="Validation"/></p>
</form>

<br/>
<form class="formulaire" name="formulaire" action="domaine_modification.php" method="post">
<titre>Modification / Suppresion du domaine d'activité</titre><br/><br/>
<div>Pour modifier un domaine d’activité, veuillez relever le numéro de ce domaine présent dans la liste sur votre gauche et insérer le dans le premier champ du formulaire ci-dessous, puis entrez une nouvelle description dans le deuxième champ du formulaire afin d’effectuer la modification. Si aucune description n’est inscrite dans le deuxième champ, la valeur sera supprimée.</div><br/>
<label>Numéro du domaine à modifier</label><input type=text name=domaine_id /><br/>
<label>Nouvel intitulé</label><input type=text name=domaine_nom /><br/><br/>
<p class="button"></b><input type="submit" name="submit" value="Validation"/></p>
</form>
</div>
<div class='Corps_bas'></div>
</div>

---------------------------------------------------------------------------------------------------------------------------------------------------------------

Et voila la page qui bug et son code associé

http://img10.imageshack.us/img10/7626/mauvaisb.gif

---------------------------------------------------------------------------------------------------------------------------------------------------------------
<? include 'verif_admin.php'; ?>
<? include 'connect.php'; ?>
<? include 'menu.php'; ?>

<? echo '<div class=Titre>Gestion des utilisateurs</div>'; ?>

<div class='Corps'>
<div class='Corps_gauche'>
<div class='Sous_titre_section'>Affichage des utilisateurs</div>
<?
// recuperation des element de la table
$sql_select = "SELECT admin_id, admin_login, admin_password FROM admin ORDER BY admin_id ASC";
$res_select = mysql_query($sql_select);
while ($row=mysql_fetch_array($res_select))
{
$admin_login_sale = $row["admin_login"];
$admin_login_nickel = html_entity_decode($admin_login_sale);
$admin_password_sale = $row["admin_password"];
$admin_password_nickel = html_entity_decode($admin_password_sale);
echo "<div class=Numero_element_section>$row[admin_id]</div><div class=Liste_login_section>".$admin_login_nickel."</div><div class=Liste_password_section>".$admin_password_nickel."</div>";
}
?>
</div>
<div class='Corps_droit'>

<form class="formulaire" name="formulaire" action="domaine_insertion.php" method="post">
<titre>Insertion d'un domaine d'activité</titre><br/><br/>
<div>Pour insérer un domaine d'activité qui se retrouvera dans la fiche de saisie de contact, veuillez remplir le formulaire ci-dessous.</div><br/>
<label>Nom du domaine d'activité</label><input type=text name=domaine_nom /><br/><br/>
<p class="button"></b><input type="submit" name="submit" value="Validation"/></p>
</form>

<br/>
<form class="formulaire" name="formulaire" action="domaine_modification.php" method="post">
<titre>Modification / Suppresion du domaine d'activité</titre><br/><br/>
<div>Pour modifier un domaine d’activité, veuillez relever le numéro de ce domaine présent dans la liste sur votre gauche et insérer le dans le premier champ du formulaire ci-dessous, puis entrez une nouvelle description dans le deuxième champ du formulaire afin d’effectuer la modification. Si aucune description n’est inscrite dans le deuxième champ, la valeur sera supprimée.</div><br/>
<label>Numéro du domaine à modifier</label><input type=text name=domaine_id /><br/>
<label>Nouvel intitulé</label><input type=text name=domaine_nom /><br/><br/>
<p class="button"></b><input type="submit" name="submit" value="Validation"/></p>
</form>
</div>
<div class='Corps_bas'>
</div>
</div>
---------------------------------------------------------------------------------------------------------------------------------------------------------------

Je peux vous fournir le code des includes, mais vu que c'est les meme, je vois pas d'ou viens le soucis

Vous voyez d'ou ca peux venir ?

1 réponse

ed_013
Messages postés
12
Date d'inscription
mercredi 18 mars 2009
Statut
Membre
Dernière intervention
21 septembre 2011
1
18 mars 2009 à 18:23
J'ai un peu avancé, mais ca bug toujours,

Quand je change ma ligne
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
inclue dans mon menu.php par
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />

Les bugs s'inverse de page (le bug qui n'existait par sur la premiere apparait et disparait sur la deuxieme), c'est a m'arracher les cheveux

Quelq'un pour m'aider ?
0