Excel - Comment grouper des données?

Fermé
Signaler
-
Messages postés
16547
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2022
-
Bonjour,

soit le tableau Excel suivant

VILLE; QUARTIER; POPULATION;

PARIS; A; 3568;
LILLE; L; 5423;
LILLE; U; 4589;
PARIS; M; 5742;
LYON; I; 754;
LILLE; K; 578;

Je souhaite obtenir, sur une autre feuille excel, un tableau donnant la population par commune:

VILLE; POP;

PARIS; n;
LILLE; n;
LYON; n;

La fonction Grouper / créer un plan pourrait être une solution mais je ne dois pas changer l'ordre des enregistrements

Merci d'avance
A voir également:

4 réponses

Messages postés
55394
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
17 224
Et pourquoi ne pas utiliser l'assistant Données/Sous-total ?
Tu fais une copie du fichier, tu tries par rapport à la première colonne (Nom de ville) et tu lances le sous-total.
3
Messages postés
26403
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 184
Bonsoir
Pourquoi pas tout simplement:
si sur feuil1:Ville en colonne A; Quartier en colonne B, population en colonne C:
En feuil2:
Colonne A, Ville / Colonne B population:
En B2 la formule à tirer vers le bas:
=SOMME.SI(Feuil1!A:A;A2;Feuil1!C:C)
Crdlmnt
1
Messages postés
24273
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
7 028
Bonsoir vaucluse,

Tu sais, les TCD ne sont pas si compliqués et tout à fait adaptés à ce type de problèmatique.
Il faut y investir un peu de temps la 1ère fois mais tu as un retour sur investissement phénoménal ;-)
C'est vraiment très puissant pour qcq clics et ça vaut vraiment le coup.

Au passage merci à michel pour ce lien qui à l'air très interessant.
eric
0
Messages postés
16547
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2022
3 258
Bonjour,

Tu pourrais faire un tableau croisé dynamique...

Si te ne connais pas, regarde ces tutos sur le site incontournable de Jacques Boisgontier
http://boisgontierjacques.free.fr/
0
Messages postés
16547
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2022
3 258
Merci, Eric
0