[virtualbox] Callee RC: REGDB_E_CLASSNOTREG (0x80040154) [Résolu/Fermé]

Signaler
Messages postés
336
Date d'inscription
jeudi 21 août 2008
Statut
Membre
Dernière intervention
19 juillet 2015
-
 simopr -
Bonjour,

aprés une plantage de mon PC je l'ai forcé a s'arreter,
la pbm c qu'aprés son démarrage virtualbox ne demarre plus et windows m'affiche un message :

failed to create the virtualbox COM object?
the application will now terminate
Callee RC: REGDB_E_CLASSNOTREG (0x80040154)


pourrez vous m'aider
merci

you can ..............

4 réponses

J'ai eu ce problème sur VMBox 5.0.

1- Cliquer sur le bouton droit du Oracle VM Box,
2- Puis exécuter en tant qu'administrateur.

ça devrait résoudre ton problème ;)
7
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 56970 internautes nous ont dit merci ce mois-ci

Messages postés
336
Date d'inscription
jeudi 21 août 2008
Statut
Membre
Dernière intervention
19 juillet 2015
16
oui
merci pour votre intervention mais j'ai trouvé la solution ici :
http://vbox.innotek.de/pipermail/vbox-users/2007-January/000045.html
Messages postés
12103
Date d'inscription
jeudi 29 novembre 2007
Statut
Modérateur
Dernière intervention
30 décembre 2019
2 121
Cool !

Ravi pour toi :)
Ca marche nickel merci...
Messages postés
336
Date d'inscription
jeudi 21 août 2008
Statut
Membre
Dernière intervention
19 juillet 2015
16
pas de quoi
Salut ton lien ne fonctionne pas, j'ai le meme probleme sous linux ultimate edition 3.4, pourais tu me dire comment tu a fait stp
Messages postés
215
Date d'inscription
mardi 30 mars 2010
Statut
Membre
Dernière intervention
8 septembre 2015
192
Bonjour,

Je sais que ce post date d'il y a un moment, mais visiblement certains (dont moi-même) rencontrent encore le même problème avec VirtualBox. Mais j'apporte une solution qui a fonctionné dans mon cas !

Trouvé sur ce post (en anglais) : http://www.kirtrainford.co.uk/fix-failed-create-virtualbox-com-object-regdb_e_classnotreg-0x80040154/

Je traduis approximativement ce qui y est décrit afin de le marquer pour de bon sur ce post : il est probable que ce soit le service de machine virtuelle qui soit arrêté. Si une réinstallation complète ne fonctionne pas, ou bien si vous ne voulez pas vous embêter et faire plus court, rentrez ces 3 lignes dans votre invite de commande ("cmd", de préférence en mode administrateur) :

chdir "C:\Program Files\Oracle\VirtualBox"

pour changer rapidement de répertoire (adaptez-le si VirtualBox n'est pas localisé dans le répertoire d'installation par défaut). Ensuite :

VBoxSVC /ReRegServer

Rien ne se passe, c'est normal. Et enfin :

regsvr32 VBoxC.dll

Une fenêtre de confirmation s'affiche. Fermez le tout et redémarrez VirtualBox.

Ciaonar@peluche !
Messages postés
12103
Date d'inscription
jeudi 29 novembre 2007
Statut
Modérateur
Dernière intervention
30 décembre 2019
2 121
Salut,

Est ce que tu as essayé de le désinstaller puis le réinstaller ?