Somme avec une condition dans Excel

Résolu/Fermé
BobMorane - 5 févr. 2009 à 10:48
colas31
Messages postés
135
Date d'inscription
samedi 5 août 2006
Statut
Membre
Dernière intervention
21 décembre 2010
- 5 févr. 2009 à 16:33
Bonjour,
Mon problème est le suivant :
je dois effectuer une somme avec la condition suivante :
Si (cellule A + cellule B est > 0) ajouter 1 au résultat
mais si cellule A+cellule B = 0, ne pas ajouter 1 et donc résultat = 0

Merci

3 réponses

colas31
Messages postés
135
Date d'inscription
samedi 5 août 2006
Statut
Membre
Dernière intervention
21 décembre 2010
21
5 févr. 2009 à 10:57
Tiens formules toute faites avec 2 cellules au hazard:

=SI((B6+C6)>0;(B6+C6+1);(SI((B6+C6)=0;(B6+C6))))
0
C'est cool, ça marche
merci
0
Mike-31
Messages postés
17954
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 mai 2022
4 947
5 févr. 2009 à 11:01
Salut,

=SI(A1+B1>0;A1+B1+1; SI(A1+B1=0;A1+B1))

mais tu pourrais l'écrire plus simplement

=SI(A1+B1>0;A1+B1+1;0)

A+
0
Impec
merci
0
colas31
Messages postés
135
Date d'inscription
samedi 5 août 2006
Statut
Membre
Dernière intervention
21 décembre 2010
21
5 févr. 2009 à 11:40
Avec plaisir,
N'oublie pas de passé ton post en résolu ^^
0
Mike-31
Messages postés
17954
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 mai 2022
4 947
5 févr. 2009 à 11:46
Salut colas31,

Il ne peut pas mettre son statut en résolu, parce qu'il n'est pas membre, je vais le faire pour lui

A+
0
colas31
Messages postés
135
Date d'inscription
samedi 5 août 2006
Statut
Membre
Dernière intervention
21 décembre 2010
21 > Mike-31
Messages postés
17954
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 mai 2022

5 févr. 2009 à 11:49
Ok, j'avais pas fait attention.
Tu es modo ? et de la région toulousaine ? :p
0
Mike-31
Messages postés
17954
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 mai 2022
4 947 > colas31
Messages postés
135
Date d'inscription
samedi 5 août 2006
Statut
Membre
Dernière intervention
21 décembre 2010

5 févr. 2009 à 13:28
Re,

non non pas un modo, un simple membre, ça me suffit, de Muret.

A+
0
colas31
Messages postés
135
Date d'inscription
samedi 5 août 2006
Statut
Membre
Dernière intervention
21 décembre 2010
21 > Mike-31
Messages postés
17954
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 mai 2022

5 févr. 2009 à 16:33
D'accord, et tu peux passer un topic en résolu même si tu ne l'as pas creer.
0