Configuration Openldap sous debian

Résolu/Fermé
Signaler
Messages postés
13
Date d'inscription
mercredi 28 janvier 2009
Statut
Membre
Dernière intervention
10 février 2009
-
Messages postés
70
Date d'inscription
jeudi 30 juillet 2009
Statut
Membre
Dernière intervention
6 février 2013
-
Bonjour à toutes et à tous.

Je travaille sur une debian en virtuel (virtualbox) et je viens tout juste d'installer openldap en suivant de nombreux tutoriels. Cependant je rencontre quelques problèmes (on ne l'aurai pas remarqué me diriez vous ^_^)

Je viens de finir de paramétrer mon slapd.conf, et j'ai validé la configuration de mon annuaire avec la commande slaptest et la config est ok. J'arrete donc mon serveur LDAP pour pouvoir utiliser la commande slapindex, mais il ne veut rien entendre il me sort un:

WARNING!
Runnig as root!
There's a fair chance slapd will fail to start.
Check file permissions!


Donc voila, après de nombreuses recherches très infructueuses avec mon ami google je ne sais toujours pas quelles permissions il me faut et surtout sur quoi. Je n'ai rien trouver dans mon fichier log qui pourrait m'être utilise :(


Merci pour toute l'aide que vous pourriez m'apporter

14 réponses

Salut je viens completer la solution :

il ne faut surtout, mais surtout pas lancer "slapindex" en root !!!
Si il te met ce message c'est qu'il y a une raison !!! c'est pas un bug de version !!!!

WARNING!
Runnig as root!
There's a fair chance slapd will fail to start.
Check file permissions!


Si tu a une erreur dans ta base openldap, il va la corriger ( Jusqua la c'est bon), mais au passage vu que tu es root, les fichiers de la base Openldap vont appartenir a "root" (et c'est la l'erreur !!!).
Le deamon Openldap est lance par l'utilisateur "Openldap" et non root.

Si tu fait un "ls -l" dans le repertoire de ta base Openldap ( Chez moi c'est /var/lib/ldap/)
tu verras des fichiers ou le le proprietaire est "root" et d'autre "openldap"

Le changement de version, n'a fais que remplacer les permissions sur les fichiers !

Donc pour resoudre le probleme :

Dans /var/lib/ldap/, lance :

# chown openldap:openldap *
# ls -l (pour verifier !)

et pour lancer ton slapindex

# sudo -u openldap /usr/sbin/slapindex

et ta plus qu'a relancer le daemon slapd

# /etc/init.d/slapd start


++
Youd
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Bon globalement, si on lance des sudo -u openldap plutot que des commandes en root, slapd cause un petit plus et nous indique ce qui ne vas pas. Sinon, en root, on a un vague message qui dit d'aller voir dans syslog...
Le fait de faire des sudo m'a donc pas mal aiguillé ensuite pour résoudre mon problème (problème de droits).
Messages postés
13
Date d'inscription
mercredi 28 janvier 2009
Statut
Membre
Dernière intervention
10 février 2009
1
je m'auto répond, ca pourra servir un jour.

En effet, avec de l'aide de quelques personnes, la solution du "slapindex" a été trouvé.

Voici leurs explications:



"
Le serveur slapd se créé un utilisateur qui est normalement openldap. Pour le savoir il suffit de faire:

' ls -l /etc/ldap '



Voici ce que vous devez obtenir en faisant: ' getent passwd '

' openldap:x:110:113:OpenLDAP Server Account,,,:/var/lib/ldap:/bin/false '



Le ' /bin/false ' signifie qu'on ne peut pas utiliser ce compte pour se connecter.



et donc pour que "slapindex" fonctionne il faut faire:

' #whoami
root
#su -m openldap
$whoami
openldap
$slapindex
$exit
# '

Ne pas oublier de faire exit, il vous faut retourner sur votre propre compte pour continuer votre travail.

"
Salut! Excuse moi de te dé"ranger mais je suis en train d'essayer d'installer OpenLDAP sur une Debian 5 (Lenny) et c'est la galère, je n'y arrive pas malgré quelques tutos (et quelques connaissances en Unix)...
Pourrais tu me dire de quels tutos t'es tu servi? Merci de ton aide
Messages postés
13
Date d'inscription
mercredi 28 janvier 2009
Statut
Membre
Dernière intervention
10 février 2009
1
personne n'a une petite idée? :(
Messages postés
13
Date d'inscription
mercredi 28 janvier 2009
Statut
Membre
Dernière intervention
10 février 2009
1
Problème toujours pas résolu même après moultes expériences...

Aucune âme charitable pour me donner une piste? ^_^
Messages postés
13
Date d'inscription
mercredi 28 janvier 2009
Statut
Membre
Dernière intervention
10 février 2009
1
Je me réponds à moi même, peut être qu'un jour ma réponse pourra débloquer quelqu'un. Apparament c'est un bug de openLDAP 2.3.30-5 , il faut donc vérifier la version ( # apt-cache policy <nom-du-paquet>) et éventuellement le mettre à jours ou le réinstaller.

Personnellement je rencontre un problème avec "apt-get install slapd" car il ne me met pas la dernière version...
Messages postés
37
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
25 août 2010
25
Bonjour j'ai un problème avec mon serveur LDAP. Ensuite j'ai voulu désinstaller le daemon pour recommencer la réinstallation. mais g le message suivant qui s'affiche

E: slapd: le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 2



Pouvez vous m'aider à résoudre ce problème? c'est vraiment urgent je dois le présenter à mon prof demain. merci
tu es sous quelle distrib et comment as tu installe ton serveur LDAP ???
Messages postés
37
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
25 août 2010
25
Merci mr_youd, j'ai pu régler le problème avec l'option purge de apt-get. Seulement j'ai un autre problème. Quand je tappe la commande :
slaptest -f slapd.conf -F slapd.d
j'ai le message suivant:

bdb(dc=dess,dc=sn): unrecognized name-value pair: dn:
bdb_db_open: database "dc=dess,dc=sn" cannot be opened, err 22. Restore from backup!
backend_startup_one (type=bdb, suffix="dc=dess,dc=sn"): bi_db_open failed! (22)
slap_startup failed (test would succeed using the -u switch)

Avec l'option -u la configuration marche mais j'ai besoin de savoir pourquoi ça marche pas sans.Mon fichier de configuration est le suivant:



include /etc/ldap/schema/core.schema
include /etc/ldap/schema/collective.schema
include /etc/ldap/schema/corba.schema
include /etc/ldap/schema/cosine.schema
include /etc/ldap/schema/duaconf.schema
include /etc/ldap/schema/dyngroup.schema
include /etc/ldap/schema/inetorgperson.schema


password-hash {MD5}

pidfile /var/run/slapd/slapd.pid
argsfile /var/run/slapd/slapd.args

loglevel none
sizelimit 500
backend bdb
database bdb
suffix "dc=dess,dc=sn"
rootdn "cn=adminldap"
rootpw {MD5}ISMvKXpXpadDiUoOSoAfww==



directory /var/lib/ldap/openldap-dess

index objectClass eq
Si tu l'as installer via Synaptic, il est possible que ton daemon
slapd utilise un fichier de conf alternatif.

Fait un slapd -d 255

peux etre que tu auras un debut de reponse

Maintenant es tu sur que ton serveur DNS (bind) tourne correctement et est bien configurer pour ton LDAP ???
Messages postés
37
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
25 août 2010
25
donc pour que ldap fonctionne normallement, il faut que dns . je savais pas.
slap -d 255 affiche le message suivant

@(#) $OpenLDAP: slapd 2.4.18 (Sep 8 2009 17:46:15) $
buildd@palmer:/build/buildd/openldap-2.4.18/debian/build/servers/slapd
ldap_pvt_gethostbyname_a: host=mistik-laptop, r=0
daemon_init: <null>
daemon_init: listen on ldap:///
daemon_init: 1 listeners to open...
ldap_url_parse_ext(ldap:///)
daemon: bind(7) failed errno=98 (Address already in use)
daemon: bind(7) failed errno=98 (Address already in use)
slap_open_listener: failed on ldap:///
slapd stopped.
connections_destroy: nothing to destroy
Messages postés
37
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
25 août 2010
25
Mon serveur dns fonctionne
bonjour j'ai besoin de la commende d'installation de LDAP. puisque je suis entrain de configurer un server radius et je suis vraiment bloquer
Tout depend de ta distrib,
ca peux etre un
# ./configure && make && make install

ou un apt-get install

sinon je ne peux que te conseiler de faire un tour sur ce site

https://www.zytrax.com/books/ldap/

++
Youd
Messages postés
37
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
25 août 2010
25
Bonjour M. Youd, excuse moi de ne pas avoir fait signe depuis lors. Le site est très interessant! J'ai fini par installer mon serveur et il fonctionne bien.
Merci
Messages postés
70
Date d'inscription
jeudi 30 juillet 2009
Statut
Membre
Dernière intervention
6 février 2013
38
Qu'elle a été la solution a ton probleme, j'ai exactement le mm probleme