Excel - Différence en pourcentage [Résolu/Fermé]

Signaler
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour,

Je suis en train de faire l'analyse de mes ventes d'articles (magasin de sports) et je bute sur un souci de formule sur excel !

Voici un exemple :

Vente de bonnet en 2000 : 27
Vente de bonnet en 2001 : 20
Différence : 7 = -25,9%
Formule : =(27-20)/-27

Jusque la tout est bon ! maintenant dans mes ventes j ai ca :

Vente de chaussettes en 2000 : 0
Vente de chaussettes en 2001 : 12
Différence : 12 = +120%

Mais qu'elle formule puis-je utiliser pour les deux cas car j'ai 230 sous-catégorie (bonnet,chaussettes,veste, ....) ? Car en utilisant la première ca ne marche pas ca met "#DIV/0!"

Merci d'avance de votre aide
A voir également:

6 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 349
bonjour

Bravo Raoul, la vengeance est un plat qui se mange froid (7 mois !) mais super ta citation qui est un grand moment de cinéma comme on n'en fait plus ?
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
16390
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 février 2021
3 141
Bonjour,

Il faut que tu teste la valeur en 2000

SI(valeuren2000=0;calcul tenant compte de 0; calcul habituel...)
Bonjour,

Pourrais-je avoir plus d'info sur cette formule je suis novice dans excel :D
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 349
bonjour

Vente de chaussettes en 2000 : 0
Vente de chaussettes en 2001 : 12
Différence : 12 = +120%


Pas tout à fait +120% car en fait ton pourcentage n'est pas possible. Si tu part de zéro, ton augmentation est "infinie" et donc incalculable. Dans excel pour que ta formule fonctionne dans tous les cas tu peux mettre cette formule :

=SI(A1>0;(B1-A1)/A1;"")

Tu n'auras pas de pourcentage mais si tu tiens à ton +120% (non correct en calcul) tu mets :

=SI(A1>0;(B1-A1)/A1;B1/10)
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 349
bonjour RAOUL-VOLFONI,

Tu as collé ta question dans un sujet résolu depuis 3 mois !

Crée un nouveau sujet à toi :

- en évitant de bloquer les majuscules.
- en précisant bien la question.

Si avec les mêmes données et les mêmes formules tu n'obtiens pas les mêmes résultats c'est sans doute qu'il faudrait d'abord rechercher les erreurs de saisie, tu ne crois pas ?
Merci Beaucoup :D

Problème résolu !

Trés bonne explication.


merci pour tout :D

VOILA LE PROBLEME NOUS SOMME 8 EN COURS SUR EXCEL ET LE SOUCI C'EST AVEC LES MEMES FORMULES NOUS NE TROUVONS PO LES MEMES RESULTAT SUR CHAQUE PC

AVEZ VOUS UNE REPONSE A CE MYSTERE
MERCI