PHPADMIN : besoin d'aide

Résolu
Bonjour,

Bonjour,

il Y A 50 minutes j'ai effacer ma base de données sur PHPADMIN
Cette base de données me permet à mon travail d'administrer des mots de passe pour se connecter à notre site.

Depuis ce matin le site est HS.
Comme j'ai prit le boulot depuis 4 mois et que c'est la première fois que cela m'arrive, j'ai besoin d'aide, personne à mon travail peut m'aider

J'ai recréer la base et j'ai importer ma sauvegarde mais les mots de passe ne passent toujours pas sur internet.
Il y a t-il une manip. que je dois faire.

Quand je tape le login et le mot de passe, un message d'erreur s'affiche sur le site :
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'caro'@'localhost' (using password: YES) in /var/www/vhosts/peghaire.fr/httpdocs/professionnel/traitement_mot_pass.php on line 17
Connexion impossible: Access denied for user 'caro'@'localhost' (using password: YES)

J'y comprend rien!

je vais essayer de régler le problème en attendant des réponses.

Merci
Configuration: Windows XP
Firefox 3.0.5

11 réponses

  1. Salut...

    L'erreur qui est retournée, c'est que le nom d'utilisateur "caro" pour la base de donnée n'existe pas ou que le mot de passe pour "caro" est faux (donc différent de l'ancien)...

    Litéralement, l'erreur Access denied for user 'caro'@'localhost' (using password: YES) signifie : "Accès refusé à l'utilisateur caro sur le serveur local (utilisation d'un mdp)
    1. Bonjour,

      Donc si je met un nouveau administrateur ça devrait marcher?

      merci pour ta réponse.
      1. Non, enfaite la connexion à la base est définie dans le site ou le programme que tu utilise pour te connecter dessus... Il faut que tu reconfigure l'utilisateur comme dans l'ancienne base... Tu avais un utilisateur "caro" avec un certain mot de passe pour cette base, il faut le recréer... (ou bien modifier dans le programme ou le site l'utilisateur)
        1. sais tu où je dois aller pour cette manip.
          (les programmes fait par les autres c'est galère!)
          1. Désolé la je suis au bureau, j'ai donc pas phpMyAdmin sous la main, mais ca doit etre dans les options de la base de données...
            1. Ok,

              je continue à chercher mais rien à faire

              j'ai remarqué que je n'ai aucun privilèges pour créer une base de données.
              Ce n'est pas normal? je pense
              1. Ca dépends... Si tu es administrateur de la base, non effectivement c'est pas normal... Autrement si tu es un utilisateur, et que quelqu'un d'autre est admin, si, c'est normal...
                1. Je pense qu'elle était la seule administrateur
                  sachant qu'il y a qu'un administrateur crée
                2. @cassije64Tu sais peut être où je peux changer ça?
              2. j'ai ça aussi comme message!

                Not Found

                The requested URL /professionnel/function.mysql-connect was not found on this server.
                Apache/2.0.54 (Fedora) Server at www.peghaire.fr Port 80
                1. par phpmyadmin tu vas dans Privilèges et tu cree un utilisateur avec comme identifiant "caro" et mot de pass celuique tu as dans ton script de connexion php

                  et avec les droits INSERT,UPDATE,FILE,SELECT
                  1. j'ai un message qd je veux accéder aux "privilèges"

                    Bienvenue à phpMyAdmin 2.6.1

                    phpMyAdmin a tenté de se connecter au serveur MySQL, et le serveur a rejeté la connexion. Veuillez vérifier les valeurs de "host", "username" et "password" dans config.inc.php et vous assurer qu'elles correspondent aux informations fournies par l'administrateur du serveur MySQL.

                    Erreur
                    MySQL a répondu:

                    #1045 - Acc賠refus頰our l'utilisateur: 'root'@'@localhost' (mot de passe: NON)
                    1. il faut que tu edites le fichier config.inc.php

                      $cfgServers[1]['user']=root;
                      1. je suis vraiment nulle!
                        comment je le fait pour le trouver!

                        merci pour ton aide

                        (je ne pourrais qu'essayer demain matin là j'ai finit le boulot)