Lancement de apache automatique

Résolu
salut,
j'ai un petit souci pour lancer apache automatiquement sous mandriva 2007.
j'ai créer un script executable avec tout les droits à tout les utilisateurs: apache.sh

dans le fichier j'ai :
#!/bin/sh
usr/local/apachectl  start


le chemin est le bon , j'ai bien vérifier

ce fichier se trouve dans etc/rc.d/init.d

j'ai créer un lien symb dans etc/rc.d/rc5.d/: S98apache

ln -s ../init.d/apache.sg S98apache


avant ca marchait nikel mais maintenant ca marche plus T_T aidez moi SVP.
Configuration: Linux Mandriva
Firefox 1.5.0.7

4 réponses

  1. petite erreur du script:

    #!/bin/sh

    usr/local/apache/bin/apachectl start

    franchement je vois pas l'erreur... help plz
    1. je crois que j'ai une piste:
      il faut etre root pour lancer apache donc comment faire pour etre reconnu root dans un script?
      1. voilà j'ai trouver le pb, mon DocumentRoot était sur mon HDD externe donc apparement qui n'était pas monter avant l'execution du script e apache...
        quelqu'un a une solution???
        1. Probleme résolu:

          j'ai un peu toucher au fstab et au mtab pour qui mon hdd externe soit reconnu et non mounté après l'execution des script de démarrage !!! =]