Apache/2.2.22 (Ubuntu) Server

Résolu
Bonjour, je vien d'installer ocs sur mon ubuntu 12.04. mais mon serveur apache2 me renvois ce message: Apache/2.2.22 (Ubuntu) Server at 127.0.0.1 Port 80.
j'ai besoin de votre aide. merci d'avance

10 réponses

  1. Modérateur
    Et quel est le problème ?
    1. bonjour et merci de votre aide. le probleme c'eset que la page ocsreports ne s'ouvre pas quand j'entre l'adresse (127.0.0.1). j'obtien juste ce message: Not Found

      The requested URL /ocsreports was not found on this server.
      Apache/2.2.22 (Ubuntu) Server at 127.0.0.1 Port 80
  2. Modérateur
    Comment as-tu installé ocsreport ? Via un paquet ? Si oui lequel ?

    Je ne sais pas si ocs inventory et ocs reports sont la même chose, mais dans le doute, as-tu regardé cette page ?
    http://doc.ubuntu-fr.org/ocs_inventory

    Il y a de bonne chance qu'il faille configurer un vhost apache. Si tu ne vois pas comment on administre un serveur apache, je t'invite à lire ceci :
    http://www.mistra.fr/tutoriel-linux-serveur-web-apache2.html

    En temps normal, quand tu installes un logiciel qui s'appuie sur apache (genre phpmyadmin et j'imagine ocsreports), on te fournit un template de vhost apache. Il suffit de le copier dans /etc/apache2/sites-available, de l'activer avec a2ensite et c'est parti.

    Bonne chance
    1. merci pour la précieuse aide. mon serveur eset mi en place. maintenant , OCS inventory NG et GLPI ne s'ouvre pas. que faire? j'ai encore besoin d'aide. merci d'avance
  3. bonjour.
    je viens d'installer mon OCS inventory NG. le probleme, c'est que je suis confronté a un nouveau probleme. quand je lance le test de mon serveur PHP, j recois un message d'erreur: [Wed Jan 02 14:30:45 2013] [error] [client 127.0.0.1] File does not exist: /usr/share/ocsinventory-reports.
    j'ai besoin de votre aide. merci d'avance
    1. Modérateur
      Et je suppose que le dossier /usr/share/ocsinventory-reports n'existe pas sur ta machine ? Du coup est-ce que tu n'as simplement pas oublié d'installer un morceau ? Ou ce chemin est-il correct (par exemple, ocsinventory n'est-il pas ailleurs) ?

      As-tu essayé de suivre ce tutoriel ?
      http://doc.ubuntu-fr.org/ocs_inventory

      Bonne chance
      1. merci pour ton aide. je viens de tout refaire en suivant ce tutoriel. le probleme c'est que PERL et ces module sont introuvable. je n'arrive pas a les trouver. j'ai encore besoin d'aide. merci
        1. Modérateur
          Il faut les installer sans doute via le gestionnaire de paquets :
          http://doc.ubuntu-fr.org/synaptic

          Mais normalement si tu as installé le paquet ocsinventory-server, normalement ils ont dû être installés en cascade. D'où ma question, comment tas-tu installé ocs inventory ?

          Bonne chance
          1. J'ai suivi les instructions du tuto a la lettre et dans l'ordre jusqu'au Perl. on m'a demandé si j voulais continuer sans l'installer, ce que j'ai fait. Ensuite, j'ai installé perl et ces modules en utilisant le gestionnaire de paquets. Quand je redémarre mon serveur, et que j'entre l'adresse de ocsreports, je reçois se massage:
            Not Found

            The requested URL /ocsreports was not found on this server. 
            Apache/2.2.22 (Ubuntu) Server at 127.0.0.1 Port 80. 


            Je suis coincé.
          2. Ça y est... j'ai tout repris à zéro et j'ai utilisé le gestionnaire de paquets pour PERL et ces modules. Maintenant ça marche. et maintenant. Je ne me souviens plus du mot de passe et login de mon serveur Mysql. Est il possible de le modifier ??
        2. Modérateur
          Ça y est... j'ai tout repris à zéro et j'ai utilisé le gestionnaire de paquets pour PERL et ces modules. Maintenant ça marche. et maintenant.

          Oui. De manière générale, installe autant que possible via le gestionnaire de paquets, sinon tu t'exposes au genre de problèmes que tu as vécu.

          Je ne me souviens plus du mot de passe et login de mon serveur Mysql. Est il possible de le modifier ??

          Si tu as installé mysql via les paquet, je pense que ceci suffit :

          sudo dpkg-reconfigure mysql-server


          Sinon tu peux purger le paquet et supprimer /var/lib/mysql (ce qui supprimera toutes les bases de mysql), puis réinstaller le paquet :

          sudo apt-get purge mysql-server
          rm -rf /var/lib/mysql
          
          sudo apt-get update
          sudo apt-get upgrade
          sudo apt-get install mysql-server


          Bonne chance
          1. bonjour et merci pour votre.
            j'ai bien purgé mon serveur mysql et je l'ai reinstallé.
            le probleme n'est toujours pas resolu. j'ai un message:
            ERROR: MySql connection problem
            Access denied for user 'region'@'localhost' (using password: YES)
            ERROR: MySql connection problem
            Access denied for user 'region'@'localhost' (using password: YES)
        3. Modérateur
          As-tu créé l'utilisateur region@localhost ? Est-ce que cet utilisateur a des droits sur la base à laquelle il se connecte :
          http://dev.mysql.com/doc/refman/5.0/fr/adding-users.html

          GRANT ALL PRIVILEGES ON mabase.* TO 'region'@'localhost'
                   IDENTIFIED BY 'un_mot_de_passe' WITH GRANT OPTION;


          Que donne la requête :

          SELECT user,host FROM mysql.user;


          Bonne chance
          1. bonjour. merci pour ta reponse.
            quand j'entre cette commande: mysql --user=root mysql
            je recoi se message:ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
            je n'arrive meme pas a a traverser cette étape.
        4. Modérateur
          À mon avis la syntaxe est plutôt :

          mysql -u root -p


          Bonne chance
          1. le meme message s'affiche toujours: ERROR: MySql connection problem
            Access denied for user 'region'@'localhost' (using password: YES)
            ERROR: MySql connection problem
            Access denied for user 'region'@'localhost' (using password: YES)
            j'ai pourtant suivi les instruction a la lettre sans coincé quelque part. a kel niveau se trouve mon probleme??
            merci pour votre aide
        5. Modérateur
          Est-ce que tu arrives à te connecter en root ?
          Si oui que donne la requête suivante :

          SELECT user,host FROM mysql.user;
          1. merci pour ton aide qui m'a beaucoup aidé. en utilisant
            gedit /usr/share/ocsinventory-reports/ocsreports/dbconfig.inc.php
            j'ai pu reconfiguré. sa a comme par miracle marché. le probleme suivant est que les autres machines de mon réseau sont sous windows. comment faire??? merci encore
          2. Modérateur
            Il n'y a pas de miracles :-) Pour ta question, vu que ça n'a plus de rapport direct avec le problème de départ, merci d'ouvrir un nouveau fil de discussion.
          3. merci pour votre aide.