Date du jour - Courbe (Graphique) Excel 2003 [Résolu/Fermé]

Signaler
-
 ZoomZoom -
Bonjour,

J'ai un graphique (courbe standard avec points) qui s'étend sur plusieurs, plusieurs, plusieurs mois. La légende de l'axe des X affiche un mois sur 4 (ce qui est voulu) pour être lisible. J'aimerais mettre en évidence les données du mois courant, par exemple en ajoutant une ligne du temps ou en mettant les données dans une couleur différente.

La seule solution que j'aie trouvé c'est de tracer manuellement une ligne avec l'outil dessin. :-( J'aimerais mieux une solution automatique. Quelqu'un a une idée?


5 réponses

Messages postés
52050
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
13 816
Je n'ai pas compris ce que tu cherches à faire ...
Dans le mois courant, il y a une seule donnée ou plusieurs ?
On peut voir ton travail ?
Bonjour (Bonsoir) Raymond. Merci d'essayer de m'aider.

J'ai plusieurs séries de données sur près de cinq ans. C'est ce qui compose ma courbe.
- Première série = Planifié
- Deuxième série = Planifié révisé
- Troisième série = Réel + projection ( la projection est établie par une analyse d'expert).

Voici une illustration (je n'ai illustré que la série réel + projection).
...........................................|
...........................................|......X...........(projeté)
...........................................|..X...............(projeté)
.........................(réel).......X
.........................(réel)...X...|
--------------------------------|-------------------------------...
Déc.........Mars........Juin..|...Sept........Déc........Mars...
...........................................|
.......................................Juillet

Les données du mois courant sont à peu près au milieu du tableau (point d'intersection du passé et du futur). L'échelle dans l'axe des X affiche l'étiquette d'un mois sur quatre (autrement dit, par trimestre = Mars, Juin, Septembre, Décembre). Je souhaite mettre en évidence les données du mois courant, pour toutes les séries, par exemple par une ligne verticale (tel qu'illustré ci dessus). En la voyant tomber entre Juin et Septembre, on comprend qu'il s'agit des données du mois de Juillet.

J'ai trouvé l'alternative de séparer ma troisième série en deux séries distinctes et de les inclure toutes les deux dans la courbe (donc avec une couleur paramétrable) mais ça a l'effet pervers d'aussi l'ajouter dans la table de données au bas de la courbe. À date, c'est la meilleure solution que j'aie trouvée.
Messages postés
1235
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
151
Bonjour,
Je viens enfin de comprendre ce que tu voulais dire =)
J'ai déjà eu ce problème mais je n'avais pas trouvé comment le résoudre, du coup dès que j'ouvrais le fichier je bougeais manuellement la flèche que j'avais insérée avec les outils de dessin...
Exactement.
Voir le commentaire laissé à "Raymond PENTIER"

La seule alternative que j'ai trouvé est de séparer mes données en deux colonnes distinctes dans ma feuille et de retourner NA() s'il n'y a pas de données (pour ne pas avoir de valeur 0 dans ma courbe). Ensuite, j'utilise deux séries dans le graphique, ce qui me permet de les personnaliser (couleur, forme, etc). Ca fait beaucoup de colonnes pour arriver à mes fins.
Messages postés
52050
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
13 816
Zoom Zoom, salut.

Je n'ai pas trouvé de solution automatique.

Si ton tableau de données va de A1 à D999, saisis en E2 la formule
=MAX($B$2:$D$999)

Puis étend la plage de données du graphique de A1 à E999 ; clique droit sur le point représentatif de la donnée E2 pour sélectionner "Modifier le type de graphique Série de données..." et choisir le type Histogramme.
* Tu obtiens ainsi ta barre verticale à la première date du tableau.
Il te suffira de déplacer cette formule en E12 par exemple pour que ta barre se place à la onzième date !
Messages postés
52050
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
13 816
Si tu trouves que ça fait vraiment trop "bidouillage", tu peux améliorer en utilisant la colonne F. Tu remplaces la formule en E2 par
=SI(F2="";"";MAX($B$2:$D$999)) que tu recopies jusqu'en E999.
Il te suffira alors de taper n'importe quel caractère dans la colonne F pour qu'une barre verticale se place dans le graphe au niveau de la date correspondante ...

Je sais, ce n'est pas très scientifique et ça ne vaut pas une bonne macro, mais enfin ça fonctionne !

Cordialement.
Messages postés
52050
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
13 816
Un exemple pour illustrer mes propos :

https://www.cjoint.com/?hkgpTOKx23
Superbe.

Ce caractère pourrait être basé sur le mois et l'année du jour par exemple... Solution très imaginative. En plus, elle est à la portée de tous!

Bravo et merci

P.S.: Commentaire additionnel dans le post de Patrice 33740
Messages postés
8162
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
6 août 2020
1 444
Bonjour,

La méthode de Raymond © est excellente, pas besoin de macro, pour la rendre un peu plus « scientifique » il suffit de compléter la formule en C2 de son exemple par :

=SI(A2=AUJOURDHUI();MAX($B$2:$B$15);"")

Ce qui donne :

https://www.cjoint.com/?hkkMA50FIt

Cordialement
Patrice
5
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57070 internautes nous ont dit merci ce mois-ci

Raymond
C'est très ingénieux et imaginatif et ça fonctionne!

Patrice,
Ce petit plus fonctionne très bien quand les données sont aussi sur une base journalière. Ainsi, si la base est différente, il faudra comparer le mois() et l'année() de la colonne A avec la fonction Aujourdhui() pour déterminer l'affichage de de la fonction MAX($B$2:$B$15). Ce qui n'est pas mon cas!

Je vais essayer de publier l'ajustement à la formule au cours des prochains jours...là j'ai une urgence bureau à régler! ;-)

Bravo Messieurs et merci!