Error al guardar por comando robocopy

Resuelto
Hola, Estoy realizando una copia de seguridad remota de un servidor de archivos en un NAS Western Digital desde Robocopy. El comando se ejecuta en un servidor con una cuenta de administrador de dominio. Para la conexión al NAS, he configurado la creación de una unidad de red con usuario y contraseña indicados. Mi archivo .bat está configurado para definir variables para la fuente, destino y la fecha. La carpeta de destino del archivo de registro se crea en función de la fecha mediante md j:\... Mi comando Robocopy es:
robocopy %SOURCE% %DESTINATION%\%year%%month%%day%DIR\ /E /copy:DAT /B /XF thumbs.db /NDL /fp /TS /NP /R:1 /W:1 >> "%destination%\%year%%month%%day%DIR\Log DIR Robocopy %year%-%month%-%day%.txt"
Elegí /copy:dat para evitar el problema de las seguridades NTFS. Pero aparece un error en bastantes archivos (222 GB por respaldar) <date> <time> ERROR 5 (0x00000005) copiar el archivo <\\.....\....\....pdf> ACCESO DENEGADO Tengo el error para todos los archivos eml, pero también en doc, docx, pdf, ... Leí que /zb resuelve algunos problemas, pero los síntomas me parecen distintos. No consigo encontrar nada en la web sobre este problema. ¿Alguien tendría alguna idea? nota: en el archivo original hay los comandos
for /f "delims=/ token=1,2,3" %%1 in ('echo %date%') do set DA=%%1/%%2/%%3
for /f "delims=/ token=1,2,3" %%1 in ('echo %date%') do set DAFR=%%1-%%2-%%3
for /f "delims=/ token=1,2,3" %%1 in ('echo %date%') do set DAY=%%1/%%2/%%3
pero no sé a qué corresponden esas líneas, así que las desactivé. Gracias a las personas que respondan sin pedir nada a cambio, siempre con respeto y con mínimas faltas. :)

10 respuestas

  1. sí, para la configuración es eso.
    probé el comando pero sigo teniendo mi error y el archivo eml que se crea pero con la fecha en 1980

    --
    Gracias a las personas que nos responden sin preguntar nada a cambio salvo respeto y pocos errores... :)
    2
    1. Solo para hacer una prueba, ¿va mejor si usas como fuente la máquina en la que se encuentra el script?
      -1
  2. no hay error en esta manera de hacer.
    Para el NAS, es un Western Digital My Cloud 4100 con el firmware 2.21.126

    --
    Gracias a las personas que nos responden sin pedir nada a cambio si no es respeto y pocos errores... :)
    1
    1. He encontrado la solución, puse /ZB en lugar de /B y ya no tuve errores en la línea de comandos, queda así:
      robocopy %source% %destination%\%year%%month%%day%XXX\dir /E /FFT /COPY:DAT /R:0 /W:2 /ZB /XF thumbs.db /V /NDL /FP /TS /NP >> "%destination%\%year%%month%%day%XXX\LOG.txt

      Gracias por la ayuda que me has brindado.
      0
    2. Contento de que tu problema esté resuelto.

      Gracias por haber dado la solución.

      Hasta pronto, quizá.
      0
    3. viendo cómo me pegué la cabeza con eso, si eso evita migrañas y aumentar el agujero de la seguridad social ... Me habéis ayudado en el pasado y bueno, por una vez si puedo ayudar, es una simple cortesía.
      0
  3. Copiar el contenido de la carpeta de pruebas en la máquina que ejecuta el archivo .bat manteniendo los mismos derechos de Active Directory.
    Sin cambios, el mismo error. acceso denegado al archivo .eml pero se copia de todas formas con los parámetros de fecha a 1980.

    --
    Gracias a las personas que nos responden sin pedir nada a cambio salvo respeto y pocas faltas… :)
    0
    1. Muy bien y ahora otra prueba:

      excluimos el NAS, copias el contenido del servidor de archivos a la máquina que lanza el script.
      0
  4. Traducción al español conservará la estructura y el formato HTML:
    net use j: /delete /y
    net use j: \\ipNAS\DossierSauvegarde /user:user password

    rem definicion del dia
    SET day=%date:~0,2%

    rem definicion del mes
    SET month=%date:~3,2%

    rem definicion del anio
    SET year=%date:~6,4%

    rem carpeta de origen
    SET SOURCE=\\IPsrvFichero\dossier a sauvegarder

    rem carpeta de destino
    SET DESTINATION=j:\%year%%month%%day%DIR\

    md %destination%
    md %destination%log

    chcp 1252

    robocopy %SOURCE% %DESTINATION% /E /FFT /copy:DAT /R:3 /W:10 /B /XF thumbs.db /V /NDL /FP /TS /NP >> "%destination%log\Log DIR Robocopy %year%-%month%-%day%.txt"

    exit
    0
    1. nivel de seguridad de los documentos, las cuentas de administradores de red tienen control total sobre todos los archivos (es el GG que lista las cuentas admin el que tiene control total)
      Pienso en las seguridades NTFS pero normalmente, en el informe sobre las líneas de error, debería tener la precisión:
      ""ERROR 5 (0 x 00000005) copiado de seguridad NTFS en el archivo de destino< nombre de directorio > acceso denegado""
      ¿Me equivoco?

      Gracias a las personas que nos contestan sin pedir nada a cambio salvo respeto y pocos errores... :)
      0
      1. Si entiendo bien, tienes un servidor de archivos, un NAS, y ejecutas este script desde una tercera máquina, ¿eso es correcto?
        0
    2. para el log:
      -------------------------------------------------------------------------------
      ROBOCOPY :: Copia de archivos robusta para Windows
      -------------------------------------------------------------------------------

      Inicio : Wed Mar 29 10:27:08 2017

      Fuente : \\IPsrvfichier\dossier a sauvegarder
      Destino : \\ipNAS\dossierSauvegarde

      Archivos : *.*

      Arch. excl.: thumbs.db

      Opciones : *.* /TS /FP /NDL /S /E /COPY:DAT /B /NP /R:0 /W:1

      -------------------------------------------------------------------------------

      Nuevo archivo 76288 2014/06/02 09:19:31 \\IPsrvfichier\dossier a sauvegarder\doc1.doc
      Nuevo archivo 40960 2014/06/02 09:19:05 \\IPsrvfichier\dossier a sauvegarder\doc2.doc
      Nuevo archivo 182926 2014/06/05 08:02:05 \\IPsrvfichier\dossier a sauvegarder\mail.eml
      2017/03/29 10:27:09 ERROR 5 (0x00000005) Copia del archivo \\IPsrvfichier\dossier a sauvegarder\mail.eml
      Acceso denegado.

      -------------------------------------------------------------------------------

      Total Copiar Ignorar Discordancia EXTRAS
      Recuento: 1 0 1 0 0 1
      Archivos: 3 2 0 0 1 0
      Octetos: 293.1 k 114.5 k 0 0 178.6 k 0
      Horas: 0:00:00 0:00:00 0:00:00 0:00:00

      Ancho de banda: 577576 Octets/seg.
      Ancho de banda: 33.049 Mega-octets/min.

      Terminó: Wed Mar 29 10:27:09 2017

      --
      Gracias a las personas que nos contestan sin pedir nada a cambio salvo respeto y pocos errores... :)
      0
      1. He notado que el archivo EML se copió correctamente, pero no logra copiar la información de los detalles. Entre otros, la fecha de creación y modificación pasa de 02.01.1980 a 01:00.

        Gracias a las personas que nos responden sin pedir nada a cambio, salvo respeto y pocos errores... :)
        0
        1. Muy bien, ¿qué dice el registro? Da todo el registro para que vea qué funciona y qué no funciona.

          Puedes hacer una simulación y generar un registro usando el interruptor /NOCOPY

          p.d.: tu primer comando md no sirve para nada.
          0
          1. rem---------------------------------------------------------------------------
            rem configuración de acceso al NAS
            rem---------------------------------------------------------------------------

            net use j: /delete /y
            net use j: \\ipNAS\DossierSauvegarde /user:user password

            rem ---------------------------------------------------------------------------
            rem definición de variables
            rem ---------------------------------------------------------------------------

            rem carpeta de origen
            SET SOURCE=\\IPsrvFichier\dossier a sauvegarder

            rem carpeta de destino
            SET DESTINATION=\\ipNAS\DossierSauvegarde

            rem definición del día
            SET day=%date:~0,2%

            rem definición del mes
            SET month=%date:~3,2%

            rem definición del año
            SET year=%date:~6,4%

            rem ---------------------------------------------------------------------------
            rem creación del directorio de destino
            rem ---------------------------------------------------------------------------

            md j:\%year%%month%%day%DIR
            md j:\%year%%month%%day%DIR\log

            rem ---------------------------------------------------------------------------
            rem ------------
            rem ---------------------------------------------------------------------------

            rem comando no conocido

            rem for /f "delims=/ tokens=1,2,3" %%1 in ('echo %date%') do set DA=%%1/%%2/%%3

            rem for /f "delims=/ tokens=1,2,3" %%1 in ('echo %date%') do set DAFR=%%3-%%2-%%1

            rem for /f "delims=/ tokens=1,2,3" %%1 in ('echo %date%') do set DAY=%%1/%%2/%%3

            rem ---------------------------------------------------------------------------
            rem lanzamiento de la copia de seguridad
            rem ---------------------------------------------------------------------------

            robocopy %SOURCE% %DESTINATION%\%year%%month%%day%DIR\ /E /copy:DAT /R:1 /W:1 /B /XF thumbs.db /NDL /fp /TS /NP >> "%destination%\%year%%month%%day%DIR\log\Log DIR Robocopy %year%-%month%-%day%.txt"

            --
            Gracias a las personas que nos responden sin pedir nada a cambio si no es respeto y pocas faltas... :)
            0
            1. Hola,

              Si quieres que te ayudemos, publica la totalidad de tu script.
              0
              1. Pensé que había puesto suficiente información, lo hago mañana, de regreso al trabajo.
                0