Erreur de sauvegarde sur commande robocopy

Résolu
Bonjour,

J'effectue une sauvegarde déportée d'un serveur de fichier distant sur un NAS Western Digital à partir de robocopy.
La commande est lancée sur un serveur avec un compte administrateur domaine.

Pour la connexion au NAS, j'ai configuré la création d'un lecteur réseau avec identifiant et mot de passe renseigné
Mon .bat est configuré pour définir des variables pour la source, destination, définition de la date
Le dossier de destination du fichier log est créé en fonction de la date par des md j:\...

Ma commande robocopy est:
robocopy %SOURCE% %DESTINATION%\%year%%month%%day%DIR\ /E /copy:DAT /B /XF thumbs.db /NDL /fp /TS /NP /R:1 /W:1 >> "%destination%\%year%%month%%day%DIR\Log DIR Robocopy %year%-%month%-%day%.txt"

j'ai choisi /copy:dat pour éviter le problème des sécurités NTFS

Mais voilà, j'ai une erreur sur pas mal de fichier (222 Go à sauvegarder)
<date> <heure> ERREUR 5 (0x00000005) copie du fichier <\\.....\....\....pdf> ACCES REFUSE

J'ai l'erreur pour tous les fichiers eml, mais aussi sur des doc, docx, pdf, ...
J'ai pu lire que /zb résout certains problèmes mais les symptômes me paraissent différents.
Je n'arrive à rien trouver sur le net sur ce problème.

Quelqu'un aurait il une idée ?

n.b.: sur le ficier d'origine, il y a les commande
for /f "delims=/ token=1,2,3" %%1 in ('echo %date%') do set DA=%%1/%%2/%%3
for /f "delims=/ token=1,2,3" %%1 in ('echo %date%') do set DAFR=%%1-%%2-%%3
for /f "delims=/ token=1,2,3" %%1 in ('echo %date%') do set DAY=%%1/%%2/%%3

Mais je ne sais pas à quoi correspondent ces lignes donc je les avais désactivé.
Merci Aux personnes qui nous répondent sans demander quoi que ce soit en retour si ce n'est du respect et peu de fautes ... :)

10 réponses

  1. oui, pour la config c'est ça.
    j'ai testé la commande mais j'ai toujours mon erreur et le fichier eml qui se créé mais avec la date en 1980
    2
    1. Juste pour faire un test, est-ce que ça va mieux si tu utilises comme source la machine où se trouve le script ?
      -1
  2. pas d'erreur sur cette façon de faire.
    Pour le NAS, c'est un Western Digital My Cloud 4100 avec le firmware 2.21.126
    1
    1. j'ai trouvé la solution, j'ai mis /ZB au lieu de /B et je n'ai plus eu d'erreur en ligne de commande, cela donne :
      robocopy %source% %destination%\%year%%month%%day%XXX\dir /E /FFT /COPY:DAT /R:0 /W:2 /ZB /XF thumbs.db /V /NDL /FP /TS /NP >> "%destination%\%year%%month%%day%XXX\LOG.txt

      Merci pour l'aide que vous m'avez apporté.
      0
    2. Content que ton problème soit résolu.

      Merci d'avoir donné la solution.

      A bientôt peut-être.
      0
    3. vu comment je me suis pris la tête avec ça, si cela évite des migraines et d'augmenter le trou de la sécurité sociale ... Vous m'avez aidé par le passé et bien pour une fois si je peux aider, c'est un juste retour d'ascenseur.
      0
  3. Copie du contenu du dossier de test sur la machine lançant le fichier .bat en conservant les mêmes droits d'AD.
    Pas de changement, même erreur. accès refusé au fichier eml mais le copie quand même avec les paramètres de date à 1980.
    0
    1. Très bien et maintenant un autre test :

      on exclut le NAS, tu copies le contenu du serveur de fichiers vers la machine lançant le script.
      0
  4. Essaie comme ça :
    net use j: /delete /y
    net use j: \\ipNAS\DossierSauvegarde /user:user password

    rem definition du jour
    SET day=%date:~0,2%

    rem definition du mois
    SET month=%date:~3,2%

    rem definition de l annee
    SET year=%date:~6,4%

    rem dossier d origine
    SET SOURCE=\\IPsrvFichier\dossier a sauvegarder

    rem dossier de destination
    SET DESTINATION=j:\%year%%month%%day%DIR\

    md %destination%
    md %destination%log

    chcp 1252

    robocopy %SOURCE% %DESTINATION% /E /FFT /copy:DAT /R:3 /W:10 /B /XF thumbs.db /V /NDL /FP /TS /NP >> "%destination%log\Log DIR Robocopy %year%-%month%-%day%.txt"

    exit
    0
    1. niveau sécurité des documents, les comptes administrateurs réseaux ont un contrôle total sur tous les fichiers (c'est le GG répertoriant les comptes admin qui est en contrôle total)
      Je pense aux sécurités NTFS mais normalement, dans le rapport sur les lignes d'erreur, je devrais avoir la précision :
      "ERREUR 5 (0 x 00000005) copie de sécurité NTFS dans le fichier de Destination< nom répertoire > accès refusée"
      Je me trompe ?

      Merci Aux personnes qui nous répondent sans demander quoi que ce soit en retour si ce n'est du respect et peu de fautes ... :)
      0
      1. Si j'ai bien suivi, tu as un serveur de fichiers, un NAS, et tu exécutes ce script depuis une troisième machine, c'est bien ça ?
        0
    2. pour le log :
      -------------------------------------------------------------------------------
      ROBOCOPY :: Copie de fichiers robuste pour Windows
      -------------------------------------------------------------------------------

      D‚but : Wed Mar 29 10:27:08 2017

      Source : \\IPsrvfichier\dossier a sauvegarder
      Dest : \\ipNAS\dossierSauvegarde

      Fichiers : *.*

      Fich. exclus : thumbs.db

      Options : *.* /TS /FP /NDL /S /E /COPY:DAT /B /NP /R:0 /W:1

      -------------------------------------------------------------------------------

      Nouveau fichier 76288 2014/06/02 09:19:31 \\IPsrvfichier\dossier a sauvegarder\doc1.doc
      Nouveau fichier 40960 2014/06/02 09:19:05 \\IPsrvfichier\dossier a sauvegarder\doc2.doc
      Nouveau fichier 182926 2014/06/05 08:02:05 \\IPsrvfichier\dossier a sauvegarder\mail.eml
      2017/03/29 10:27:09 ERREUR 5 (0x00000005) Copie du fichier \\IPsrvfichier\dossier a sauvegarder\mail.eml
      AccŠs refus‚.

      -------------------------------------------------------------------------------

      Total Copi‚ Ignor‚Discordance CHEC Extras
      R‚pÿ: 1 0 1 0 0 1
      Fichiersÿ: 3 2 0 0 1 0
      Octetsÿ: 293.1 k 114.5 k 0 0 178.6 k 0
      Heures: 0:00:00 0:00:00 0:00:00 0:00:00

      D‚bitÿ: 577576 Octets/sec.
      D‚bitÿ: 33.049 M‚ga-octets/min.

      Termin‚ÿ: Wed Mar 29 10:27:09 2017

      0
      1. J'ai pu remarquer que le fichier eml était bien copié mais qu'il n'arrivait pas à copier les informations de détails
        Cela mets entre autre, date de création et de modification 02.01.1980 à 01:00

        Merci Aux personnes qui nous répondent sans demander quoi que ce soit en retour si ce n'est du respect et peu de fautes ... :)
        0
        1. Très bien, que dit le log ? Donne tout le log pour que je vois ce qui fonctionne et ce qui ne fonctionne pas.

          Tu peux faire une simulation et générer un log à l'aide du commutateur /NOCOPY

          ps : ta première commande md ne sert à rien.
          0
          1. rem---------------------------------------------------------------------------
            rem configuration des acces au NAS
            rem---------------------------------------------------------------------------

            net use j: /delete /y
            net use j: \\ipNAS\DossierSauvegarde /user:user password

            rem ---------------------------------------------------------------------------
            rem definition de variables
            rem ---------------------------------------------------------------------------

            rem dossier d origine
            SET SOURCE=\\IPsrvFichier\dossier a sauvegarder

            rem dossier de destination
            SET DESTINATION=\\ipNAS\DossierSauvegarde

            rem definition du jour
            SET day=%date:~0,2%

            rem definition du mois
            SET month=%date:~3,2%

            rem definition de l annee
            SET year=%date:~6,4%

            rem ---------------------------------------------------------------------------
            rem creation du repertoire de destination
            rem ---------------------------------------------------------------------------

            md j:\%year%%month%%day%DIR
            md j:\%year%%month%%day%DIR\log

            rem ---------------------------------------------------------------------------
            rem ------------
            rem ---------------------------------------------------------------------------

            rem commande non connue

            rem for /f "delims=/ tokens=1,2,3" %%1 in ('echo %date%') do set DA=%%1/%%2/%%3

            rem for /f "delims=/ tokens=1,2,3" %%1 in ('echo %date%') do set DAFR=%%3-%%2-%%1

            rem for /f "delims=/ tokens=1,2,3" %%1 in ('echo %date%') do set DAY=%%1/%%2/%%3

            rem ---------------------------------------------------------------------------
            rem lancement de la sauvegarde
            rem ---------------------------------------------------------------------------

            robocopy %SOURCE% %DESTINATION%\%year%%month%%day%DIR\ /E /copy:DAT /R:1 /W:1 /B /XF thumbs.db /NDL /fp /TS /NP >> "%destination%\%year%%month%%day%DIR\log\Log DIR Robocopy %year%-%month%-%day%.txt"

            0
            1. Bonjour,

              Si tu veux qu'on t'aide, poste l'intégralité de ton script.
              0
              1. je pensais avoir mis assez d'info, je fais ça demain de retour au boulot
                0