Configuration réseau sur linux

Résolu
Bonjour,

je travaille avec linux debian (machine virtuelle sous windows vista)..le problème c'est qu'il y a un problème de configuration réseau.c'est à dire que je peux pas se connecter à internet depuis la machine virtuelle..par exemple lorsque je fais
wget https://www.google.fr/?gws_rd=ssl
j'obtiens l'erreur suivante

--2011-01-10 11:40:37-- https://www.google.fr/?gws_rd=ssl
resolving www.google.fr ...failed:name or service not known
wget: unable to resolve host address 'www.google.fr'


même les commande apt-get install ou update ou... n'arrive pas à fonctionner correctement puisque la configuration réseau n'est pas adéquate

je sais pas quoi faire,et je sais pas dans quel fichier je dois verifier : /etc/hosts ? /etc/network/interfaces ?...

est ce que qlq'un peut me donner un coup de main?

merci d'avance

10 réponses

  1. ahhh ça y est..j'ai trouvé le problème..car dans le fichier /etc/network/interface s'est écrit eth0 au lieu de eth2...maintenant tout va bien..et c'est grace à toi Mytux.....merci infiniment..trés gentil de ta part

    merci encore une fois
    1. bonjour,
      merci parce que j'ai utilisé ce lien et j arrive a connecter avec machine virtual pour une période, après que le problème est revient a nouveau.
      la seul différence est que j utilise ubuntu comme un os pour la machine hôte.
      je crois que le problème
      due a propos d un mise a jour ubuntu.
    2. Bonjour à tous,
      D'abord merci beaucoup pour ce lien il est très intéressant pour moi mais j'ai rencontré un problème lors de modification du fichier /etc/network/interfaces car l'écriture sur ce fichier est non permise.Bon j'ai essayé de modifier les droits d'accès avec chmod mais ça n'a pas marché. SVP y'a t'il quelqu'un qui peut m'aider?
      merci d'avance .
    3. Contributeur
      Bonjour,

      Je ne suis pas un spécialiste linux (j'utilise occasionnellement Puppy Linux), mais je pense que pour modifier les droits d'accès, vous devez passer en mode administrateur en tapant su ou sudo avant de rentrer vos commandes chroot. Faute de quoi, si vous êtes comme il est de règle en mode utilisateur, vous ne pourrez pas modifier les fichiers que vous n'avez pas créés.

      Cordialement
    4. merci beaucoup georges97 .
      apparemment le problème est due de la plateforme soclib :j'ai supprimé la plateforme et je l'ai réinstallée et ça marche maintenant je peux modifier les droits d'accès bien sur en tant q'administrateur.
      tout va bien :)
      merci encore une fois georges97.
  2. Ok,

    Donc comme tu peux le constater, tu ne possèdes pas d'adresse IP. Essaie de faire la commande ifup eth2. Elle sert à activer ta carte réseau et ainsi obtenir une adresse IP.

    Peux - tu aussi me montrer le contenu de ton fichier /etc/network/interfaces?

    Bien à toi,
    MyTux.
    1. pour le système de virtualisation,j'utilise virtualbox
      pour la connection,il s'agit d'une connection filaire
      pour la carte réseau,j'ai bien mis une carte réseau pour cette machine virtuelle (PCnet-PCI II (NAT))

      enfin,voila ce que j'obtiens avec la commande ifconfig -a

      eth2     link encap:Ethernet   HWaddr  08:00:27/9e:ea:26
                 BROADCAST MULTICAST   MTU:1500  Metric:1
                 RX packet:8  errors:0 dropped:0  overruns:0 frame:0
                 TX packet:8  errors:0 dropped:0  overruns:0 carriers:0
                 collisions:0 txqueuelen:1000
                 RX bytes:0 (0.0 B)  TX  bytes:0 (0.0 B)
                 Interrupt:10 Base address:0xd020
      
      lo        link encap:local loopback
                 inet addr:127.0.0.1  Mask: 255.0.0.0
                 inet6 addr:   ::1/128 Scope:Host
                 UP LOOPBACK RUNNING  MTU:16436  Metric:1
                 RX packet:8  errors:0 dropped:0  overruns:0 frame:0
                 TX packet:8  errors:0 dropped:0  overruns:0 carriers:0
                 collisions:0 txqueuelen:0
                 RX bytes:560 (560.0 B)  TX  bytes:560 (560.0 B)
      
      
      
      
      
      
      


      merci
      1. Bon,

        Peux - tu me dire ce que tu utilises comme système de virtualisation? ( virtual PC, server, vmware, virtualbox)

        Vérifie aussi que tu aies bien mis une interface réseau à ta machine virtuelle lors de sa configuration. Utilises - tu une connexion filaire ou possède tu une connexion wifi sur ta machine hôte?

        Une fois que tu t'es bien assuré d'avoir mis une carte réseau à ta machine virtuelle, tu démarres celle-ci, tu vérifies les connexions réseau avec ifconfig ( voire ifconfig -a ( pour voir toutes les connexions ) ).

        bien à toi,
        MyTux.
        1. voila ce que me donne la commande ifconfig

          lo        link encap:local loopback
                     inet addr:127.0.0.1  Mask: 255.0.0.0
                     inet6 addr:   ::1/128 Scope:Host
                     UP LOOPBACK RUNNING  MTU:16436  Metric:1
                     RX packet:8  errors:0 dropped:0  overruns:0 frame:0
                     TX packet:8  errors:0 dropped:0  overruns:0 carriers:0
                     collisions:0 txqueuelen:0
                     RX bytes:560 (560.0 B)  TX  bytes:560 (560.0 B)
          
          
          


          merci
          1. Alors pour découvrir l'adresse ip de ta machine tu as la commande:
            ifconfig.

            Bien à toi,
            MyTux.
            1. bon je sais pas comment découvrir l'adresse IP de ma machine virtuelle(je suis plus que nulle en linux)

              pour le fichier /etc/hosts il contient

              127.0.0.1	localhost
              127.0.1.1	soclib
              
              # The following lines are desirable for IPv6 capable hosts
              ::1     localhost ip6-localhost ip6-loopback
              fe00::0 ip6-localnet
              ff00::0 ip6-mcastprefix
              ff02::1 ip6-allnodes
              ff02::2 ip6-allrouters
              ff02::3 ip6-allhosts
              
              


              merci
              1. Alors si elle est configurée en NAT, c'est ton pc qui doit faire serveur DHCP.
                - As - tu bien obtenu une adresse IP pour ta machine virtuelle?
                - Quel est le contenu de ton fichier /etc/hosts?

                Bien à toi,
                MyTux.
                1. effectivement,actuellement elle est configurée en NAT,mais je peux la modifier si ça peut arranger l'affaire..en tout cas,j'ai essayé même en pont,et ça n'a pas marché

                  merci
                  1. Bonjour,

                    Tout d'abord la première question à se poser est: comment as - tu configuré la carte réseau de ta machine virtuelle? ( pont, NAT...) ?

                    Bien à toi,
                    MyTux.