Trouver une fonction excel

Fermé
Signaler
-
Messages postés
17697
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
-
Bonjour,
Je souhaite comparer deux listes de nom pour savoir si le gens de la liste A figure aussi dans la liste B, je souhaite utiliser une fonction qui dira si dans liste A il y a les personnes de la listes B, alors "Elus" et sinon "non élus", dans une colonne atenante à la liste la plus volumineuse.
je pense qu'il faut utiliser la fonction SI, combiner à une autre mais je ne sais pas laquelle!!

Merci pour votre aide!
Excel est plein de mistère pour moi.
Lilirose.

4 réponses

Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
6 975
Bonsoir tout le monde,

Hummmm, mike... ça marcherait si les 2 listes sont bien égales mais dès qu'il manque un nom en colonne B ils ne sont plus en face.
Je dirais plutôt :
=SI(NB.SI(B:B;A2);"élu";"non élu")
à recopier vers le bas.
Si le nom en A2 est trouvé en colonne B alors "élu"
eric
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
18990
Date d'inscription
dimanche 16 décembre 2007
Statut
Membre
Dernière intervention
2 décembre 2021
3 072

Messages postés
17697
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 855
Salut,

En supposant que ta première liste commence en A2 et ta deuxième en B2 place cette formule en C2 et incrémente jusqu'a la fin de ta liste

=SI(A2<>B2;"non élus";"Elus")

A+
Messages postés
17697
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 855
Salut Eriiic,

Oui tout à fait ou encore qui marche quelque soit l'ordre de saisie dans la colonne

=SI(A2="";"";SI(ESTNA(EQUIV(A2;B$2:B$9;0));"non élu";"Elu"))

Bonne journée