Excel Compter Nombre de mots différents [Résolu/Fermé]

Signaler
-
 PHIIIIIIT -
Bonjour,

Je souhaiterais savoir comment faire exactement pour compter le nombre de mots différents dans une colonne.

Exemple :

En colonne A :
A1 = 'Bonjour
A2 ='Bonjour
A3 = 'Adieu

Placée en B1, la formule que je cherche pour toute la colonne 'A' devrait me donner '2'

Je vous remercie d'avance.

1 réponse

Messages postés
9084
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
28 mai 2018
121
Avec la fonction NB.SI() il est possible de compter les cellules qui contiennent le mot (ex. : ANS)
Exemple : =NB.SI(C1:D14;"ans")
Merci,

Mais en fait je ne sais pas comment l'améliorer pour obtenir le nombre de mots différents.

Aurais-tu une solution ?
> Kromulus
Bonjour les amateurs !

Je me répons à moi même, si ça peut aider qqn :

- Sélectionner la colonne où il faut compter le nombre de noms différents
- Faire un filtre élaboré en cochant la case "Extraction sans doublon"
- Faire un compter classique (non testé, mais à partir de la ligne précédente... il n'y a plus de secret)
Et quand nous avons 3600 caractères , c'est a dire on applique le filtre et ils nous enlève les doubles. Mais lorsque on trouve plus de 300 caractères différents pour les compter un par un c'est.... long