Excel Compter Nombre de mots différents

Résolu/Fermé
Kromulus - 1 déc. 2008 à 00:01
 PHIIIIIIT - 11 oct. 2012 à 16:55
Bonjour,

Je souhaiterais savoir comment faire exactement pour compter le nombre de mots différents dans une colonne.

Exemple :

En colonne A :
A1 = 'Bonjour
A2 ='Bonjour
A3 = 'Adieu

Placée en B1, la formule que je cherche pour toute la colonne 'A' devrait me donner '2'

Je vous remercie d'avance.

1 réponse

jfqld Messages postés 9080 Date d'inscription jeudi 18 septembre 2008 Statut Membre Dernière intervention 28 mai 2018 125
1 déc. 2008 à 07:57
Avec la fonction NB.SI() il est possible de compter les cellules qui contiennent le mot (ex. : ANS)
Exemple : =NB.SI(C1:D14;"ans")
1
Merci,

Mais en fait je ne sais pas comment l'améliorer pour obtenir le nombre de mots différents.

Aurais-tu une solution ?
0
Kromulus > Kromulus
16 janv. 2009 à 21:32
Bonjour les amateurs !

Je me répons à moi même, si ça peut aider qqn :

- Sélectionner la colonne où il faut compter le nombre de noms différents
- Faire un filtre élaboré en cochant la case "Extraction sans doublon"
- Faire un compter classique (non testé, mais à partir de la ligne précédente... il n'y a plus de secret)
0
Et quand nous avons 3600 caractères , c'est a dire on applique le filtre et ils nous enlève les doubles. Mais lorsque on trouve plus de 300 caractères différents pour les compter un par un c'est.... long
0