Excel renseigner automatiquement des colonnes

Résolu/Fermé
anton 29 - 13 nov. 2008 à 09:05
 anton 29 - 14 nov. 2008 à 09:43
Bonjour,à tous


Ayant des connaissances des plus basiques sous Excel ,je viens vous demander votre aide .

je dispose sur un feuille 1 d'un listing de pieces détachées ( à peu près 1500 références)où figure dans la colonne B les références produit (ex: AP 27)et en colonne E leur prix ,maintenant mes feuilles numérotées de 2 à 10 sont mes différentes familles de d'appareil ou l'on retrouve toujours en colonne B la réference produit celle ci est renseigné mais ici je n'ai pas ma colonne prix que je voudrais mettre en colonne D par exemple et cela sur toutes mes feuilles suivantes(2 à 10 )

ma question est il possible par une formule excel ou une macro de renseigner automatiquement ma colonne D si mes les valeurs sont les memes pour la colonne B dans la Feuille1 et 2

Ex : dans ma Feuille 1 j'ai la référence AP 27 en B27 et le prix en E27

maintenant sur ma Feuille 2 j'ai a référence AP 27 en B4 et je voudrais que Excel trouve automatiquement dans que DB4de ma feuille2 soit égale à E27de ma feuille1
car B27etB4 sont égaux sur les deux feuilles


Merci d'avance

3 réponses

gbinforme Messages postés 14935 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 628
13 nov. 2008 à 09:43
bonjour

En colonne D de tes feuilles tu peux mettre cette formule en remplaçant "Feuil1" par le nom de ton onglet listing :

=SI(B1="";"";RECHERCHEV(B1;DECALER(Feuil1!$B$1;;;NBVAL(Feuil1!$B:$B);5);4;0))

Pour mettre la formule sur toutes les feuilles, tu sélectionnes tes 9 onglets puis tu colles la formule sur la feuille visible en D1. Ensuite tu tires ta formule vers le bas et tu dissocies tes feuilles.
0
Mike-31 Messages postés 18049 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 septembre 2022 4 996
13 nov. 2008 à 09:59
salut,

Il n’est pas nécessaire de passer par le VBA, la fonction RECHERCHEV fait l’affaire.

Clique sur la feuille 2 et clic sur la touche shift et la dernière feuille colle la formule en B2 sur une feuille et incrémentes la formule vers le bas de ta feuille recliques sur la première feuille pour dissocier ta sélection et toutes tes feuilles sont paramétrées

=SI(B2<>"";RECHERCHEV(B2;Feuil1!B1:E11;4;0))

A+
0
merci à vous deux cela marche parfaitement
je vous remercie encore une fois
0