Astuce facturation

[Fermé]
Signaler
-
Messages postés
16491
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 juillet 2021
-
Bonjour, comment faire pour quand je fais une facture client, que je tape uniquement la ref produit et que la designation et le prix s'affiche automatiquement et soit soustrait au stock.
Merci d'avance votre aide m'est precieuse

9 réponses

Messages postés
370
Date d'inscription
mardi 14 janvier 2003
Statut
Membre
Dernière intervention
11 septembre 2009
54
Bonsoir,

comment faire pour quand je fais une facture client, que je tape uniquement la ref produit et que la designation et le prix s'affiche automatiquement et soit soustrait au stock.

un logiciel adéquat.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

merci mais que logiciel
Messages postés
16491
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 juillet 2021
3 200
Bonjour,

Sur XL<2007

petite démo très basique de gestion de stocks
=SI(B2="";"";RECHERCHEV(B2;H$2:I$8;2))

pour le prix, il suffira d'ajouter 2 colonne PU et Nbre...
Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
5 999
Bonjour michel-m
petit complément pour éviter les impairs:
La formule RECHERCHEV que tu proposes ne marchecorrectement que si la première colonne du champ de recherche est classée par ordre croissant.
Pour contourner cet inconvénient, il faut rajouter un code derrière le N° de colonne (en l'occurence le 2)dans la deuxième partie de la formule, soit donc:
=SI(B2="";"";RECHERCHEV(B2;H$2:I$8;2;0))
ou encore
=SI(B2="";"";RECHERCHEV(B2;H$2:I$8;2;FAUX))
Crdlmnt
Messages postés
16491
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 juillet 2021
3 200
???
regarde comment est organisée la source sur mon exemple....
Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
5 999
??? quel exemple, comprend pas, suis borné le lundi!
Messages postés
16491
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 juillet 2021
3 200
je vieillis mal!...

ci joint l'exemple
https://www.cjoint.com/?kBn5H0FWmQ
Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
5 999
Moi, j'ai un avantage sur toi, je suis déja vieux :-)
Ceci dit, effectivement ton exemple fonctionne bien.
Je maintiens quand même qu'il est utile de prévenir que cette formule ne marche bien que si les données de la première colonne sont classées.(si l'on disperse les valeurs de la colonne H dans ton tableau, la recherchev renvoie n'importe quoi!

Il semble que le demandeur puisse rencontrer ce problème, puisqu'il n'évoque pas:
_D'une part le type de référence qu'il utilise et donc comment elles peuvent se classer
_D'autre part qu'il est peut être possible que ce tableau de référence doivent évoluer dans le temps. Il sera alors possible de la rallonger sans refaire le tri à chaque fois.(le magasin peut peut-être décider uytérieurement de vendre des mangues, des ananas et des litchies)

Par ailleurs,on peut aussi conseiller de mettre en place sur la colonne B une liste déroulante basée sur la colonne I pour éviter les fautes de frappe(des fois qu'il rentre en stock des ceurises et des auranges.....si le gestionnaire des stocks tappe aussi bien que moi, va y avoir de la dispersion dans les réserves!)

Bien cordialement,

l'ancien vieux au futur vieux (Bienvenu au club.)
A+
Messages postés
16491
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 juillet 2021
3 200
OK, mais de toutes façons, pas de nouvelles du demandeur...
donc