Monter une partition au démarage d'Ubuntu [Résolu/Fermé]

Signaler
Messages postés
1661
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
27 juillet 2012
-
Messages postés
1661
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
27 juillet 2012
-
(Re)bonjour a tous,

J'ai sur mon PC 3 partitions :
/dev/sda1 => Partition Windows
/dev/sda3 => Partition Ubuntu
/dev/sda5 (étendu de /dev/sda2) => Swap

J'ai crée le dossier Windows dans /media

J'ai ajouté la ligne suivante dans /etc/fstab :
/dev/sda1 /media/Windows ntfs-3g rw, user, auto, exec 0 0
Je n'ai pas oublié le saut de ligne a la fin du fichier.

Je ne vois pas pourquoi il ne réussit pas a le monter au démarrage, et pourquoi si j'essaye de le monter après, il me dit :
[mntent]: ligne 11 dans /etc/fstab est erroné
mount: ne peut repérer /media/Windows dans /etc/fstab ou /etc/mtab

Que faire ?

3 réponses

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 522
Salut,

Affiche le résultat de
 cat /etc/fstab
Messages postés
1661
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
27 juillet 2012
564
Il m'affiche comme dans Gedit :

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda3
UUID=f6f4d469-b542-472f-9b82-5ae986825904 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda5
UUID=f32a9426-cf3d-4a8b-8b98-82bcaefa1728 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sda1 /media/Windows ntfs-3g rw, user, auto, exec 0 0
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 522
Il n'y a pas d'espace avant et après la virgule
/dev/sda1 /media/Windows ntfs-3g rw,user,auto,exec 0 0 
Regarde les autres lignes
Messages postés
1661
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
27 juillet 2012
564
Ah oui oups... Sa marche merci!
Autre petite question : Y a-t-il un moyen pour changer le nom de l'icône sur le bureau? Windows apparaît toujours comme "Média 53.7 Gio"...
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 522
Re,
sudo aptitude install ntfsprogs
sudo umount /dev/sda1 && sudo ntfslabel /dev/sda1 ntfs_part
sudo init 6

Après le redémarrage (c'est la dernière commande qui le fait) tu verras sur ton bureau le nom ntfs_part
 /!\ ATTENTION /!\
- la commande ntfslabel doit être faite sur une partition ntfs
- à ne pas exécuter sur une partition montée
Messages postés
1661
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
27 juillet 2012
564
Merci. Ceci ne risque pas d'altérer ma partition Windows ?
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 522 >
Messages postés
1661
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
27 juillet 2012

Re,

Tu n'as qu'à exécuter les commandes que je t'ai donné
Tu remarques que je démonte d'abord la partition avant de mettre le label ;-)

Si tu respectes ce que j'ai écrit dans ATTENTION tu ne risque rien.
J'ai testé chez moi la manipulation avant de te la donner ;-))
Messages postés
1661
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
27 juillet 2012
564 >
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019

Ok merci pour tout

Remarque : faut pas être doué pour toucher aux infos d'une partition alors qu'elle est montée...
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 522 >
Messages postés
1661
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
27 juillet 2012

Justement la commande que j'ai donné élimine ce risque
sudo umount /dev/sda1 && sudo ntfslabel /dev/sda1 ntfs_part
La 1ère commande va démonter la partition
Le signe && veut dire que si la 1ère commande réussi alors la 2ème sera exécutée
Le cas contraire (la 1ère commande ne réussi pas) alors la 2ème ne sera pas exécutée

Si échec pas besoin de redémarrer ;-))
Messages postés
1661
Date d'inscription
mardi 27 mai 2008
Statut
Membre
Dernière intervention
27 juillet 2012
564 >
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019

Merci pour tout