[excel]fonction recherchev réclcitrante [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
15 octobre 2008
-
 vegeta -
Bonjour,

J'ai un problème pour utiliser la fonction RECHERCHEV

Si j'ai mon tableau comme ceci

---------------
/| A | B
1|antoine | 12
2|benjamin| 10
3|Coralie | 8

Je souhaite afficher le nom du premier, celui qui a la meilleure note.
Donc je tape la fonction :


=RECHERCHEV(MAX(B1:B3);A1:B3;1;0)



Là il me renvoie une erreur, si j'avais mis la colone des notes avant la colonne des noms (et en adaptant la formule en conséquence), il ne me met pas l'erreur.

Comment faire???

Merci!!! :D

3 réponses

Messages postés
16885
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
10 107
Bonjour,

Utilise plutôt les fonctions INDEX et EQUIV :

=INDEX(A1:B3;EQUIV(MAX(B1:B3);B1:B3;0);1)

Si tu veux trouver le premier, le second, troisième, etc. utilise plutôt la fonction GRANDE.VALEUR

m@rina
les cours excel en video

http://www.litalib.com/telecharge.html
Messages postés
4
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
15 octobre 2008

Merci, ca marche, en combinant j'ai réussit à faire ce que je voulais !!

Merci pour la rapidité. Tchuss