[EXCEL] rechercher dans un tableau ?

[Fermé]
Signaler
-
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
-
Bonjour,

J'ai :
en colonne A
BEAUJON
MASSENA
CHOISY
VELIZ
NAVARIN

en colonne B
161
842
11867
11866

Je voudrai que si
C1 = MOMASSENAti alors D1 = 161
C2 = tuVELIZDC alors D2 = 11867
C3 = zzzxsnavarin alors D3 = 11866

en fait, si la cellule de la colonne C contient un une chaine qui comprend les caractères de la colonne A alors D contient la valeur correspondant en face.

Euhhh, j'espère que j'ai été clair.

Merci de vos lumiere.
PS: Une solution sans passer par un macro serai génial.

7 réponses

Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
241
bonjour

en d1 tu mets

=recherchev(C1;A:B;2;Faux)
Bonjour,

ça ne marche pas, ai je fait une erreur quelque part ?

colonne A
BEAUJON
MASSENA
CHOISY
VELIZ
NAVARIN

colonne B
161
842
11867
3333
111

colonne C
MOMASSENAti
VELIZDC
zzzxsnavarin
tototo
tatatat

colonne D
#N/A (formule '=recherchev(C1;A:B;2;Faux)')
#N/A (formule '=recherchev(C2;A:B;2;Faux)')
#N/A (formule '=recherchev(C3;A:B;2;Faux)')
#N/A (formule '=recherchev(C4;A:B;2;Faux)')
#N/A (formule '=recherchev(C5;A:B;2;Faux)')

alors que je voudrais :
colonne D
842
3333
111
......
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228
Bonjour

en D1:
=SI(NBCAR(C1)-NBCAR(SUBSTITUE(A1;C1;))>0;B1;)

à tirer vers le bas

Bonjour,

Désolé michel_m, mais tu n'a pas compris ce que je voudrais.

Regarde bien l'exemple du deuxieme message :
C1 contient MOMASSENAti
dans la colonne A, le contenu de la colonne A2 est MASSENA
MOMASSENAti contient bien la suite de lettre MASSENA
alors D1 prendra la valeur B2 (sur la meme ligne que MASSENA)
Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
241
re:, Bonjour Michel
je ne sais pas????
un fichier exemple serait necessaire, sinon une formule matricielle si j'ai compris

=Si(A$1:A$1000 = "*" & $C1 & "*"; B$1:B$1000;"#INEXISTANT")

Formule matricielle à valider en appuyant simultannement sur Ctrl + Maj + Entrée
si la validation est correcte, des {} encadrent automatiquement la formule

Ps: Michel, je donnerai ton bonjour demain
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228
re,

bin, au lieu de A1, tu mets A2 et au lieu de B1 tu mets B2!

avant de te faire une proposition, je la teste et ca marche!

je REvérifie quand m^me

Salut Wilfried

Fais aussi une bise à Brigitte et Sylvie, une grande tape dans le dos à _Thierry et MichelXLD s'il est là
Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
241
re:

michel, pas de problème, mais les dames vont croire que je suis gourmand et les mecs que je les agresses lol
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228
Une tape dans le dos A-MI-CA-LE !!!

Bonnes crèpes et chouchen!