Excel renvoyer une donnée à une date précise

[Résolu/Fermé]
Signaler
Messages postés
6
Date d'inscription
vendredi 28 décembre 2007
Statut
Membre
Dernière intervention
25 août 2008
-
Messages postés
24182
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
-
Bonjour,

J'ai élaboré un tableau sous Excel afin de gérer les cours de valeurs boursières. Je demande donc à EXCEL de me fournir parmi un ensemble de données celleS se rapportant à la valeur X à une date bien précise.
J'ai essayé RECHERCH, EQUIV, INDEX mais cela ne convient pas car à chaque fois EXCEL me renvoie la valeur correspondant à la première date mentionnée alors que je demande de m'indiquer quelle est la valeur d'une action à une date précise.
Colonne A= Nom de l'action
Colonne B= Date
Colonne C = Valeur
Toutes les valeurs se suivent jour après jour. APr exemple.
VIVENDI 22 Aout = X
VIVENDI le 25 aout = Y
VIVENDI le 26 aout = Z
Quelles formule de calcul me permettrai sur une autre feuille d'EXCEL d'extraire la valeur de VIVENDI à la date de mon choix, SVP?
Je peux transmettre si besoin le fichier EXCEL s'y rapportant.
Merci pour les pistes que vous pourrez me souffler pour sortir de ce problème.

DANY

3 réponses

Messages postés
24182
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 886
Bonsoir,

avec sommeprod() qui te calcule matrice par matrice si le test est vrai ou faux, les multiplie entre eux et fait la somme.
=SOMMEPROD((A2:A13="vivendi")*(B2:B13=CNUM("27/08/08"))*(C2:C13))

tu peux remplacer =CNUM("27/08/08") par =D2 avec la date recherchée en D2

eric
Bravo Eric!!
Merci infiniment. C'est exactement ce que je recherchais.
Je peux m'essayer à compléter le tableau en attendant de trouver d'autres difficultés.
Merci encore et bonne journée.

Dany
Messages postés
24182
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 886
De rien, bonne continuation :-)
N'oublie pas de mettre en résolu stp