Comparaison de deux feuilles excel::

Résolu/Fermé
Signaler
Messages postés
2
Date d'inscription
dimanche 2 mars 2008
Statut
Membre
Dernière intervention
27 octobre 2008
-
Messages postés
434
Date d'inscription
jeudi 7 février 2008
Statut
Membre
Dernière intervention
4 juin 2010
-
Bonjour à tous,

S'il vous plait c'est trés urgent,j'en est besoin d'un resultat rapide,

J'ai deux feuilles excel (feuil 1 et feuil 2) dont chacune contient entre autres une colonne qui contient des numero de factures, j'ai besoin d'un outil (ou bien formule avec explication ou bien macro avec explication car je suis pas bien experimenté) qui me permet de degager les numero de factures qui existe dans la feuille 1 mais non dans la feuille 2 et de placer les informations concernant cette facture(ligne toute entière) dans une 3ème feuille.
Et le meme demarche pour les numero de facture existant dans la feuille 2 mais pas dans la feuille 1 et de placer le resultat dans une 4ème feuille (feuil 4)

Merci d'avance et s'il vous plait c'est trés urgent.

4 réponses

Messages postés
434
Date d'inscription
jeudi 7 février 2008
Statut
Membre
Dernière intervention
4 juin 2010
229
Bonjour,

à essayer :

https://www.cjoint.com/?ispPDwx0mh

il y a des 0 parce que je n'ai fait que quelques essais, donc pas complet
les explication de la feuille 3 sont valables pour la feuille 4 (inverser les feuilles dans les formules)
je n'ai fait des reports que sur les colonnes B et C




Denis
0
Bonjour Denis,

Merci pour votre attention, en faite vous êtes le seul qui a essayé de m'aider .

Je veux modifié un peu l'énoncé car j'ai pas pu arrivé avec cette solution.

Maintenant j'ai deux feuilles:
Feuil1: contient en colonne B "num Facture" et en G son etat (Payé/Impayé/...)
Feuil2: contient en colonne B "num Facture" (toujours entre autres)
Je veux trouver une formule qui, pour chaque "num Facture" de Feuil2, elle teste son existence dans la feuil1 et s'il existe elle me rend son état dans une colonne L de la Feuil2 pour que je puisse dégager la différence d'état entre les deux feuilles et si le "num Fact" n'existe pas en feuil1 elle m'écrit en colonne L "Inexistant" .

Merci Beaucoup

et j'espère que les autres répondent aussi.
0
Messages postés
36
Date d'inscription
jeudi 24 août 2006
Statut
Membre
Dernière intervention
5 octobre 2011
6
Bonjour tu peux utiliser la fonction RECHERCHEV,(je suppose que dans la feuille1 les n° de facture sont uniques) mais il faudrait dans ta feuille1 "rapprocher" ta colonne G des n° de facture (en B les n° de facture, en C l'état des factures) ceci fait il faudra aussi trier le tableau de la feuille1 sur le n° de facture.
Je vais prendre comme hypothèse, que dans les deux feuilles tes n° commencent à la ligne 2 et que dans ta feuill1 les factures s'arrêtent à la ligne 300
Dans ta feuille2 en C2 entre la formule suivante:
=SI(ESTNA(RECHERCHEV(B2;Feuil1!B$2:C$300;2;FAUX));"inexistant";RECHERCHEV(B2;Feuil1!B$2:C$300;2;FAUX)) et étend la à toute la colonne.
0
Bonjour jean-pierre,

J'ai testé ta formule mais j'ai pas arrivé à une solution, j'ai obtenu des 0 et parfois un chiffre bizarre (39115),
et malgrés que j'ai fait des modifications divers en suivant une selection directe sur les feuilles et en fixant les colonnes qu'ils faux fixer mais sans arrivé.
En faite voici ma formule:
=SI(ESTNA(RECHERCHEV(B2;'Fact Exist et manq Recouv 2007'!B$2:G$973;2;FAUX));"inexistant";RECHERCHEV(B2;'Fact Exist et manq Recouv 2007'!B$2:G$973;2;FAUX))
Concernant la 2ème partie ;RECHERCHEV(B2;'Fact Exist et manq Recouv 2007'!B$2:G$973;2;FAUX)) je veux qu'elle me renvoi l'état de fact sachant qu'elle se trouve à la colonne G donc comment faire pour fixer la colonne d'ou retourne le resultat (2 ou 6 ou 7)?

Merci pour votre effort et j'attend ta reponse.
0
Messages postés
434
Date d'inscription
jeudi 7 février 2008
Statut
Membre
Dernière intervention
4 juin 2010
229
bonjour,

nouvelle mouture à essayer :

https://www.cjoint.com/?iuwIHSiecW

en L2 de la feuille 2:
=SI(NB.SI(Feuil1!B:B;Feuil2!B2)=0;"inexistant";DECALER(titre;EQUIV(Feuil2!B2;Feuil1!B:B;0)-1;5))

Denis
0
Salut Denis.L,

Merci bien pour votre aide. Ca bien marché.



Coordialement,
0
Messages postés
434
Date d'inscription
jeudi 7 février 2008
Statut
Membre
Dernière intervention
4 juin 2010
229
STP si c'est bon, met le post en résolu.
merci




Denis
0