Liste déroulante semie automatique [Résolu/Fermé]

Signaler
Messages postés
343
Date d'inscription
mercredi 29 août 2007
Statut
Membre
Dernière intervention
12 mars 2012
-
Messages postés
3
Date d'inscription
vendredi 19 décembre 2008
Statut
Membre
Dernière intervention
21 décembre 2008
-
Bonjour,
J'ai essayé d'adapter une formule trouvée sur le net (voir fichier https://www.cjoint.com/?irjCgWBSMi
Le truc c'est que j'ai essayé de l'adapter à une liste déroulante "dynamique" (liste dont la source change en fonction d'une autre liste déroulante).
N'ayant pas vraiment compris les subtilités de la formule que j'ai pompé :
=SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMME((STXT(l_noms;1;NBCAR(A1))=TEXTE(A1;"0"))*1));l_noms)
en remplaçant A1 par l'identification de la première cellule sélectionnée.
J'ai évidemment du mal à l'adapter.

Si quelqu'un maîtrise bien le sujet, je suis preneur.
Merci

2 réponses

Messages postés
343
Date d'inscription
mercredi 29 août 2007
Statut
Membre
Dernière intervention
12 mars 2012
28
Re,
J'aiurais pas dû coller une parenthèse sur mon lien. Voici de nouveau le lien :
https://www.cjoint.com/?irjCgWBSMi
Merci
Messages postés
343
Date d'inscription
mercredi 29 août 2007
Statut
Membre
Dernière intervention
12 mars 2012
28
Re,
C bon, j'ai trouvé, le truc était tout bête, juste remplacer :

=SI(B5<>"";DECALER(debut;EQUIV(B5&"*";list;0)-1;;SOMME((STXT(list;1;NBCAR(B5))=TEXTE(B5;"0"))*1));list)

par

=SI(B5<>"";DECALER(list;EQUIV(B5&"*";list;0)-1;;SOMME((STXT(list;1;NBCAR(B5))=TEXTE(B5;"0"))*1));list)
Messages postés
3
Date d'inscription
vendredi 19 décembre 2008
Statut
Membre
Dernière intervention
21 décembre 2008

Bonjour,
B5 dans ton exemple fait reférence à quelle place dans ta feuille.
est-ce que tu pourrais svp m'envoyer un fichier car je suis bloqué sur cette partie
Merci