[Linux Ubuntu] aMsn 0.97.2 --> Pb d'install ?

Résolu/Fermé
Signaler
Messages postés
4590
Date d'inscription
jeudi 23 octobre 2003
Statut
Contributeur
Dernière intervention
6 septembre 2021
-
 kevin -
Bonjour,

Je n'arrives pas à installer la nouvelle version de aMsn 0.97.2 sous Linux Ubuntu 8.04 ?
Désolé pour le détail, mais j'ai essayé 2 méthodes mais sans succès.

Tout d'abord, j'ai exécuté les mises à jour du système :

- sudo apt-get update
- sudo apt-get upgrade

1ère méthode d'install :
--------------------------------

1°) Je me suis occupé du logiciel aMsn existant, j'ai désinstallé la version 0.97 via le gestionnaire de paquetages

2°) Téléchargement et décompression du fichier :

amsn-0.97.2.tar.bz2
cd /usr/local/aMsn_0.97.2

--> Problème d'installation .??
./configure

root@tux-laptop:/usr/local/aMsn_0.97.2# ./configure
checking for prefix by checking for wish... /usr/bin/wish
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking tcl build dir... using tcl library in /usr/lib/tcl8.4
checking tk build dir... using tk library in /usr/lib
./configure: line 3611: /usr/lib/tkConfig.sh: No such file or directory


Que faut-il que j'installe, et comment faire ?

2ème méthode d'install :
--------------------------------

A partir amsn-0.97.2-1.tcl85.x86.package
1°) Install
Le processus d'install s'est achevé mais un problème est apparu.

2°) Pb d'exécution :
Loading TkCximage failed. This module is needed to run aMSN.
Please compile aMsnfirst, instructions on how to compile are located in the file INSTALL.


Contenu du fichier INSTALL

In order to install amsn, or even to be able to launch it, you will need to compile it first.
To do so, you must first configure the package by executing the command
> ./configure
You must have the tcl-dev and tk-dev packages installed on your system, please refer to your system package management software or website in order to find these packages and to install them prior to running the ./configure script.
Once the configure script finished without any error, you can proceed with the compilation, it is as simple as typing :
> make
You can now launch amsn by typing
> ./amsn
Or you can install it with the command
> make install
Then you can use the
> amsn
command to launch future sessions of amsn.
You can also create a .deb and .rpm package by launching respectively the command
> make deb
and
> make rpm

For any other help, please refer to the FAQ at http://www.amsn-project.net/wiki/FAQ or the wiki at http://www.amsn-project.net/wiki/Main_Page or the website at http://www.amsn-project.net/ or visit the forums of amsn at http://www.amsn-project.net/forums/ but make sure you search for an answer to your question before asking it, it might have already been answered.

have fun.


De ce fait, j'ai vérifié la présence de tcl & tk

apt-get install tcl-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
tcl-dev est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
unixodbc odbcinst1debian1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

apt-get install tk-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
unixodbc odbcinst1debian1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
libice-dev libsm-dev libxt-dev tk8.4-dev
Paquets suggérés :
tk-doc tk8.4-doc
Les NOUVEAUX paquets suivants seront installés :
libice-dev libsm-dev libxt-dev tk-dev tk8.4-dev
0 mis à jour, 5 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 1409ko dans les archives.
Après cette opération, 4153ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ?

La version de TCL & TK sont 8.4, comment installer les VERSIONS 8.5 ?

apt-get install tk8.5-dev

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
tk8.5-dev est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
unixodbc odbcinst1debian1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

apt-get install tcl8.5-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
tcl8.5-dev est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
unixodbc odbcinst1debian1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.


apt-get autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
unixodbc odbcinst1debian1
Les paquets suivants seront ENLEVÉS :
odbcinst1debian1 unixodbc
0 mis à jour, 0 nouvellement installés, 2 à enlever et 0 non mis à jour.
Après cette opération, 1090ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ?

(Lecture de la base de données... 134805 fichiers et répertoires déjà installés.)
Suppression de unixodbc ...
Suppression de odbcinst1debian1 ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place

Installation de aMsn_0.97.2

./configure
checking for prefix by checking for wish... /usr/bin/wish
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking tcl build dir... using tcl library in /usr/lib/tcl8.4
checking tk build dir... using tk library in /usr/lib/tk8.4
checking for main in -lstdc++... yes
checking how to run the C preprocessor... gcc -E
checking for X... libraries , headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for png_read_info in -lpng... no
configure: error: libpng is required


--> package install amsn-0.97.2-1.tcl85.x86.package

/usr/bin/amsn

Même constat qu'avec la première méthode !!!

Comment résoudre ce problème d'installation ?

6 réponses

Messages postés
4590
Date d'inscription
jeudi 23 octobre 2003
Statut
Contributeur
Dernière intervention
6 septembre 2021
496
Bonjour,

J'ai réussi à installé aMsn 0.97.2 avec le paquetage amsn-0.97.2-1.tcl84.x86.package


Les versions de TK & TCL sont 8.4.

Comment puis-je les mettre à jour TK & TCL vers la version 8.5 ?

1
j'ai le même problème que toi...
0
merci a tous garce a vaus conseil j'ai réussi a instaler amsn
gros bisous est merci du fond du coeur
0
Messages postés
84
Date d'inscription
jeudi 12 juillet 2007
Statut
Membre
Dernière intervention
21 mai 2010
21
Si qelqu'un a une solution, peut_il me la partager ? SVP.
Merci d'avance,
Cordialement,
Bidi62
-1
Messages postés
4590
Date d'inscription
jeudi 23 octobre 2003
Statut
Contributeur
Dernière intervention
6 septembre 2021
496
Bonjour,

Le problème a été résolu grâce à la commande "apt-get install" + noms progrmmes :

tcl 8.5.4 : http://www.tcl.tk/software/tcltk/download.html
tk 8.5.4

--> amsn 0.97.2
http://www.amsn-project.net/linux-downloads.php

Choisir la version selon ta distribution Linux

BONNE CHANCE
-1