[excel]comment contrôler la saisie des numéro

[Résolu/Fermé]
Signaler
Messages postés
233
Date d'inscription
dimanche 15 mai 2005
Statut
Membre
Dernière intervention
26 novembre 2011
-
Messages postés
233
Date d'inscription
dimanche 15 mai 2005
Statut
Membre
Dernière intervention
26 novembre 2011
-
Bonjour,
je suis entrains de créer un fichiers excel qui contient plusieurs numéro de téléphones. Mon souci est que je ne souhaiterai pas saisir un numéro déjà existant donc j'aimerais avoir une sorte de message d'erreur qui m'indique que telle ou telle numéro existe déjà ou autre chose ...
et merci d'avance.

2 réponses

Messages postés
4802
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
9 septembre 2021
4 263
Bonsoir,
Avant de les faire rougir tu peux aussi les interdire avec :
Données/Validation/Autoriser : personnalisé.
Dans la formule demander dans la zone que tu veux définir, ici de A2 à A50 par exemple :
=NB.SI($A$2:$A$50;A2)<2
Tu auras un message de rejet à chaque donnée déjà trouvée.

Bonne soirée.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Bonsoir,
La solution la plus pratique et la plus rapide est d'utiliser une mise en forme conditionnelle

Selectionner la colonne où doivent être inscrits les N° (Ici l'exemple en colonne A)
Faire
Format
Mise en forme conditionnelle
La formule est
=NB.SI(A:A;$A1)>1
Format
Motif
rouge par exemple
Les deux "doublons" vont rougir lors de la validation de la saisie

Bonne fin de soirée

@+ LM
Messages postés
233
Date d'inscription
dimanche 15 mai 2005
Statut
Membre
Dernière intervention
26 novembre 2011
26
ça marche, je te remercie cher ami