Fonction multi conditionnelle sur Excel 2002

Résolu/Fermé
-
Messages postés
55453
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 janvier 2022
-
Bonjour,

Je travaille sur Excel 2002, et je peine à trouver une fonction me permettant de trouver le nombre de cellules répondant à plusieurs conditions:

Par exemple, en tenant compte du tableau ci dessous, la 1° condition serait "les cellules B1 à B11 = 1
2° condition: les cellules C1 à C11 = JK
3° condition: les cellules D1 à D11 = "soleil"

Le résultat que je désirerais faire apparaitre en case D14 par ex serait donc de 2. Mais comment écrire la fonction équivalente sur Excel 2002 ?



A	 B	C	D	E	F

X 1	 1	JK	Soleil	Lune	Soleil
X 2	 1	OP	Lune	Soleil	Lune
X 3	 2	OP	Soleil	Etoile	Soleil
X 4	 3	JK	Etoile	Soleil	Etoile
X 5	 3	JK	Soleil	Lune	Etoile
X 6	 1	JK	Lune	Soleil	Soleil
X 7	 2	OP	Soleil	Etoile	Etoile
X 8	 2	JK	Etoile	Etoile	Etoile
X 9	 2	OP	Etoile	Soleil	Etoile
X 10	 1	JK	Soleil	Lune	Soleil
X 11	 3	OP	Lune	Lune	Lune<code>





Bien sûr, un tableau croisé dynamique , ou l'utilisation de filtres successifs me donnerait le résultat. Et cela de façon trés simple. Mais, dans mon cas précis, je ne veux pas utiliser ces 2 fonctions, d'où ma difficulté.

Merci pour vos précieux conseils.

4 réponses

Messages postés
433
Date d'inscription
dimanche 17 février 2008
Statut
Membre
Dernière intervention
17 octobre 2008
309
Bonjour,
la fonction SOMMEPROD devrait marcher avec Excel 2002.
Tu l'emploies comme suit :
=SOMMEPROD((B1:B11=1)*(C1:C11="JK")*(D1:D11="soleil"))
I.
Super !!!!

Ca marche du feu de dieu !!!

Merci beaucoup Chevalier
Messages postés
55453
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 janvier 2022
17 226
Une astuce consiste à utiliser une colonne vide, Z:Z par exemple, et d'y saisir la formule
=B:B & C:C & D:D
ce qui donnerait comme résultats 1JKSoleil, 1OPLune, etc.
et en D4 tu saisis simplement
=NB.SI(Z1:Z11;"1JKsoleil")

Pour faciliter ta saisie (mais peut-être l'as-tu déjà prévu ainsi) tu peux insérer des listes déroulantes en B14, C14 et D14 contenant respectivement les données 1;2;3 - JK;OP - Etoile;Lune;Soleil.
La formule en D4 devient alors =NB.SI(Z1:Z11;B14&C14&D14)

... ça te convient ?
Messages postés
4244
Date d'inscription
lundi 31 mars 2008
Statut
Contributeur
Dernière intervention
8 décembre 2021
795
Bonjour,
Moi je l'écrirais comme cela :

=SI(ET(B3=1;C3="JK";D3="Soleil");2;"")

Mais je ne suis pas sur d'avoir compris ta question en totalité
Le resultat que je désire voir apparaitre, est le nombre de cellules sur la colonne D, qui répondent aux 3 critères. Je pense qu'il me faut partir de la fonction "NB.SI".
Sur une version récente de Excel, il existe une fonction "NB.SI.ENS" qui semble permettre cela, mais pas sur ma version.