Lame mp3 et windows media player 11

Résolu/Fermé
Signaler
Messages postés
104
Date d'inscription
lundi 21 janvier 2008
Statut
Membre
Dernière intervention
6 juillet 2017
-
 Jerome -
bonjour
Comment faire pour que Windows Media 11 encode avec Lame mp3 au lieu de FhG lorsque j'extrait un CD audio ?
(SVP ne me parlez pas de CDex ou les autres logiciels de ce genre, je connais.)
merci.

13 réponses

Messages postés
104
Date d'inscription
lundi 21 janvier 2008
Statut
Membre
Dernière intervention
6 juillet 2017
20
lorsque j'encode en mp3 avec WMP il le fait avec l'encodeur mp3 "fhg" et moi je veux qu'il le fasse avec l'encodeur "lame mp3" (je sais qu'il encode avec "fhg" en regardant avec le logiciel "encspot" )
Comment faire pour encoder avec "lame mp3" et pas avec "FhG" ???
Messages postés
104
Date d'inscription
lundi 21 janvier 2008
Statut
Membre
Dernière intervention
6 juillet 2017
20
svp de l'aide !!
Messages postés
104
Date d'inscription
lundi 21 janvier 2008
Statut
Membre
Dernière intervention
6 juillet 2017
20
quelqu'un a t-il la solution
Messages postés
104
Date d'inscription
lundi 21 janvier 2008
Statut
Membre
Dernière intervention
6 juillet 2017
20
personne... ?
Messages postés
128
Date d'inscription
samedi 29 septembre 2007
Statut
Membre
Dernière intervention
21 avril 2015
20
Si je comprend bien tu veu extraire en mp3 tes Cd audio avec WMP ? Eh bien eh bien que d'histoire pour rien ^^
Tu ouvre WMP tu clic sur Extraire = et tu as une toute petite fleche blache en dessus de Extraire, tu clic sur celle ci, tu va dans formater puis tu choisis mp3 !!!! =D
Messages postés
128
Date d'inscription
samedi 29 septembre 2007
Statut
Membre
Dernière intervention
21 avril 2015
20
Eh mince dsl tu vois bien de toute facon la flèche ? ^^ elle est en dessous jé loupé le o =X
Messages postés
128
Date d'inscription
samedi 29 septembre 2007
Statut
Membre
Dernière intervention
21 avril 2015
20
dsl pour l'écriture sms je vais faire un effort =X dsl comment ca marche
Messages postés
104
Date d'inscription
lundi 21 janvier 2008
Statut
Membre
Dernière intervention
6 juillet 2017
20
oui je sais mais c'est pas ça. wmp il encode avec "FhG" et moi je veux qu'il encode avec "Lame MP3"
Messages postés
128
Date d'inscription
samedi 29 septembre 2007
Statut
Membre
Dernière intervention
21 avril 2015
20
telecharge lame mp3, prend le fichier qui encode les mp3 c'est un fichier .dll
Messages postés
104
Date d'inscription
lundi 21 janvier 2008
Statut
Membre
Dernière intervention
6 juillet 2017
20
Ok mais wmp il encode automatiquement avec FhG, pas avec lame mp3 !
Messages postés
104
Date d'inscription
lundi 21 janvier 2008
Statut
Membre
Dernière intervention
6 juillet 2017
20
Il n'y a pas de solutions alors ?
Pour les débutants en informatique comme moi mais amateurs de musique de qualité qui souhaitent encoder en MP3 avec Lame tout en utilisant Lecteur Windows Media (Windows Media Player) : voici la méthode à suivre, ça demande un peu de bidouillage.

Je précise avant toute chose que mon système d'exploitation est Windows Vista, donc j'utilise Windows Media Player (WMP pour faire plus simple) version 11. De plus, il faut avoir l'accès administrateur pour modifier un fichier système. J'ai trouvé la combine en visitant ce site https://support.microsoft.com/en-us/help/306494 mais ici je détaille la procédure.


1ère étape : Il faut tout d'abord trouver le codec pour Lame au format .acm (c'est ce format qui est utilisé par WMP et pas le format .dll ) sur Internet. Il est disponible à cette adresse : https://www.free-codecs.com/lame_acm_codec_download.htm?f=lame_acm_codec_download
Une fois le dossier téléchargé, trouvez le fichier lameACM.acm et placez le dans le dossier System32 de votre ordinateur, dans le chemin suivant : C:\Windows\System32

2ème étape : Le problème est que, pour encoder vos fichiers ou CD en MP3, WMP utilise le codec Fraunhofer IIS (codec d'origine, moins performant) et ne permet apparemment pas d'en changer pour Lame.
Cette configuration ne se fait pas en utilisant les options de WMP mais en modifiant le logiciel à partir d'un éditeur de registre (fichier au format .exe ) qui est celui-ci : regedit , à cet emplacement de votre ordinateur : C:\Windows (si vous ne le trouvez pas, faites une recherche de fichiers).
Ouvrez ce fichier, donnez votre autorisation lorsqu'on vous demande l'accès administrateur. Dans la fenêtre vous voyez l'arborescence de dossiers à gauche.
Ouvrez le dossier HKEY_LOCAL_MACHINE en double-cliquant dessus, puis SOFTWARE - Microsoft - MediaPlayer - Settings et enfin MP3Encoding
Dans la fenêtre centrale, il y a alors 7 fichiers.
C'est le dernier qui nous intéresse surtout : PreferredCodecPath , double-cliquez dessus.
Une petite fenêtre apparaît, dans le champs "Données de la valeur" tapez le chemin suivant : C:\Windows\System32\lameACM.acm , c'est là que se trouve le fichier codec .acm
Si vous le voulez, vous pouvez configurer les autres fichiers : changer le nom du codec avec PreferredCodecName , changer les bitrates d'encodage...
Enfin, quittez regedit, l'éditeur de registre. Il n'est pas nécessaire d'enregistrer quoi que ce soit, fermez la fenêtre tout simplement.


La prochaine fois que vous encoderez avec WMP, vos fichiers MP3 seront de meilleure qualité !


Si ça ne marche pas, essayez d'insérer le codec au format .dll en plus dans System32
Il faut tout trouver le codec au format .dll pour Lame sur Internet à cette adresse : https://www.01net.com/telecharger/windows/Multimedia/encodeurs_et_decodeurs/fiches/19740.html
Sinon recherchez "LAME" sur le site "www.01net.com".
Une fois téléchargé, placez le fichier lame_enc.dll dans le dossier System32 comme précédemment et réessayez.

Si ça ne marche toujours pas, je ne peux plus rien pour vous !
Messages postés
104
Date d'inscription
lundi 21 janvier 2008
Statut
Membre
Dernière intervention
6 juillet 2017
20 > Lorenzen
waow ! super ça marche !
merci beaucoup !
Je confirme cela fonctionne même sur la version RC1 de Windows 7 (Seven). Merci beaucoup !!! :)
Super ! Ca marche nickel, et ca fait longtemps que je voulais mixer la qualité de lame avec la facilité de WMP...
Merci !
Alors je révise un peu mon post précédent. Certes, ca marche dans le sens où il utilise bien lame pour encoder, mais ça fait planter mon WMP toutes les 2 min en encodage... Pas facile pour encoder un CD complet ! :-) Je suis sous XP Pro.
Est-ce que vous avez le même problème ? Vous avez quel OS ?