Probleme de droit bizarre [Résolu/Fermé]

Signaler
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
-
 tuxce -
SAlut,

j'essayes de mettre en place sur ma machine un serveur FTP avec VSFTPD.
j'ai mis en place l'userlist pour filtrer quels comptes j'autorises a se loguer sur le FTP

userlist_enable=YES
userlist_deny=NO
userlist_file=/etc/vsftpd.userlist

et à la tentative de connection, toujours la même erreur :

Status:	Connection established, waiting for welcome message...
Response:	500 OOPS: cannot open user list file:/etc/vsftpd.userlist 
Error:	Critical error
Error:	Could not connect to server


pourtant,
[root@kronstadt soviet]# ls -l /etc/vsftpd.userlist
-rw-r--r-- 1 root root 12 mai  6 02:44 /etc/vsftpd.userlist


même chose en chownant ce fichier à l'utilisateur ftp.
Quelqu'un aurait-il une idée parce que là je dois avouer que je sèche :)
Merci d''avance.

14 réponses

Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
709
bon .....

une bonne âme à l'oeuil acéré sur irc m'a fait remarquer qu'il y avait un espace en trop A LA FIN de cette ligne :

userlist_file=/etc/vsftpd.userlist

voila quoi, merci à tous pour votre aide :)
moi je vais me pendre et je reviens :/
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 837
Comme quoi on est à la merci d'un petit rien du tout ;-(

Enfin, le principale c'est que ce soit réglé ;-))

Tu t'es pas pendu pour de vrai, hein ?

Petit jeu du pendu...
Trouver le mot :

e----e

;-DDD
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 522
Salut,

affiche le résultat de
 ps aux | grep ftp
--
106485010510997108
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
709
lut lamij o/

[root@kronstadt soviet]# ps aux | grep ftp
soviet   19078  0.0  0.3   4936  1536 ?        Ss   01:29   0:00 /usr/lib/ssh/sftp-server
root     19749  0.0  0.1   3580   880 pts/0    S    02:59   0:00 /usr/sbin/vsftpd
root     19771  0.0  0.1   3764   888 pts/0    S+   03:25   0:00 grep ftp

Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
709
Edit: je precise jsute qu'en desactivant l'userlist, ça marche très bien.
Messages postés
2572
Date d'inscription
vendredi 1 avril 2005
Statut
Contributeur
Dernière intervention
6 septembre 2008
370
Salut,

tu as adapté ton vsftpd.pam ?
les exemples du site parle de ce fichier, c'est peut être utile :)

ftp://vsftpd.beasts.org/users/cevans/untar/vsftpd-2.0.6/EXAMPLE/
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
709
'l'ut marc,
merci pour ce lien qui bien qu'en anglais m'a l'air assez complet.
Cependant je n'utilise pas du tout PAM sur cette machine et je vois mal quoi faire avec ce fichier. Il ne me semble pas que l'authentification par PAM soit obligatoire avec VSFTPD.
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 522
Re,

affiche quand même le fichier
/etc/pam.d/vsftpd

mets les droits à 777 pour voir si ça change quelque chose ;-))
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
709
j'avais dejà essayé le coup des droits à 777 mais ca n'avais rien donné (j'ai quand même réessayé par acquis de conscience mais rien)
pas

pas de fichier vsftpd dans /etc/pam.d/ , ni rien qui y ressemble

[root@kronstadt soviet]# cat /etc/pam.d/vsftpd
cat: /etc/pam.d/vsftpd: Aucun fichier ou r��pertoire de ce type

[root@kronstadt soviet]# ls /etc/pam.d/
chage chgpasswd chsh groupdel groupmod newusers passwd shadow su userdel
chfn chpasswd groupadd groupmems login other screen sshd useradd usermod

Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 837
Salut,

Moi ce qui me pose problème c'est la compréhension des directives associées.
Je m'explique. En prenant référence sur cette page et à ceci :
userlist_deny — Lorsque cette option est utilisée de concert avec la directive userlist_enable et que sa valeur est NO, tous les utilisateurs locaux se voient refuser l'accès à moins que le nom d'utilisateur ne figure dans le fichier spécifié par la directive userlist_file. Étant donné que l'accès est refusé avant même que le client ne puisse saisir son mot de passe, le choix de la valeur NO pour cette directive empêche les utilisateurs de soumettre des mots de passe non cryptés sur le réseau.

La valeur par défaut est YES.

userlist_enableLorsque cette option est activée, les utilisateurs mentionnés dans le fichier spécifiés par la directive userlist_file se voient refuser l'accès. Étant donné que l'accès est refusé avant même que le client ne puisse saisir son mot de passe, les utilisateurs n'ont pas la possibilité de soumettre des mots de passe non cryptés sur le réseau.

Bien que la valeur par défaut soit NO, sous StartCom Enterprise Linux la valeur est YES.

userlist_file — Spécifie le fichier référencé par vsftpd lorsque la directive userlist_enable est activée.

la valeur par défaut est /etc/vsftpd.user_list. 
Si je comprends encore bien le français et si je m'en tiens à ce qu'il y a d'écrit ci-dessus, et compte tenu de la config de ton fichier "vsftpd.conf", tu devrais voir ton accès refusé ;-((

Cette directive s'adresse qu'aux comptes locaux apparemment, non ?

Dites-moi que j'ai bien compris et que je suis pas encore bon pour la retraite ;-))

PS. C'est toi qui a créé le fichier "vsftpd.userlist" (rapport à ce que dans la doc il est nommé "vsftpd.user_list" avec un underscore) ?
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
709
Salut Jipicy,
oui c'est bien cela :
l'user a un compte local sur la machine et son nom est bien dans ce fichier afin qu'il ait le droit de se loguer.
(c'est bien moi qui est créé le fichier vsftpd.userlist et je lui indique par la directive userlist_file=/etc/vsftpd.userlist, le nom de fichier avec l'underscore et juste le nom donné par defaut quand il n'est pas specifié :)
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 837 >
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008

le nom de fichier avec l'underscore et juste le nom donné par defaut quand il n'est pas specifié
Ça encore je l'avais bien compris (chuis pas entièrement neuneu encore ;-D )

Ce qui me pose problème(dans la compréhension) c'est bien :
userlist_enable — Lorsque cette option est activée, les utilisateurs mentionnés dans le fichier spécifiés par la directive userlist_file se voient refuser l'accès

;-\

C'est bien le contraire que tu veux ?
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
709 >
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020

oui, que l'on obtient de la sorte :

userlist_deny — Lorsque cette option est utilisée de concert avec la directive userlist_enable et que sa valeur est NO, tous les utilisateurs locaux se voient refuser l'accès à moins que le nom d'utilisateur ne figure dans le fichier spécifié par la directive userlist_file

:-)
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 837 >
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008

Oui ça aussi je l'avais bien pigé, mais pour mon petit cerveau ils auraient du préciser pour la directive "userlist_enable" :
Lorsque cette option est activée, les utilisateurs mentionnés dans le fichier spécifiés par la directive userlist_file se voient refuser l'accès, sauf lorsque cette option est utilisée de concert avec la directive userlist_deny.

;-))
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
709 >
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020

je te rassures, il m'a aussi fallu une bonne demi-heure ce matin pour comprendre la subtile alchimie qui opere entre ces 2 options ;-)
Messages postés
1542
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 avril 2016
154
Fait bien attention, car il me semble qu'il y a une directive à la biip a ajouter, sinon par défaut l'accès est REFUSE a tous les utilisateurs dans ton fichier vsftp.userlist.
Solution dans ce cas, reprendre tout le contenu de /etc/shadow et enlever les utilisateurs autorisés en ftp
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
709
excuses-moi, mais je ne comprend pas très bien ce que tu veux dire.
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 837
Peux-tu afficher ton fichier de conf en entier, peut être y descellerons-nous un ch'tit truc qui t'aurait échappé et qui perturbe les directives userlist_* ?
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
709
bonne idée :

# Example config file /etc/vsftpd.conf
#
# Use this to use vsftpd in standalone mode, otherwise it runs through (x)inetd
listen=YES
listen_port=21
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
#write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
nopriv_user=ftp
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
ftpd_banner=Welcome on your .USELESS-NETWORK FTP account.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
chroot_local_user=YES
chroot_list_enable=YES
# (default follows)
chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
ls_recurse_enable=NO

dual_log_enable=YES

#ssl_enable=YES
#ssl_tlsv1=YES

userlist_enable=YES
userlist_deny=NO
userlist_file=/etc/vsftpd.userlist 
#only user in this file can log-in

max_per_ip=5 
#not more than 5 conncetion per ip allowed


Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 522
Ben, le boulot ne m'as pas vraiment permis de suivre la discussion ;-) (j'avoue aussi que c'est aussi la paresse, vu que jipicy à pris le relais ;-))

moi je vais me pendre et je reviens :/

Non, ne le fait pas, laisse nous ce plaisir ;-DDDDDDDDDDDDDDDDDDDDDD
Messages postés
3616
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
8 juillet 2008
709
oué bin d'abord les devs ils avaient qu'à coder un truc qui parse le fichier de conf correctement d'abord :D
et puis je vous merde ;D
d'un autre coté, si tu veux vraiment l'espace... :)
mais bon, effectivement, il aurait pu mettre un message d'erreur plus explicite, genre entourer le nom de fichier par des guillemets.