Excel Masque le 0 des formules

[Résolu/Fermé]
Signaler
-
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
-
Bonjour,

Dans mon classeur Excel j'ai 5 feuilles. Certaines cellules de ces feuilles sont liées avec la formule =feuille1!C12 (par exemple)

Le problème est que sur ma feuille 2 (où figure la formule) apparait un 0 tant que je n'entre pas de données dans la feuille 1.
Comme mon tableau fait 50 lignes, ça me fait 50 0 qui apparaissent et ce n'est pas franchement beau, et je vous explique même pas à l'impression!

Est-ce possible de masquer ces 0 ?

Merci d'avance

Aquarelle

2 réponses

Messages postés
11
Date d'inscription
dimanche 30 mars 2008
Statut
Membre
Dernière intervention
11 janvier 2021
32
bonjour
je n'ai plus excell mais je l'ai utilisé pendant longtemps et je crois me souvenir
c'est pareil que dans Open office calc
il faut aller dans les options et décocher la case "valeurs zéro " dans affichage
a+
Merci!! Tu as bonne mémoire!

C'est nettement mieux!

Merci beaucoup!
Bonjour,

Tu peux aussi modifier ta formule plutôt que de décocher la valeur zéro.
Car si tu enlève la valeur zéro, tu l'enlèves sur TOUTE le feuille et pas seulement sur ton tableau.
Autrement tu peux écrire cette formule:

=si(feuille1!C12="";"";feuille1!C12)

Puis faire une copie dans toutes les cellules ou tu en as besoin.

DAN'
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 090 > DAN'
Bonjour DAN
Vous avez entièrement raison, mais toutefois, il faut se méfier de cette option. Si les cellules concernées sont ensuite utilisées dans des calculs suivants, certaines formulations ne fonctionnent pas avec le code ""!
par exemple:
=SOMME(A1:A4)va marcher même si A2 est ""
mais A1+A2+A3+A4, pourtant identique, renvoie"#VALEUR" .
CRDLMNT