[fedora] configuration sendmail

Bonjour,

J'essaie d'apprivoiser sendmail ....juste pour voir si j'y arrive !

pour l'instant je vois pas d'erreur (mais ça ne saurait tarder !).

les liens qui m'ont aider :
https://doc.fedora-fr.org/wiki/Configurer_sendmail_:_envoyer_des_mails_via_le_relay_stmp.free.fr
https://forums.fedora-fr.org/viewtopic.php?pid=120423
http://www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-email-mta.html

petit rajout :
https://forums.fedora-fr.org/viewtopic.php?id=20961

pour l'instant pas de question .....mais ça ne saurait tarder ....

:-))

--
Un Linux, c'est bien ...........plein de Linux, c'est mieux !
Debian lenny  // Fedora 8 // Gentoo 2007-rc8 // Mandriva 2007.1 Spring...
Configuration: Linux
Mozilla 1.9

17 réponses

  1. petite synthèse :

    installation du paquetage sendmail-cf

    $ su -
    # yum install sendmail-cf


    modifications fichier /etc/hosts :

    [root@fedora8 redfox]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 fedora8 localhost localhost.localdomain
    ::1 localhost6.localdomain6 localhost6
    192.168.1.2 fedora8

    [root@fedora8 redfox]#

    modifications fichier /etc/mail/sendmail.mc :

    root@fedora8 redfox]# vi /etc/mail/sendmail.mc
    VERSIONID(`Installation Personnel')dnl

    define(`SMART_HOST',`smtp.fournisseur.fr')

    GENERICS_DOMAIN(fedora8 localhost localhost.localdomain)dnl

    FEATURE(`genericstable')dnl

    MASQUERADE_AS(`fournisseur.fr')dnl

    FEATURE(masquerade_envelope)dnl


    création du fichier /etc/mail/genericstable:

    [root@fedora8 redfox]# cat /etc/mail/genericstable :
    redfox login@monfai.fr
    [root@fedora8 redfox]#

    prise en compte des modifications :

    [root@fedora8 redfox]# cd /etc/mail/
    [root@fedora8 mail]# make
    [root@fedora8 mail]# /sbin/service sendmail restart
    Arrêt de sm-client : [ OK ]
    Arrêt de sendmail : [ OK ]
    Démarrage de sendmail : [ OK ]
    Démarrage de sm-client : [ OK ]
    [root@fedora8 mail]#

    0
    1. apparemment j'arrive à envoyer un courrier via la console :

      [redfox@fedora8 ~]$ mail monlogin@monfai.fr
      Subject: hhhhhh
      hhhhhhh
      Cc:
      [redfox@fedora8 ~]$

      ...mais le fichier /var/log/maillog me dit : "452 4.3.1 Insufficient system storage"
      une explication possible (voir probable) ici :
      http://www.commentcamarche.net/forum/affich 792616 outlook probleme n arrive plus a envoyer

      FIN ! (parce que, sendmail, c'est prise de tête tout de même !)
      0
      1. Client host rejected: AP0002 Please use your ISP mailserver / Veuillez utiliser le serveur SMTP de votre FAI

        bon j'abandonne ! mon FAI semble bloquer volontairement !
        0
        1. bonjour,

          Je pense que j'ai vu la configuration de sendmail en long, en large et en travers !
          J'envoie et reçois des mails en local sans souci !

          par contre je n'arrive toujours pas à envoyer un mail en passant par mon FAI avec invariablement la réponse suivante :
          Client host rejected: AP0002 Please use your ISP mailserver / Veuillez u
          tiliser le serveur SMTP de votre FAI


          mon FAI est 9telecom/club-internet !

          tant pis !

          si quelqu'un à la solution (juste pour savoir si c'est possible avec mon FAI). moi j'ai "tout" essayé ! merci !

          de toute façon moi j'arrête là avec sendmail !

          :-))
          0
          1. HOURRA !!!!!!!!!!!!!!!

            j'ai réussi !

            j'ai suivi CE tuto spécial fedora8 (en anglais) et ........................ ça marche !!!!!!!!!
            http://optics.csufresno.edu/~kriehn/fedora/fedora_files/f8/howto/sendmail.html

            ce site est une excellente référence pour les Fédoriens !

            et lorsque je fais :

            [redfox@fedora8 ~]$ mail monlogin@monfai.fr

            ...................je ne me fais pas éjecter par mon FAI !

            yahooooooooooooooooooooo ! trop content je suis !

            :-))

            faut dire que j'en ai bavé !
            0
            1. Bonjour,

              Moi j'ai un problème, j'envoie les mail facilement, mais ce sont les autres fournisseurs, gmail, caramail... qui refuse les mail.
              A cause des spam....
              Si il y a une solution, je doute mais bon....
              0
              1. ERRATA :

                en fait je n'arrive toujours pas à envoyer un mail via sendmail et mon FAI (cf post<10>)
                j'ai cru réussir ........mais non !

                le fichier maillog me renvoit éternellement "stat=Service unavailable" !

                j'arrête les frais .....

                FIN !
                0
                1. sendmail + fail2ban = OK !

                  [root@fedora8 log]# cat secure* | grep "Invalid"
                  May 15 08:17:52 fedora8 sshd[5365]: Invalid user ftpuser from 200.2.252.18
                  May 15 08:17:57 fedora8 sshd[5370]: Invalid user user from 200.2.252.18
                  May 15 08:17:59 fedora8 sshd[5372]: Invalid user mailer from 200.2.252.18
                  [root@fedora8 log]#

                  je reçois bien un mail de confirmation :

                  Sujet: [Fail2Ban] SSH: banned 200.2.252.18
                  Date: Thu, 15 May 2008 08:18:01 +0200

                  Hi,

                  The IP 200.2.252.18 has just been banned by Fail2Ban after
                  5 attempts against SSH.

                  Here are more information about 200.2.252.18:

                  [Requête en cours whois.lacnic.net]
                  [whois.lacnic.net]

                  % Joint Whois - whois.lacnic.net
                  % This server accepts single ASN, IPv4 or IPv6 queries

                  % Copyright LACNIC lacnic.net
                  % The data below is provided for information purposes
                  % and to assist persons in obtaining information about or
                  % related to AS and IP numbers registrations
                  % By submitting a whois query, you agree to use this data
                  % only for lawful purposes.
                  % 2008-05-15 03:19:55 (BRT -03:00)

                  % Too many clients. Please, try again later.

                  % whois.lacnic.net accepts only direct match queries.
                  % Types of queries are: POCs, ownerid, CIDR blocks, IP
                  % and AS numbers.

                  Regards,

                  Fail2Ban


                  j'avais laissé le port 25 ouvert ! grosse boulette ! corrigée ! :-)

                  0
                  1. j'avais laissé le port 25 ouvert

                    le port 22 plutôt !!!

                    [root@fedora8 log]# cat secure* | grep invalid
                    May 15 06:17:49 fedora8 sshd[5363]: input_userauth_request: invalid user ftp
                    May 15 06:17:52 fedora8 sshd[5366]: input_userauth_request: invalid user ftpuser
                    May 15 06:17:54 fedora8 sshd[5368]: input_userauth_request: invalid user mail
                    May 15 06:17:57 fedora8 sshd[5371]: input_userauth_request: invalid user user
                    May 15 06:17:59 fedora8 sshd[5373]: input_userauth_request: invalid user mailer

                    [root@fedora8 log]# cat secure* | grep Invalid
                    May 15 08:17:52 fedora8 sshd[5365]: Invalid user ftpuser from 200.2.252.18
                    May 15 08:17:57 fedora8 sshd[5370]: Invalid user user from 200.2.252.18
                    May 15 08:17:59 fedora8 sshd[5372]: Invalid user mailer from 200.2.252.18
                    0
                    1. Bonjour

                      ça serait sympa si tu nous donnait tes dernieres modif et en particulier sendmail.mc

                      en fait comme sur tes 1er posts

                      Merci d'avance
                      0
                    2. @lemarecsalut,

                      désolé mais j'ai malencontreusement écrasé ma partition fedora !

                      :-(
                      0
                  2. je reprends mes essais avec la Fedora9 et sendmail.

                    il semble que l'envoi de messages soit possible :
                    [redfox@fedora9 ~]$ mail monlogin@monfai.fr

                    fichier /var/log/maillog :
                    Nov 27 21:10:16 fedora9 sendmail[5767]: mARKAGpd005767: to=root,monlogin@monfai.fr, ctladdr=redfox (500/500), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=60069, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (mARKAGJk005769 Message accepted for delivery)

                    je réceptionne bien le message avec evolution via mon compte monlogin@monfai.fr

                    en fait j'ai créé un compte redfox pour le local (messagerie evolution) :
                    type de serveur : "Distribution locale" pour la réception de message
                    type de serveur : "SMTP" (avec pour login "monlogin") pour l'envoi de message.

                    ...et là .... ça marche !
                    0
                    1. ..et là .... ça marche .........; toujours pas pour envoyer un mail en ligne de commande via sendmail vers mon adresse monlogin@monfai.fr

                      je pensais que cela avait fonctionné mais ... non ! toujours le même message d'erreur :
                      Client host rejected: AP0002 Please use your ISP mailserver / Veuillez utiliser le serveur SMTP de votre FAI
                      554 5.0.0 Service unavailable
                      <<< 554 5.5.1 Error: no valid recipients


                      tant pis !
                      0