La derniere valeur dans une colonne [Résolu/Fermé]

Signaler
-
 lysou63 -
Bonjour,
savoir qelle est la derniere valeur dans une colonne avec excel

10 réponses

Messages postés
16196
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
3 septembre 2020
3 020
Bonjour Eric,Vaucluse

Une alternative avec une fonction personnalisée:

Function derlig(col As String)
derlig = Range(col & Range(col & "65536").End(xlUp).Row)
End Function

Autres possibilités par formule (au cas où)

si il n'y a que des textes
=recherchev(car(255);A:A;1)

si il n'a que des nombres
=recherchev(9^9;A:A;1)
71
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60839 internautes nous ont dit merci ce mois-ci

> Haze le Kfar
Merci pour cette formule, c'est ce qu'il me fallait. bravo.
merci beaucoup. =recherchev(car(255);A:A;1) fonctionne super
simple et efficace. Que du bonheur après pas mal de recherches!
=recherchev(9^9;A:A;1) Fonctionne A1! Simple et efficace. Merci beaucoup!
super génial mille merci
un grand merci c'est exactement ce que j'avais besoin! :)
Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
5 434
Bonjour
Deux options pour vous dépanner ci dessous:

1° votre colonne de référence n'a pas de trou et vous cherchez la dernière valeur entrée:

Utilisez une colonne hors champs , admettons la colonne X.Nous supposons que vos valeurs à détecter sont dans la colonne A
En B1:
=SOMME(X:X)
En X1
:SI(A2=0;A1;0)
Tirez cette formule sur la hauteur du champ, ainsi B1 vous renverra la dernière valeur de la colonne , (où la somme de celle qui précéde des trous dans la colonne!!!!)
___________________________________________
2° votre colonne a des cellules vides avant la derniére:

Il faut admettre ici que la colonne A a ses limites, admettons pour l'exemple: A1 à 1000 (à vous de réaligner!)
Dans la colonne X en X1 rentrez la formule
=SI(ESTNUM(A2);0;A1)*SI(SOMME(A2:$A$1000)=0;1;0)
Ainsi vous n'aurez en B1 que le renvoi de la cellule qui n'a pas de "suite" dans la colonne A
Attention au blocage de la deuxième partie de la formule, la cellule A2 doit rester évolutive qunad vous la tirez sur la hauteur du champ
Bien entendu, vous pouvez placer cette formulation dans une colonne masquée, voire sur une feuille masquée pour ne pas perturber vos mises en page
Bien cordialement
Messages postés
16196
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
3 septembre 2020
3 020
re,

Merci Vaucluse, je suis tout colorindex=3 ...

mais je me suis planté!!!

au lieu de:
=recherchev(car(255);A:A;1)
il faudrait écrire
=rechercheV("zzzzzzzzzzzz";A:A;1)

Bon dimanche
Michel
Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
5 434
Pas de problème, je n'ai traité que la valeur numérique, dans mon essai....!!!!!!
Errare humanum est, comme disaient de vieux copains à moi, et au moins, cela confirme le bien fondé de ma signature!
Bien cordialement
Messages postés
52215
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 septembre 2020
13 986
Ah bon ? Pas dans mes tests !
Bye.
Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
5 434
Salut Raymond
ci joint pour exemple
http://www.cijoint.fr/cjlink.php?file=cj200802/cij2526731825520.xls
SLT
Messages postés
16196
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
3 septembre 2020
3 020
Bonjour,

Suis en plein boulot (Merise, Mcd....SQL) sponsorisé par Doliprane

Je mettrai un mot ce soir at home si je suis pas trop crevé; j'aurais du faire jardinier!

Amicalement
Michel
Messages postés
16196
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
3 septembre 2020
3 020
Re,

Ci joint petite démo sur le problème d'Eric, sans réponse à nos propositions, mais peut-être parti rejoindre Raymond aux antilles pour mieux étudier une solution

https://www.cjoint.com/?czsZZ1UYlp

Bonsoir ou bonjour

Michel
Messages postés
16196
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
3 septembre 2020
3 020
re,re

après la soupe...

Bon sang, mais c'est bien sûr!!!

Formule matricielle (à valider pat Ctrl+maj+entrée)

=INDEX(plage;MAX(SI(plage<>"";LIGNE(plage)))-1)

plage est ici B2:Bx...

A+
Michel
Merci beaucoup! ça fonctionne bien!
Messages postés
52215
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 septembre 2020
13 986
Si je ne me trompe, cela ne marche que si la colonne A est triée ? La formule renvoie en effet la valeur la plus grande de la liste, pas la dernière !
Amitiés.
Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
5 434
Salut Raymond
Doit avoir erreur, là.......
Chez moi, cela marche avec la dernière valeur quelque soit celles entrées dans la colonne, et qu'il y ai des vides ou non dans la liste!
Bien cordialement

Messages postés
4
Date d'inscription
dimanche 15 janvier 2012
Statut
Membre
Dernière intervention
27 janvier 2012
3
Dans Libre office cela marche avec:
=RECHERCHE("z";A1:A4999)

"z" : indique dernière valeur
A1:A4999 : de la cellule A1 à la cellule A4999
c'est un exemple, au lieu de A4999 ce peut être A6500 ou peut-être plus

idem pour une ligne, en remplaçant A1:A4999 par A8:ZZ8 (par exemple)

Ne pas mettre la formule à la fin de la colonne ou de la ligne de la recherche