Probleme d'accent page web (UTF-8 ISO-8859-1) [Résolu/Fermé]

Signaler
Messages postés
82
Date d'inscription
samedi 29 décembre 2007
Statut
Membre
Dernière intervention
20 août 2008
-
 serrhini -
Bonjour,
Je cree un nouveau forum car j'ai compris quelque chose de nouveau donc je peu reformuler:
J'ai cree un site web,dans mon ordinateur prenons par exemple la page 1 je l'ouvre avec firefox et l'affichage est en iso-8859-1 jusque la tout va bien.Cependant une fois que j'ai envoyer mes fichiers a mon hebergeur lorsque je vais sur mon site via le web le texte s'affiche bizarrement genre les accent et les apostrophe sont remplacer par des "?".
A ce moment je regarde dans affichage encodage des caracteres et je remarque la ligne UTF-8 cochee.Je la decoche mon probleme est regler.
Mais des que je me reconecte ou que je change de page l'affichage revien par default UTF-8.
Que faire pour que l'affichage par default sur tous ce qui visitent mon site soit en ISO-8859-1.

24 réponses

J'arrive un peut tard, mais j'ai le même probléme, j'ai tout essayer dans les posts précedents et c'est toujours pareil, quand j'analyse mon site, j'ai que des accents.....
j'ai essayé ca aussi
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
et aussi de modifier le htacess....
merci de votre aide
Bonjour,
je connais quelques diffciultés à bien afficher mon site, en faite j'ai defini utf-8 comme charset de mes pages, et j'ai remplacé les accents par leurs équivalent en code. Sur le site le resultat est nickel mais quand je regarde le code source sur le naviagteur evidement je trouve le code par exemple (à,...) et je me demandais si d'abord c'était normale et si elle a un impact sur le réferencement de mon site. merci
Bonjour,

tu utilises quoi IIS lighttpd ou tu ouvres directement t pages web depuis ton systeme de fichiers ?

merci de poster une question clair, car la tu as un discours "ca marche pas" sans expliquer le contexte pour nous permettre de comprendre ton problème.

sinon tu peux ajouter des entetes html dans ta page html.

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

Cdt,

Steph
Merci beaucoup pour le conseil apache avec le .htaccess

Ça marche nikel !



Fichier .htaccess avec la ligne suivante AddDefaultCharset ISO-8859-1
Salut !
je me demande ou je peus trouver le fichier de configuration .htaccess?

j'ai cherché dans Program Files\Apache Software Foundation mais j'ai pas trouvé le fichier
jais le meme problemme avec mon site !! http://www.chat18.fr.ht/