[Debian] ssh et commande scp [Résolu/Fermé]

Signaler
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
Bonjour,

voilà tout est dit !

192.168.1.2 = mandriva
192.168.1.3 = debian

les 2 machines sont connectées à un routeur ! la commande ssh fonctionne pour les 2 machines ....mais si je veux copier un fichier d'une machine à l'autre :

redfox@mandriva:~/Desktop$ scp -v redfox@192.168.1.3:/home/redfox/Desktop/fichier .

ça ça fonctionne !! c'est-à-dire que j'ai bien le fichier sur le Bureau mandriva

..........mais :

redfox@debian:~/Desktop$ scp -v redfox@192.168.1.2:/home/redfox/Desktop/fichier .

ça , ça fonctionne pô ! c 'est-à-dire que je n'ai pas le fichier sur le Bureau debian !

et pourtant rien d'anormal dans le mode verbeux ! c'est identique à celui de la mandriva excepté que je dois valider "Entrée" pour retrouver le prompt !
une idée svp ?

merci.

:-))

25 réponses

Messages postés
29880
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 juin 2021
7 121
Ce message signifie que pour un host (identifié sur son hostname ou son IP selon la manière dont tu t'es connecté en ssh), la clé publique ne correspond plus. Comme tu le sais sûrement ssh repose sur un système de clé publiques et privées.
https://fr.wikipedia.org/wiki/Secure_Shell

Tu as sûrement remarqué que la première fois que tu te connectes sur une machine en ssh, on te donne son fingerprint et on te demande si c'est bon (et en général on tape yes sans réfléchir). Cette étape sert en fait en gros à te demandé : penses tu que cette machine est vraiment celle qu'elle prétend être. Si tu réponds oui, ça veut dire que tu penses que tout est ok et par la suite on ne te demandera plus cette confirmation. Celle si est stockée en fait dans ~/.ssh/known_hosts

... jusqu'au jour où ton client ssh s'aperçoit que les fingerprints ne correspondent plus (ce qui est ton message d'erreur). Ceci peut survenir quand le serveur ssh auquel tu te connectes a été réinstallé (et utilise donc une autre clé publique). Autre cas de figure tu te connectes par exemple à mando@192.168.1.10, mais cette IP est donnée en DHCP et n'est plus attribuée à la même machine. Dernière possibilité (d'où le message de ssh) la machine en question se fait intercepter son trafic, ou ta machine a été piratée et n'est plus routée vers la machine que tu crois... d'où le message d'erreur.

Si tu es dans l'un des deux premier cas de figure, une simple suppression de ~/.ssh/known_hosts suffit.

En espérant que ça t'a éclairé...
11
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 861
Sans vouloir en rajouter... pourquoi détruire le fichier "known_hosts", il arrive bien souvent qu'il y ait plusieurs clés dedans, donc juste commenter (ou supprimer) la ligne faisant référence à l'hôte en question, non ?
Messages postés
29880
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 juin 2021
7 121
A mon avis, c'est simplement que le serveur ssh sur debian n'est pas installé ou lancé, seul le client est installé ! En root :
aptitude update
aptitude upgrade
aptitude install openssh-server
/etc/init.d/ssh start

La dernière commande est a priori superflue car debian lancera automatiquement ssh (ainsi qu'à chaque redémarrage).

Bonne chance
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
tu sors .... -DDDDD
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 861
Ok, mais ça me dis pas quand même si ça marche ou pas ? ;-DDDDDDD
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469 >
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020

je vois que tu coules du nez .... allumes le chauffage, c.n !!!!

ben comme la fédora est sur une partition et la gentoo sur une autre partition et tout ça sur le même DD que la Mandriva ...ça va être chaud pour faire du ssh entre ..... -DDDDDDD
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
redfox@debian:~/Desktop$ scp -v redfox@192.168.1.2:/home/redfox/Desktop/fichier .
Executing: program /usr/bin/ssh host 192.168.1.2, user redfox, command scp -v -f /home/redfox/Desktop/fichier
OpenSSH_4.3p2 Debian-9, OpenSSL 0.9.8c 05 Sep 2006
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to 192.168.1.2 [192.168.1.2] port 22.
debug1: Connection established.
debug1: identity file /home/redfox/.ssh/identity type -1
debug1: identity file /home/redfox/.ssh/id_rsa type 1
debug1: identity file /home/redfox/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.6
debug1: match: OpenSSH_4.6 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3p2 Debian-9
debug1: An invalid name was supplied
Cannot determine realm for numeric host address

debug1: An invalid name was supplied
A parameter was malformed
Validation error

debug1: An invalid name was supplied
Cannot determine realm for numeric host address

debug1: An invalid name was supplied
A parameter was malformed
Validation error

debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '192.168.1.2' is known and matches the RSA host key.
debug1: Found key in /home/redfox/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /home/redfox/.ssh/identity
debug1: Offering public key: /home/redfox/.ssh/id_rsa
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /home/redfox/.ssh/id_dsa
debug1: Next authentication method: password
redfox@192.168.1.2's password:
debug1: Authentication succeeded (password).

debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = fr_FR.UTF-8
debug1: Sending command: scp -v -f /home/redfox/Desktop/fichier
Sink: This is BASH 3.1 - DISPLAY on :0.0
This is BASH 3.1 - DISPLAY on :0.0
redfox@debian:~/Desktop$ Sending file modes: C0644 18111 fichier
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: channel 0: free: client-session, nchannels 1
debug1: fd 0 clearing O_NONBLOCK
debug1: fd 1 clearing O_NONBLOCK
debug1: Transferred: stdin 0, stdout 0, stderr 0 bytes in 0.3 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 0.0
debug1: Exit status 1

et là ça reste bloqué et je fais "Entrée" pour retrouver le prompt
redfox@debian:~/Desktop$
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
Bonjour,

aptitude install openssh-server me dit qu'il n'y a rien à installer !

et

redfox@debian:~/Desktop$ apt-file search openssh
openssh-client: usr/lib/openssh/ssh-keysign
openssh-client: usr/share/doc/openssh-client/NEWS.Debian.gz
openssh-client: usr/share/doc/openssh-client/OVERVIEW.gz
openssh-client: usr/share/doc/openssh-client/README
openssh-client: usr/share/doc/openssh-client/README.Debian.gz
openssh-client: usr/share/doc/openssh-client/README.dns
openssh-client: usr/share/doc/openssh-client/README.tun.gz
openssh-client: usr/share/doc/openssh-client/changelog.Debian.gz
openssh-client: usr/share/doc/openssh-client/changelog.gz
openssh-client: usr/share/doc/openssh-client/copyright
openssh-client: usr/share/lintian/overrides/openssh-client
openssh-server: usr/lib/openssh/sftp-server
openssh-server: usr/share/doc/openssh-server


ça fait pas un peu léger pour le "server" ???

:-))
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 542
Salut,

la commande ssh fonctionne pour les 2 machines

on s'en fous ;-))

affiche le résultat de
 ps aux | grep ssh
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
redfox@debian:~/Desktop$ ps aux | grep ssh
redfox 2593 0.0 0.1 4124 476 ? Ss 19:47 0:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session x-session-manager
root 23788 0.0 0.4 4916 1056 ? Ss 21:39 0:00 /usr/sbin/sshd
redfox 24470 0.0 0.2 2876 748 pts/1 R+ 22:04 0:00 grep ssh
redfox@debian:~/Desktop$

:-))
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 542
aussi sur mandriva mon brave ;-)))
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
[bob 25] Desktop > ps aux | grep ssh
root 3836 0.0 0.0 5116 920 ? Ss 18:42 0:00 /usr/sbin/sshd
redfox 4353 0.0 0.0 4552 688 ? Ss 18:43 0:00 ssh-agent
root 5734 0.0 0.0 4552 664 ? Ss 20:03 0:00 ssh-agent
redfox 5965 0.0 0.0 3044 752 pts/1 R+ 21:12 0:00 grep --color ssh
[21:12 1.50]
[bob 26] Desktop >

et voici pour la Man
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 861 >
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014

C'est pô les mêmes ;-((

redfox@mandriva:~/Desktop$
et
[bob 25] Desktop >
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469 >
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020

tu as le nez qui coule ...mais tu as l'oeil qui brille ! je vois que tu as remarqué ...mais ça change rien à mon problème ! :-)

:-))
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 861
Question : Mais est-ce que ça marche entre Gentoo et Fedora et réciproquement ???










































=>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> ;-))
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 542
affiche ce que tu vois à l'écran quand tu tapes
redfox@debian:~/Desktop$ scp -v redfox@192.168.1.2:/home/redfox/Desktop/fichier . 
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
je reprendrai plus tard !

un grand merci à mamiemando, lami20j et un grand grand grand grand grand merci à jipicy pour son .....soutien moral :-))

ps jipicy : par contre le ssh fedora -> debian et gentoo -> debian fonctionne très bien (pas encore essayé la commande scp)

Bonne nuit les petits ! -:)

:-))
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
RESOLU !

Vous allez me killer (kill -9) ! C'était mon fichier .bashrc (mandriva) bidouillé à l'origine du souci !
Je viens de remettre le fichier .bashrc (mandriva) d'origine et cette fois tout marche nickel pour la debian !

Désolé !

:-))
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 861
killall bob031 && reset && rm -fr /head/cerval && logout
;-DDD
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
je dois vraiment taper tout ça ???? -DDDDDDD


Allez tchôôô !!! :-)
Messages postés
29880
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 juin 2021
7 121
Par rapport à <2>
(mando@aldur) (~) $ apt-file list openssh-server
openssh-server: etc/default/ssh
openssh-server: etc/init.d/ssh
openssh-server: etc/pam.d/ssh
openssh-server: usr/lib/openssh/sftp-server
openssh-server: usr/lib/sftp-server
openssh-server: usr/sbin/sshd
openssh-server: usr/share/doc/openssh-server
openssh-server: usr/share/man/man5/sshd_config.5.gz
openssh-server: usr/share/man/man8/sftp-server.8.gz
openssh-server: usr/share/man/man8/sshd.8.gz

Donc non, il y a bien tout ce qu'il faut :-)
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
merci pour les indications ! en effet :

redfox@debian:~$ apt-file list openssh-server
openssh-server: etc/default/ssh
openssh-server: etc/init.d/ssh
openssh-server: etc/pam.d/ssh
openssh-server: usr/lib/openssh/sftp-server
openssh-server: usr/lib/sftp-server
openssh-server: usr/sbin/sshd
openssh-server: usr/share/doc/openssh-server
openssh-server: usr/share/man/man5/sshd_config.5.gz
openssh-server: usr/share/man/man8/sftp-server.8.gz
openssh-server: usr/share/man/man8/sshd.8.gz
redfox@debian:~$


ce qui est moins "léger" que ce que je voyais avec ma "mauvaise" commande ! :-)

:-))
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
ASTUCES :

j'ai parfois ceci :

redfox@debian:~$ ssh redfox@192.168.1.2
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
bc:64:dc:cb:aa:f3:3e:f2:59:4c:8b:81:e2:d3:ac:2f.
Please contact your system administrator.
Add correct host key in /home/redfox/.ssh/known_hosts to get rid of this message.
Offending key in /home/redfox/.ssh/known_hosts:1
RSA host key for 192.168.1.2 has changed and you have requested strict checking.
Host key verification failed.


pour régler le problème taper la commande suivante :
cat /dev/null > /home/redfox/.ssh/known_hosts


normalement cela suffit !

si vous avez ceci :

redfox@debian:~$ cat /dev/null > /home/redfox/.ssh/known_hosts
bash: /home/redfox/.ssh/known_hosts: cannot overwrite existing file
redfox@debian:~$

alors taper la commande suivante :
cat /dev/null >| /home/redfox/.ssh/known_hosts


redfox@debian:~$ cat /dev/null >| /home/redfox/.ssh/known_hosts
redfox@debian:~$ ssh redfox@192.168.1.2
The authenticity of host '192.168.1.2 (192.168.1.2)' can't be established.
RSA key fingerprint is bc:64:dc:cb:aa:f3:3e:f2:59:4c:8b:81:e2:d3:ac:2f.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.1.2' (RSA) to the list of known hosts.
Password:
Last login: Sat Dec 29 20:11:51 2007 from 192.168.1.3

redfox@localhost ~ $


source :
http://www.gentoo.org/news/en/gwn/20040614-newsletter.xml
6. Tips and Tricks

:-))
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
mamiemando
c'est beaucoup plus clair ! Merci. :-)

pour préciser : j'obtiens ce message dans le sens Debian -> Mandriva/Fedora/Gentoo !
je pense que c'est parce que je passe d'une distribution à l'autre et Debian "y comprend plus rien" !

jipicy
juste commenter (ou supprimer) la ligne faisant référence à l'hôte en question, non ?

whouaaaaaaa ! j'ai déjà jeté un oeil dans le fichier (mais vraiment survolé) : pour moi c'est indéchiffrable !

:-))
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 861
Ben chaque clé commence par le nom de la machine ou son adresse IP. Suffit de rajouter un "#" devant ce nom (ou IP) et le tour est joué...

;-))
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 542
j'ai déjà jeté un oeil dans le fichier (mais vraiment survolé) : pour moi c'est indéchiffrable !

quel b******u :-))))

il ne faut pas le lire, juste commenté ;-DDDD

pour chaque host il y a une seule ligne, mais vu qu'elle est très longue, tu la vois sur plusieurs lignes à l'écran.

tu peux t'acheter un écran avec de la taille d'un terrain de foot pour voir les entrées sur une seule ligne ;-DDDDDDDDDDDD

tu n'as qu'à utiliser les touches Debut et Fin pour attendre le début de la ligne ou la fin (au cas où tu n'as pas compris)

;-DDDDDDDDDDDDDDDDDDDDDDDdd


Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 861
Quand tu auras fini de te moquer d'un pôvre toulousain en perdition dans la capitale, tu pourras t'atteler à la tâche, noméo !!! ;-)))
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
lami20j
pour chaque host il y a une seule ligne, mais vu qu'elle est très longue, tu la vois sur plusieurs lignes à l'écran
c'est exactement ça ! ok, je viens de piger (enfin je crois) tu veux dire que c'est toute la ligne que je dois commenter ???

tu peux t'acheter un écran avec de la taille d'un terrain de foot
j'en ai déjà un ! -DDDDDDD

jipicy
Quand tu auras fini de te moquer d'un pôvre toulousain en perdition dans la capitale

merci ! -DDDDDDDDDDDD


bon je verrai ça ce soir à la maison ...

:-))
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 542 >
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014

tu veux dire que c'est toute la ligne que je dois commenter ???

Non, que la moitié ;-DDDDDDDDDDDDDDDDDD


Alle je ferai un effort d'être sérieux ;-)

Tu fait comme t'a dit jipicy, tu te mets au début de la ligne et tu mets un # (c'est pareil comme pour /etc/apt/sources.list par exemple)
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469 >
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019

merci Chef ! :-)

:-))
Messages postés
29880
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 juin 2021
7 121
Ca casse :-)
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
Ca casse ........grave, même ! -DDDDDD
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
pour ma pomme :
une discussion passionnante :
Securing OpenSSH Server
http://web.archive.org/web/*/https://debian-administration.org/article/573/Securing_OpenSSH_Server__Part_1

:-))
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 542
on attends la traduction ;-))
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469 >
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019

en gros :
faut faire joujou avec les options du fichier /etc/ssh/sshd_config ... :-)
*) rootlogin désactivé
*) PasswordAuthentication no
*) AllowGroup
*) AllowUsers

et aussi :
*) NetFilter bien sûr !
*) modifier le port 22 ...ok contre le scaning automatique ....mais c'est pas la panacée !
*) denyhost / allowhost
*) les authentifications (public / private keys, ....
*) le port-knocking
*) authentification opiekey/skey

ensuite on attaque les trucs de "fou" ...
*) le sshjumphost
Joerg Jaspert: Using a SSH jumphost
http://www.opentechs.org/index.php/2007/12/15/joerg-jaspert-using-a-ssh-jumphost/



un truc sympa :

history|awk '{print $2}'|awk 'BEGIN {FS="|"} {print $1}'|sort|uniq -c|sort -rn|head -10