Exce count nbre cellule sans doublons critere [Résolu/Fermé]

Signaler
-
Messages postés
23401
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
13 mai 2020
-
Salut à tous,
J'ai un nouveau problème.
Je désire compter le nombre de cellule en fonction de 2 critères. Le problème si situe au niveau des cellules à compter car il y a des boublons donc le résultat est faussé.
Ci-dessous un exemple :
dossier dispo sexe age
589462 P 1 21
590534 P 1 43
590534 P 1 43
591043 P 1 38
591043 P 1 38
591043 P 1 38
600000 P 1 46
777777 P 2 18

Voila, je désire compter le nombre de dossier ayant comme critères 1 (le sexe) et comme age <45 (pour l'age).

Le total de dossier ayant comme sexe à 1 et comme age inférieur à 45 devrait être : 3

PS : je ne désire pas utiliser les tableau croisé dynamique.

Encore merci pour votre aide.

Philippe.

5 réponses

Messages postés
23401
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
13 mai 2020
6 160
Bonjour,
Ah ok, c'est un peu plus compliqué:
=SOMMEPROD(($C$1:$C$8=1)*($D$1:$D$8<45)*(EQUIV($A$1:$A$8;$A$1:$A$8;0)=LIGNE($A$1:$A$8)))

eric
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 86943 internautes nous ont dit merci ce mois-ci

Messages postés
23401
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
13 mai 2020
6 160
Bonsoir

=SOMMEPROD(($C$1:$C$8=1)*($D$1:$D$8<45))

mais le résultat est 6, pas 3 !

eric
Bonjour, merci pour cette réponse mais le soucis, c'est que je ne désire pas comptabiliser plusieus fois le même dossier, donc le résultat doit être 3.

589462 P 1 21 - compatibiliser 1 fois

590534 P 1 43 - compatibiliser 1 fois
590534 P 1 43 - déjà compatibiliser

591043 P 1 38 - compatibiliser 1 fois
591043 P 1 38- déjà compatibiliser
591043 P 1 38 - déjà compatibiliser

Merci,

Philippe
Bonjour,

La formule marche nickel par contre je désirai récuperer les vaeurs des 2 critères 1 et <45 à partir d'autres cellules.

=SOMMEPROD(($C$1:$C$8=1)*($D$1:$D$8<45)*(EQUIV($A$1:$A$8;$A$1:$A$8;0)=LIGNE($A$1:$A$8)) )

Pour 1 par de problème, par contre je ne vois comment faire pour le <45 sachant que je désire garder le <

A B
sexe age
67 1 <45

=SOMMEPROD(($C$1:$C$8=A67)*($D$1:$D$8=B67)*(EQUIV($A$1:$A$8;$A$1:$A$8;0)=LIGNE($A$1:$A$8)) )

Cette formule me retourne 0

Encore merci
Messages postés
23401
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
13 mai 2020
6 160
Bonjour,

Ton test < doit rester dans la formule et dans B67 tu mets 45.
Et c'est mieux d'écrire tes references en absolu avec des $ si tes cellules sont fixes des fois que tu sois amené à utiliser la recopie incrémentée.
=SOMMEPROD(($C$1:$C$8=$A$67)*($D$1:$D$8<$B$67)*(EQUIV($A$1:$A$8;$A$1:$A$8;0)=LIGNE($A$1:$A$8)))
eric