Excel Recherche verticale et concatener

Résolu/Fermé
Signaler
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour,
J'ai 2 feuilles excel avec 3 colonnes Collectif, compte, et solde.
Je dois comparer les soldes des 2 feuilles.
L'entité unique me permettant la comparaison est la concaténation collectif compte.
Si je conatène dans les 2 feuilles compte et collectif et que je fais ma recherche V après c'est OK.
Mais je voudais "inclure la concaténation" dans la recherche V et ça ne marche pas.
Merci de votre aide

1 réponse

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 569
bonjour

Effectivement la recherchev avec concaténation ne peux pas fonctionner.

Je te propose de le faire avec une formule matricielle
=SOMME((Feuil2!$A$2:$A$65000=A2)*(Feuil2!$B$2:$B$65000=B2)*(Feuil2!$C$2:$C$65000))-C2
à valider par ctrl + Majuscule + Entrée simultanément 

c'est une formule à saisir en D2 de la Feuil1 car j'ai supposé que tu avais une ligne titre.

Elle calcule la différence entre :
-les soldes (colonne C) de la feuille 2 dont
les collectifs (colonne A) et les comptes (colonne B) sont égaux à ceux de la ligne de la feuille 1
- et le solde de la ligne de la feuille 1.

Cette formule peux bien sûr être recopiée sur les lignes nécessaires car les cellules lignes sont évolutives et les matrices fixes.
Si tu décoches l'affichage des valeurs zéro, tu n'auras que les différences.