Comparaison Fichiers Excel

Résolu/Fermé
Utilisateur anonyme - 1 nov. 2007 à 18:31
 Utilisateur anonyme - 29 oct. 2008 à 09:48
Bonjour,
J'ai 2 fichiers Excel qui sont presque identiques (mêmes données sur 5 colonnes) SAUF environ une cinquantaine de lignes de plus dans le second...
Comment comparer ces deux fichiers, soit tels quels, soit en copiant/collant le second dans le premier de facon à faire ressortir UNIQUEMENT les lignes supplémentaires du second

Excel 97 ou 2000

9 réponses

fourvin
Messages postés
270
Date d'inscription
lundi 19 mars 2007
Statut
Membre
Dernière intervention
2 février 2012
102
1 nov. 2007 à 19:02
Bonsoir,

le plus simple est de construire une colonne sur ta deuxième feuille, dont les cellules comportent une formule du type :

=SI(<cellule sur feuille1>=<cellule sur feuille2>;"";"différence")
0
eriiic
Messages postés
24408
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
23 juin 2022
7 090
1 nov. 2007 à 19:10
Bonjour,

Fabrique toi une clé en colonne A qui te permet de différencier toutes les lignes.
Par exemple A1=A2 & A3 & A4, et tu recopies vers le bas la formule. Le tout est d'avoir une valeur différente sur chaque ligne, peut-être que tu as déjà une colonne qui rempli directement cette condition.
Tu le fais sur ta feuille1 et sur ta feuille2.
Sur la feuille2 dans une colonne tu inscris: =SI(ESTERREUR(RECHERCHEV(A1;Feuil1!A1:A24;1;FAUX));"nouveau";"") et tu recopie vers le bas.
Tu mets un filtre automatique et sur cette colonne tu sélectionnes 'nouveau'.

Je n'ai pas tout détaillé, re-post si tu as des difficultés.
Ou sinon déposes ton fichier sur www.cijoint.fr et colles le lien ici

eric
0
Utilisateur anonyme
1 nov. 2007 à 19:14
@ fourvin
Ca peut pas marcher car en fait la cinquantaine de lignes en plus sont intercalées entre les lignes communes
Si je trie sur les colonnes " A", jusque la ligne 10 (par exemple) c'est pareil et ensuite la ligne 11 est identique à la 12 de la seconde feuille car un nouvel élément s'est intercalé
0
Utilisateur anonyme
1 nov. 2007 à 19:25
eriic si tu pouvais détailler sur cet exemple ce serait sympa

exemple avec les 2 fichiers sur la même feuille

0.18187 48.40729 // 0.18187 48.40729
-0.1833 47.15429 // -0.1833 47.15429
0.18498 45.85405 // -0.19694 48.46028
-0.19694 48.46028 // 0.19741 46.75871
0.19741 46.75871 // -0.22635 48.95809
-0.22635 48.95809 // 0.233 48.4828
0.233 48.4828 // 0.23435 48.05815
0.23435 48.05815 // 0.24301 46.6312
0.24301 46.6312 1 // -0.25498 45.67028

Les lignes 1 et 2 idem ensuite la 4 c'est la 3 à droite car une donnée supplémentaire est insérée etc
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
eriiic
Messages postés
24408
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
23 juin 2022
7 090
1 nov. 2007 à 21:07
Voici un exemple pour traiter ton pb:
http://www.cijoint.fr/cij44196260730433.xls

eric
0
Utilisateur anonyme
2 nov. 2007 à 11:03
Ca marche !! (appel à des formules que je ne maîtrise pas )
Merci eriic

0
eriiic
Messages postés
24408
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
23 juin 2022
7 090
2 nov. 2007 à 11:42
De rien,
Ne perd plus le nord maintenant ;-)
eric
0
goa
Messages postés
78
Date d'inscription
dimanche 24 octobre 2004
Statut
Membre
Dernière intervention
21 mars 2009

29 oct. 2008 à 04:30
Bonjour à toutes et tous.
Je travaille pour une ONG, nous disposons de plusieurs ordi et nous balladons avec des clefs USB...
Nos fichiers sont des fichiers excel sur lesquels nous listons médocs et dispositifs medicaux.
Comment mettre a jour automatiquement sur nos ordi le dernier fichier?
En un mot sur ma clefUSB je viens de charger le fichier excel mis à jour (augmentation des données)
Comment en rentrant chez moi et mettant ma clef USB, mettre mon fichier (non a jour)...à jour automatiquement???
J'ai l'impression de ne pas etre clair......
Merci de m'aider et bonne journée.
Goa
0