Probleme de calcul sur calc

Résolu
enyx210 Messages postés 2 Date d'inscription dimanche 16 juin 2024 Statut Membre Dernière intervention 18 juin 2024 - 16 juin 2024 à 23:45
enyx210 Messages postés 2 Date d'inscription dimanche 16 juin 2024 Statut Membre Dernière intervention 18 juin 2024 - 18 juin 2024 à 18:55

Bonjour,

J aurai besoin de votre aide pour résoudre une condition sur calc je souhaite dans une cellule avoir la condition suivant: si cellule I44 est supérieur a 25 alors calcul sinon I44 est égal ou inférieur a 25 alors conservé I44. les deux formule fonctionne dans des cellules séparée mais je n arrive pas a les réunir en une seul, il me dit soit err509 soit err507 selon ce que je change.

voici la formule: =SI.CONDITIONS(I44>25;(F59-(F59*0,02*(I44-25))));(I44>=25;I44)

=SI.CONDITIONS(I44>25;(F59-(F59*0,02*(I44-25)))) comme mentionné plus haut cette formule seule fonctionne ainsi que celle qui suit =SI.CONDITIONS(I44>=25;I44).

si quelqu'un peut m apporté la réponse, c est la première fois que je me sers de calc c est surement une erreur bête.

merci

Windows / Firefox 123.0

A voir également:

3 réponses

Raymond PENTIER Messages postés 58546 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 21 juillet 2024 17 148
17 juin 2024 à 02:52

Bonsoir.

Oui, c'est une erreur bête : Remplace >= par <=


eriiic Messages postés 24585 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 27 juin 2024 7 227
17 juin 2024 à 12:54

Bonjour à tous,

en fait, un seul test suffit.
S'il n'est pas >25 il est obligatoirement <=25

=SI(I44>25;F59-(F59*0.02*(I44-25));I44)

eric


Raymond PENTIER Messages postés 58546 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 21 juillet 2024 17 148
17 juin 2024 à 23:58

... et on peut encore simplifier :

=SI(I44>25;F59-F59*0.02*(I44-25);I44)
et même
=SI(I44>25;F59(1-0.02*(I44-25));I44)
1
eriiic Messages postés 24585 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 27 juin 2024 7 227 > Raymond PENTIER Messages postés 58546 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 21 juillet 2024
18 juin 2024 à 18:19

te foules pas, on peut s'assoir sur un merci... ;-)

0
enyx210 Messages postés 2 Date d'inscription dimanche 16 juin 2024 Statut Membre Dernière intervention 18 juin 2024
18 juin 2024 à 18:55

J ai testé vos idées et elle fonctionne, je vous remercie pour votre aide.

Merci