Formulaire excel

Calibri - 14 mai 2024 à 12:21
Raymond PENTIER Messages postés 58486 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 8 juin 2024 - 14 mai 2024 à 18:46

Bonjour, 

je souhaite soustraire des colonnes entre elles pour obtenir un solde. Plus le résultat des soustractions se rapprochent de zéro mieux c'est. Mon problème est que des fois la soustraction est 0-0 et alors cela fausse mon résultat. Je souhaiterai donc avoir une formule de soustractions mais avec l'exception que si le calcul est 0-0 alors le résultat est "NUL" et non "0".

Merci 

A voir également:

3 réponses

brucine Messages postés 15010 Date d'inscription lundi 22 février 2021 Statut Membre Dernière intervention 8 juin 2024 1 961
14 mai 2024 à 12:27

Bonjour,

Outre que la question n'est pas dans la bonne question, précise, je n'ai rien compris.

On ne soustrait pas des colonnes mais des cellules, et à supposer que l'on fasse une formule pour dire que 0-0 vaut NUL, c'est du texte, pas un nombre, tu ne pourras plus faire des opérations sur la colonne, tu vas en faire quoi?

0
ccm81 Messages postés 10862 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 30 mai 2024 2 408
14 mai 2024 à 17:41

Bonjour

Peut être quelque chose comme ça (à tirer vers le bas) ?

=SI(ET(A2=0;B2=0);"NUL";A2-B2)

Cdlmnt

0
Raymond PENTIER Messages postés 58486 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 8 juin 2024 17 127
14 mai 2024 à 18:46

Bonjour.

Je te dirai comme brucine : Je ne comprends pas ta question "je souhaite soustraire des colonnes entre elles pour obtenir un solde. Plus le résultat des soustractions se rapprochent de zéro mieux c'est"


0